SOLVED Can't logon after Imaging / SQL service dead

  • I had this problem this morning and wanted to put it up here so it could be found in a search by someone else having the same issue.

    I set a load of imaging going late last night, came in this morning and couldn’t login to the fog server. It came up with the initialise schema screen you get on install.

    I checked the SQL service, and got this

    xxxx@fog:~$ systemctl status mysql.service
    ● mysql.service - MySQL Community Server
    Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: en
    Active: activating (start-post) (Result: exit-code) since Wed 2018-05-16 08:0
    Process: 3696 ExecStart=/usr/sbin/mysqld (code=exited, status=1/FAILURE)
    Process: 3688 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exit
    Main PID: 3696 (code=exited, status=1/FAILURE); : 3697 (mysql-systemd-s
    Tasks: 2
    Memory: 336.0K
    CPU: 319ms
    CGroup: /system.slice/mysql.service
    ├─3697 /bin/bash /usr/share/mysql/mysql-systemd-start post
    └─3904 sleep 1

    SQL wasn’t loading. A bit of Google, and I checked disk capacity and the disk was full.
    I have a SSD array and wanted the OS protected as well as the images, hence why they are on the same disk.
    All I did was to delete an image, releasing space, reboot the server, and all’s well.

    If you have this, I hop this helps. Please mark this as solved