• Running into an issue with newer Dell systems.

    Here is what goes through at the moment. Complete image, laptop reboots, boots to hard drive and boot loops with REFIND. Try removing PXE boot from the equation and then no boot device found. These laptops are UEFI only and are unable to boot Legacy. I have our DHCP server configured to allow UEFI imaging and booting but I am at a loss at how to resolve this issue.

    Currently the BIOS is set as follows. Secure Boot - disabled. Legacy ROMS Enabled and Legacy Boot Enabled.

    Any ideas?

    For UEFI server options, 066 is server address and 067 is ipxe.efi

  • @quinniedid Sure!

    Base steps were I created a new image in GPT format.

    Afterwards, on the FOG server itself I edited the config file located at /var/www/fog/service/ipxe/refind.conf

    Below are what I have the values at. This was after some troubleshooting so some may be back to their default values.

    timeout -1
    scanfor internal,external (I also have both lines commented out at the moment)
    uefi_deep_legacy_scan is uncommented
    scan_delay 5

    From my memory that is all that is changed. After the imaging is completed in UEFI, it will boot straight to the OS instead of pushing itself through FOG and/or rEFInd.

    Hope this works for you!

  • @jemerson93 Would you please provide what you did to resolve this issue?

  • @sebastian-roth Yes, I did.

    As another update, I spent this weekend editing rEFInd’s timeout, scanfor, and a few other settings I found browsing the forums and this morning I have successfully imaged 2 computers with my new UEFI image and did not receive rEFInd pop up at all. After it completed imaging, it booted straight into the OS.

    Safe to say this has been solved. Thank you to everyone for the assistance. It is greatly appreciated!

  • Moderator

    @jemerson93 Have you played with rEFInd’s timeout option yet?

  • Trying to remove the need to hit any key to continue. I know this is technically a different issue now, if I need to open a new post, I understand.

  • @Tom-Elliott
    After some more troubleshooting I am still stuck on trying to skip the REFIND screen. I will have some screenshots below. I’ve attempted to remove all scanfor BIOS options from refind.conf with no luck. If I enter any key, I can boot to the OS. I’m trying to find how to remove this scan as I’m trying to make the UEFI imaging as automated as the BIOS imaging. Images below…

    After imaging
    0_1526665135492_FOG 1.PNG

    After inputting any key

  • @Wayne-Workman @Tom-Elliott

    As an update, after creating a GPT partitioned image and uploading it to FOG, the image will successfully boot.

    The only issue I have now is that I still receive the REFIND menu. It allows me to boot into the OS afterwards, but each time it boots (unless I disable network boot), it will go into the REFIND menu. Is there a way to either, edit the conf file to not display REFIND or to fix the issue with it not detected a CSM?

    I have not tried other exit types after fixing the image so if this is how REFIND will be, I can re-attempt other exit methods.

    On a side note, thank you to everyone for the assistance. I did not even realize that UEFI used GPT partitions to boot.

  • @tom-elliott Thank you for the clarification. I will finish uploading the image in the morning and post an update.

  • @jemerson93 If the image was captured/deployed to a disk in MBR format, UEFI would indeed not find the drive as the disks MUST be in GPT format.

  • @wayne-workman curiosity question as I was doing some more research. My current image I’m testing is formatted as a MBR partition. I read that UEFI needs to be formatted as GPT to be bootable. I just created a VM (using Proxmox) as UEFI bios and converted it to GPT. Going to upload it to Fog in the am. Think that could deal with the REFIND loop?

  • @wayne-workman I do not notice any errors during capture or deploy.

  • @jemerson93 said in Boot loop after imaging UEFI:

    Believe all laptops being affected are M2 SSD’s. Unsure if they are nvme.

    Then it may be that there is something wrong with the imaging process - it may be that the exit types are working fine but the local disk simply isn’t bootable. Are there any errors during image capture or deploy?

  • @wayne-workman As another update, I’ve tested all exit types and all have failed to boot.

    Exit gives me a chainloading fail
    The rest just keep doing the boot to hard drive in Fog

    I edited the /var/www/html/fog/service/ipxe/refind.conf to scanfor internal,external,hdbios,biosexternal and timeout to 0 per another forum post and still no luck.

    Again, even after imaging, BIOS shows both NIC boots but no other boot device (such as Windows Boot Manager) or a hard drive. Believe all laptops being affected are M2 SSD’s. Unsure if they are nvme.

  • @jemerson93 said in Boot loop after imaging UEFI:

    Anything specific I should look at for creating a UEFI based image?

    Not really, if FOG is capturing it successfully then you’re good to go for that part.

    @george1421 any ideas with the refind loop?

  • @wayne-workman That could be a big issue though. I am creating my images via a VM. Anything specific I should look at for creating a UEFI based image?

    I did do CTRL ALT DELETE to test each exit so I can power off and go from there.

  • @jemerson93 said in Boot loop after imaging UEFI:

    I don’t have separate images for Legacy/UEFI. Should I create a specific image a certain way for only UEFI machines?

    You absolutely need an image for Legacy and an image for UEFI. One does not work on the other.
    Have you tried every exit type individually? Are you fully turning off the system between each try? A simple ctrl+alt+delete does not clear the firmware memory properly and will botch a retry of a different exit type.

  • @wayne-workman Update: Also happening on Dell Latitude 7480s. Only support UEFI. Below is how this one was imaged

    UEFI Network Stack enabled
    Secure Boot disabled
    SATA changed to ACHI

    Stuck in REFIND loop. If exit type is changed, receiving a chainloading fail.

    Earlier I tested an old workstation set to Legacy and imaged fine. Still thinking it’s an issue with UEFI or my image.

    Currently I have 1 master image being used (split off into multiple smaller images). Sysprep it and upload to Fog. I don’t have separate images for Legacy/UEFI. Should I create a specific image a certain way for only UEFI machines?

  • @wayne-workman Currently the issue is residing on Dell Latitude 5590s. Received a few new ones to deploy and all are experiencing this issue.

  • @jemerson93 It sounds like your DHCP is working correctly - your problem is with the exit modes. What exact models of systems are you having these problems on?