Install FOG 1.5.2 on ubuntu 18.04 : checking package curl failed!



  • Hello,

    I tested Fog 1.5.2 on ubuntu 18.04 LTS.

    Impossible to continue installation, the setup stop after this failed.

    * Installing package: apache2.................................OK
     * Skipping package:   bc......................................(Already Installed)
     * Skipping package:   build-essential.........................(Already Installed)
     * Skipping package:   cpp.....................................(Already Installed)
     * Installing package: curl....................................OK
     * Skipping package:   g++.....................................(Already Installed)
     * Skipping package:   gawk....................................(Already Installed)
     * Skipping package:   gcc.....................................(Already Installed)
     * Skipping package:   genisoimage.............................(Already Installed)
     * Skipping package:   gettext.................................(Already Installed)
     * Skipping package:   gzip....................................(Already Installed)
     * Skipping package:   htmldoc.................................(Already Installed)
     * Skipping package:   isolinux................................(Already Installed)
     * Skipping package:   lftp....................................(Already Installed)
     * Installing package: libapache2-mod-php7.1...................OK
     * Skipping package:   libc6...................................(Already Installed)
     * Installing package: libcurl3................................OK
     * Skipping package:   liblzma-dev.............................(Already Installed)
     * Skipping package:   m4......................................(Already Installed)
     * Skipping package:   mysql-client............................(Already Installed)
     * Skipping package:   mysql-server............................(Already Installed)
     * Skipping package:   net-tools...............................(Already Installed)
     * Skipping package:   nfs-kernel-server.......................(Already Installed)
     * Skipping package:   openssh-server..........................(Already Installed)
     * Installing package: php7.1..................................OK
     * Installing package: php7.1-bcmath...........................OK
     * Skipping package:   php7.1-cli..............................(Already Installed)
     * Installing package: php7.1-curl.............................OK
     * Installing package: php7.1-fpm..............................OK
     * Installing package: php7.1-gd...............................OK
     * Skipping package:   php7.1-json.............................(Already Installed)
     * Installing package: php7.1-ldap.............................OK
     * Installing package: php7.1-mbstring.........................OK
     * Installing package: php7.1-mcrypt...........................OK
     * Installing package: php7.1-mysql............................OK
     * Skipping package:   php7.1-mysql............................(Already Installed)
     * Installing package: php-gettext.............................OK
     * Skipping package: sysv-rc-conf..............................(Does not exist)
     * Skipping package:   tar.....................................(Already Installed)
     * Skipping package:   tftpd-hpa...............................(Already Installed)
     * Skipping package:   tftp-hpa................................(Already Installed)
     * Skipping package:   unzip...................................(Already Installed)
     * Skipping package:   vsftpd..................................(Already Installed)
     * Skipping package:   wget....................................(Already Installed)
     * Skipping package:   xinetd..................................(Already Installed)
     * Skipping package:   zlib1g..................................(Already Installed)
     * Updating packages as needed.................................OK
    
     * Confirming package installation
    
     * Checking package: apache2...................................OK
     * Checking package: bc........................................OK
     * Checking package: build-essential...........................OK
     * Checking package: cpp.......................................OK
     * Checking package: curl......................................Failed!
    

    What is the problem and solution ? thanks.


  • Senior Developer

    @fmaster007 the … translates to the path of your fog installer, not the path on Linux of /lib



  • @ggg Hello there, I do not see that path on my end. see image attachment, please. 0_1526665741768_57d45f31-ce6d-4f17-a660-6e5b16c93538-image.png


  • Senior Developer

    @andythemayor still waiting a bit more information on a few other bugs that were reported. If you’d like to test things as well checkout the working branch and install.



  • @tom-elliott any ETA on push?



  • This post is deleted!

  • Senior Developer

    @mike-fahey this is already fixed and will be available for the 1.5.3 push.



  • @tom-elliott
    I have exact same problem. Brand new Ubuntu 18.04 install.

    in the error log from fog install.

    Some packages can not be installed. This can mean
    that you asked for the impossible, or, if you use
    the unstable distribution, that some packages have not yet
    were created or did not come out of Incoming.
    The following information should help you resolve the situation:

    The following packages contain unmet dependencies:
    libcurl3: Is in conflict with: libcurl4 but 7.58.0-2ubuntu3 will need to be installed
    libcurl4: Is in conflict with: libcurl3 but 7.58.0-2ubuntu2 will need to be installed



  • So even though this was a great fix – what would you oh great FOG gurus say about officially giving the green light to deploy FOG on 18.04 LTS?

    Is it ok or should we still deploy FOG on 16.04 LTS until 18 is fully vetted?

    Thanks
    ~B



  • @ggg Apologies, this was an upgrade for me from Fog version 1.5.0 to 1.5.2 after upgrading from Ununtu Server 16.04 LTS to Ununtu Server 18.04 LTS. So, for me, in addition to the fix suggested by ggg, I also had to change libcurl3 to libcurl 4 in /opt/fog/.fogsettings. Perhaps this information will be useful to Tom for future build, as well as other users.



  • @tom-elliott Yes, Tom, it’s specific to Ubuntu Server 18.04 LTS.



  • @ggg great ! it works ! just replace libcurl3 by libcurl4 on config.sh, my installation is done and it work to test. thank !



  • replace libcurl3 in …/lib/ubuntu/config.sh ( /path/to/fogprojec/install/lib/ubuntu/config.sh) with libcurl4 and it will work


  • Senior Developer

    @diggy and it’s specific to Ubuntu 18.04 correct?



  • I’ve run into the same problem, and see the same error as xybar (conflict with libcurl3 and libcurl4).



  • This post is deleted!


  • I looked in the error log, actually there is a conflict with libcurl3 and libcurl4.

    Some packages can not be installed. This can mean
    that you asked for the impossible, or, if you use
    the unstable distribution, that some packages have not yet
    were created or did not come out of Incoming.
    The following information should help you resolve the situation:
    
    The following packages contain unmet dependencies:
      libcurl3: Is in conflict with: libcurl4 but 7.58.0-2ubuntu3 will need to be installed
      libcurl4: Is in conflict with: libcurl3 but 7.58.0-2ubuntu2 will need to be installed
    

    to be continued.


  • Senior Developer

    18.04 is a pretty release so I don’t have any information about it. That said the installer error log could be useful. It would be in the error_logs folder of your fog installer bin folder. E.g /path/to/fogprojec/install/bin/error_logs


Log in to reply
 

447
Online

6.2k
Users

13.6k
Topics

128.0k
Posts