SOLVED No DHCP Response on Eth0

  • Hi All,

    So I am setting up fog on an isolated network here at my office at work. I am using an old dell server and an old cisco switch. I have fog set up on with no router, no dns and letting fog use DHCP.
    My Web interface opens great, I plug in another computer through the switch and get a IP so I know my server is giving out IP addresses, I can connect to the fog management console through on both PC’s also.

    However, once I boot to pxe I get the fog screen, I click deploy image, click the image I created within the fog management console, and then I get this error message. 0_1518475282157_Fog Issue.JPG

    The sever I am using has 4 network ports on it and I am using the first one, or ENO1. It looks to me like fog is only trying to scan for eth0 instead of everything including eno. How can I fix this to where it’s sees the eno1 and the image can pull from the pc to the sever, and vice versa (pulling an image)

  • Moderator

    @bartont126 I’m glad you have it all worked out. I checked in on the other threads and it looks like you found out about the dirty bits and shutting windows down properly and how to add additional storage to your fog server. well done.

  • @george1421 Thanks for all your help, boss! My boss also appreciates it

  • @george1421 I actually just posted another thread as that’s what I thought the moderator wanted me to do. however, I will look into these few things and look for your thread on adding more space. My networking guy is taking a look into the rstp on the switch so hopefully we can get this enterprise switch up and going to increase our speeds.

  • Moderator

    @bartont126 If you are getting 3GB/min right now that is acceptable. I may have your thread mixed up with another one with a similar issue.

    Adding a second hard drive is a topic for another thread. But there are a few ways to go about it.

    1. If your system uses lvm, just add the new disk to the lvm pool and your done.
    2. Add the new disk as a second storage node on your fog server
    3. Mount the new disk over /images to place all of your images on the new disk while the original disk is just used for the OS and FOG.

    If you look in the tutorial section of the forums you will see many of my posts, some discuss adding additional space to your fog server. The easiest I my say is the LVM route.

  • Senior Developer

    @bartont126 Great to hear you got most of your issues solved. Thanks to George who’s been of great help. I’d ask you to try and keep topics together in one thread and separate unrelated issues in different threads. There is no restriction on how many threads you open and it’s way better for everyone to follow!

    I’ll mark this solved now.

  • @george1421 So stp mode needs to be changed to rstp or whatever to fix the spanning issue? I’m using some cheap tenda switch I’m getting around 3gb/sec right now. Obviously the enterprise switch would be ideal. I’m definitely going to run into an issue with space. my Ubuntu is imaged on a patrician of only around 150gb. I have about 70gb of free space left on it. I have another drive on the server with 1.7tb of space. is there a way for me to direct the images folder to another drive on the server to maximize my space without having to re set up the whole sever?

  • Moderator

    @bartont126 well now don’t forget your original issue with spanning tree. Make sure you get that bit fixed on your enterprise switch so you get the best deployment times. Ideal times for deployment are around 6GB/min according to the partclone screen. Capture times will be less of course. Less rates to just under 2GB/min are typically seen, but 6GB/min is ideal with a typical SSD dual or quad core target computer. I have seen speeds as high as 10GB/min with a new 7280 and 7285 Dell laptop with nvme drives. Just so you are aware the target computer has a bigger impact on deployment speeds than the FOG server.

  • @george1421 George, looks like it was the firewall the whole time. It’s now copying the image.

  • @george1421 I just disabled the firewall. Trying to enable Selinux right now and set to permissive. Running Ubuntu desktop 16.04.3

  • Moderator

    What OS did you use for the FOG server?

  • @george1421 ls -la /images/dev

    total 16
    drwxrwxrwx 4 fog root 4096 Feb 12 19:06 .
    drwxrwxrwx 4 fog root 4096 Feb 12 16:06 …
    drwxrwxrwx 2 root root 4096 Feb 12 19:06 54e1adc29063
    -rwxrwxrwx 1 fog root 0 Feb 12 16:06 .mntcheck
    drwxrwxrwx 2 fog root 4096 Feb 12 16:06 postinitscripts

    ls -la /images

    total 16
    drwxrwxrwx 4 fog root 4096 Feb 12 16:06 .
    drwxr-xr-x 27 root root 4096 Feb 12 16:30 …
    drwxrwxrwx 4 fog root 4096 Feb 12 19:06 dev
    -rwxrwxrwx 1 fog root 0 Feb 12 16:06 .mntcheck
    drwxrwxrwx 2 fog root 4096 Feb 12 16:06 postdownloadscripts

    I also did not disable the firewall and setting selinux. I’m unsure of how to do that so I will look it up.

  • Moderator

    @bartont126 can you also run these commands? (hint if you connect to your FOG server using a terminal program like putty you can copy and paste outputs a bit easier).

    ls -la /images/dev
    ls -la /images

  • Moderator

    @bartont126 those settings are correct. You have 2 shares. /images and /images/dev. (I assume the missing slash in front of /images was a type-o).

    I’m still a bit confused why your target computer is reporting “Unable to locate image store”. Did you do the prerequisites of disabling the firewall and setting selinux to permissive?

  • @bartont126 Any ideas what might be causing the issue from the showmount -e?

  • @george1421 Hi George. I did the showmont -e and the two lines i’m getting says

    Export List for
    /images/dev/ *
    images *

  • @george1421 No worries. I just got home from work. I will give this a shot in the morning and respond with my findings. Thank you George!

  • Moderator

    @bartont126 ok on the FOG server, will you key in the following command showmount -e That will show the NFS share on the fog server. It should present two lines one for /images and one for /images/dev I’m traveling right now so I don’t have immediate access to a fog server to give you an example.

  • @george1421 Kernel Variables and settings:
    bzImage Loglevel=4 initrd=init.xz root=/dev/ram0 rw ramdisk_size=127000 web= consoleblank =0 rootfstype=ext4 mac=54:e1:type=up

  • @george1421 Try this. Sorry it’s always sideways. It’s straight on my computer until I upload it. 0_1518481254065_Long Error.JPG