Unable to upload image from VMware Win7 box

  • I’ve built a brand new Win7 x64 box in VMware to use as my new base image. I have the HDD type set to IDE in VMware Workstation, and have Win7 prepped and ready to go.

    The problem is when I go to upload the image, I get to the blue “Please wait” screen, and then it scrolls up with what looks like an error below (scrolls way too fast to read), and then FOG continues to reboot the VM as though the image was completed.

    Has anyone else run into this problem before? Maybe there’s a VMware setting I’m missing?

  • So after I uploaded one of my existing images successfully, I made a new image and uploaded the contents of the VM to it.

    Now it works. One thing I noticed is FOG can see two partitions rather than just one which is all it was seeing before. I’m not sure FOG can only see one partition on the disk I was using previously. I didn’t do anything different to prep it this time.

  • Uploading to my old images works, which leads me to wonder where the information for each image is kept (other than the image itself)?

  • I checked the fog script. Everything looks good to me.

    I’m going to try imaging the VM using one of the images I already have, and then writing the image back to FOG and see what happens.

  • Moderator

    Search wiki for help modifying init.gz file.

  • Maybe I’m just being a n00b, but there are no subdirectories in my ./bin/. Is that where I should be looking for this script?

  • Moderator

    I don’t know if it’s the true cause of your issue since your other Windows 7, Single Partition - Resizable seem to work right? But in the init.gz, in the /bin/fog script, there is a line that seems to double up on the path, so you get /images//images/[mac-address].

    More than likely this isn’t what’s killing your upload, since the code would execute for all Windows 7, Single Partition - Resizable images.

    You might try chkdsk with the full repair/fix options to see if there is something wrong with the filesystem. Other than that, just use the multiple-partition, single disk image type for Windows 7. It’s a simpler code path and less prone to issues.

  • Thanks so much for your help, chad!

    Ok, so it does work when the image is set to Multiple Partition - Single Disk. I tried changing it back to Single Partition - Resizable and the error comes back.

    Is there a config file that needs to be edited somewhere?

  • Moderator

    Are your other Windows 7 images also of type Single Partition - Resizable? It appears that FOG executes the same chmod command for all Windows 7 Single Partition Resizable images, regardless of the number of partitions (1 or 2). Maybe there is something keeping this image from uploading correctly and the chmod failure is just a false clue.

    Try changing the type to Multiple Parition - Single Disk. It will still compress the image, you just have to restore to an HD of the same size or larger, and since VMWare default disk size is like 60GB, you shouldn’t have an issue with that.

  • Before the error everything looks normal. The resize test runs successfully, the partition is resized, the disks are allowed to settle, and then the blue screen comes up with the “Please wait” message. That sticks around for 3-4 seconds and right underneath the error appears and it all quickly scrolls off the screen.

    Then, FOG continues as though there was no error. The MBR is restored, disks are settled again, partition size restored, and then the system begins the reboot process.

  • Moderator

    Can you tell what happens before the error and the reboot? I’m tracking down chmod calls in FOG, but there are several different times it’s called when doing a windows 7 image upload for single partition resizable.

  • Single partition resizable.

  • Moderator

    What image type? Single disk resizable, multiple partitions-single disk, or multiple partitions, all disks?

  • Moderator

    Looks normal.

  • Here you are:


    Created by FOG Imaging System

    DEFAULT send
    LABEL send
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= type=up img=Win764BitStandardV2 imgid=11 mac=00:0c:29:8e:f7:2a storage= web= ignorepg=1 osid=5 pct=5 imgType=n shutdown= loglevel=4 consoleblank=0 fdrive= chkdsk=0

  • Moderator

    Grab the task file from /tftpboot/pxelinux.cfg/01-[mac-address] and post it here. Use CODE tags please so we don’t have to guess what the smilies mean.

  • Just tried it. Same issue. 😞

  • Moderator

    During an upload, it should be going to /images/dev/[mac-address], not /images//images/[mac-address].

    Kill the task, make sure the task file is removed from /tftpboot/pxelinux.cfg. Try to start the upload task again and see if it does the same thing.

  • I checked, and it is set to “Win764BitStandardV2”, just like the other working images (the other images have different names of course).

    The name of the image is entirely different from what the error states. The file name it’s looking for appears to be the MAC address of the VM, where the image file name I have it set to in the FOG GUI is “Win764BitStandardV2”.

  • Moderator

    Check your image definition. Sounds like you set the location as /images/something instead of just “something”