Dell 3010 Not Compatible



  • Hi Guys,

    Love the concept of FOG having used ghost in the past to multicast the interface / setup is awesome. I’m struggling to get FOG to work with PXE on Dell Optiplex 3010 systems that I’m trying to roll out. I’ve tried also using 3rd party PXE boot image but still no joy, system will either not get an IP or boots then falls over. Reading the forums it appears that others are having the same issue with Realtek 8168’s (dell integrated NIC)., some suggestions of changing Fog Kernel (I’ve not tried this) but I’m running out of time and not being great with Linux feeling a bit stuck! Also tried a pause resume during DHCP discover but Fog still appears to fall over.

    Any suggestions or ideas would be greatly appreciated, I know that Fogs working 100% as it fires up in on my Vaio laptop no problem.

    Tim,



  • Works great on proxmox 3.0 (ubuntu 12.04) :D
    Successful upload and download Dell 3010 image :cool:


  • group:cid:13:privileges:mods:members

    Does the the machine stop at this point? Every model of our Dell’s had that error message and never affected the imaging process. We run Dell Optiplex 745, 755, 760, 780, 790, 7010 and Latitudes E6400, E6410, E6420, and E6430’s. We run kernel 3.6.9 and have had no problems with imaging.



    1. download bzImage.c600.nonv.rar
    2. unrar
    3. copy to fog kernel dir
    4. edit pxelinux.cfg/default
    5. edit fog [FONT=Ubuntu][COLOR=#333333]FOG_TFTP_PXE_KERNEL[/COLOR][/FONT]
      [FONT=Ubuntu][COLOR=#333333]6. reboot fog server[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#333333]PXE load [/COLOR][/FONT]bzImage.c600.nonv
    and…
    Error unknown (unsupported) BIOS version Dell Inc./OptiPlex 3010/A09 Aborting

    :(

    @x23piracy, Thanks for Your help, greetings from Poland.



  • Hi,

    try a newer kernel:
    Start here: [url]http://fogproject.org/forum/threads/hard-disk-not-found-lenovo.4159/page-2#post-12491[/url]
    don’t be confused of the thread title.

    It’s based on linux kernel 3.9.4 instead of older 3.8.8

    Greetz X23



  • [FONT=Ubuntu][COLOR=#333333]Kernel - 3.8.8 Core[/COLOR][/FONT]
    Error unknown (unsupported) BIOS version Dell Inc./OptiPlex 3010/A09 Aborting
    :(



  • Does anyone find a solution for this problem because we are about to purchase 120 PCs of optiplex 3010 and [I] need to know whether it works with fog or not [/I]



  • Hi,

    I just received a brand new Optiplex 3010 (Manufactured on 15/12/2012 with Bios A5 (bios date 18/09/2012)) of an other department and it looks like it works fine for me. I’m getting the “unsupported bios, please report” message but the imaging works.

    After a successful upload and download of the default dell image (Windows 7 Pro 64 bit) I did a hardware inventory.
    This works fine as well.

    I’m using a testing setup: live cd of pfsense 1.2 and newly installed fog 0.32 on ubuntu 12.04 (enabled the DHCP option) without changing the network card booting settings in Linux.

    So if it depends on me the Optiplex 3010 can be added to the list of working devices.

    Greetings,
    Johan



  • Johan. Yes, after the change the 390’s work. I am not sure about 3010, since I do not have any of the them to test out. However, since they look like they have the same network card, hopefully they will work.



  • Hey,
    Tx for the reply. I have 18 Optiplex 390 as well and that works fine for me after making the changes.
    I had contact with my Dell account manager and at the end of Januari (I’m waiting until the construction of our new school building is finished) I will ask for a test system so then I will be able to confirm if it works.

    Greetings,
    Johan



  • Hey guys…I noticed that the 3010 has the same network card as the dell op 390. I was able to get the 390 to work, but only after enabling chainloading on the fog server. Here is a link to a fog wiki page that talks about this fix. I do not know if it fixes the 3010, but it did work on the 390.

    [url]http://www.fogproject.org/wiki/index.php?title=FIX:_Chainloading_alternate_SYSLINUX_to_force_boot_from_first_hard_drive[/url]



  • Hi There,

    Did you find a solution. We did buy several Dell optiplex 3010 systems and would like to image them as well. We can PXE boot but when we try to image the PC we recieve an error unknown (unsupported) BIOS version Dell Inc./OptiPlex 3010/A05 Aborting.

    I hope that someone did find a solution

    gr

    Henk



  • Timmay did you try compiling a KitchenSink of the newest Linux kernel (3.6 branch), and see if it supports your NIC?

    I do not have a 3010 to test on unfortunately.
    [url]http://fogproject.org/wiki/index.php?title=Building_a_Custom_Kernel[/url]
    Swap the wget line with a different kernel from kernel.org , such as one of these(the below link with show the 3.x kernel source code , listing the last updated kernel first):
    [url]http://www.kernel.org/pub/linux/kernel/v3.x/?P=linux-3.*.gz&C=M&O=D[/url]



  • Hi Johan,

    I tried for very long time to get it to work on 3010’s without any joy (tried multiple karnels / boot disks etc).

    Regards

    Tim,



  • Hi Guys,

    I’m planning of buying 18 Optiplex 3010 for our school. We are using Fog for a few year now so first I want to make sure that Fog is working on the devices. Can anyone give me an update if Fog is working on the Dell Optiplex 3010?

    Tx,
    Johan



  • Tried Kernel 3.3.3 and its saying that BIOS A02 is unknown and falls over before image creation starts although it allowed me to register the host.

    I also tried 3.3 but it fails to boot and just times out.

    Any other Kernel suggestions??

    Reports PXE 2.5 during boot



  • This post is deleted!


  • Thanks for reply, I have FOG setup as a stand alone unit so I can’t select the kernels without being online through the web gui.
    Is their another way of changing Kernel and any suggest to which I should try or any guides in doing this?



  • From the sounds of it your having a kernel problem. The kernel holds all the drivers FOG uses during the PXE boot. Updating the kernel is easy from the web gui. Other information -> then kernel updates and try one of the kernels. There have been a couple of posts with custom kernels built to handle Dells. If you can’t find one I have one on my production FOG server that might work.


Log in to reply
 

359
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.