TFTP fails on PXE boot CentOS 7



  • I just switched from Ubuntu Server to CentOS 7 for my FOG servers. I am unable to get PXE boot working. It has to be something with the OS because that is all that has changed. Same IP address and same options 66 and 67 booting to undionly.kpxe. At this stage when I was learning how to properly setup FOG using Ubuntu Server I was able to test the TFTP by using the windows built in client and obtain the pxe file. Now it just says “Connect request failed”. I have the CentOS firewall turned off completely. Anybody know why I wouldn’t be able to get the pxe file through TFTP?



  • Fixed it. Found this little bit on another post and it did the trick for me:

    Also. please validate if selinux is in permissive or disabled mode.

    You can verify by running:

    sestatus

    If you notice it says enforcing still, run:

    setenforce 0

     -  From Tom Elliot

Log in to reply
 

418
Online

39.8k
Users

11.2k
Topics

106.8k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.