Super newbie guide for creating image to w10?

  • hello! im new at FOG and PXE, I read a lot of sites but I couldn’t make a w10 iso to install over pxe…

    Is there some guide where I can make my custom winpe image with w10 install? I will add the xml for automated installation too.

    Thanks for the help!

  • @george1421 Stuck at 1º step at the moment…

  • Moderator

    @motto Lets backup and start over.

    Please reset every thing so that we can get you to the message “Press any key to boot from CD or DVD…”

    1. At this message press any key on the keyboard before it boot the local hard drive. This should launch the winpe image you created.
    2. At the end of the booting process it should drop you to a cmd prompt.
    3. Manually map to your win10 network share
    4. Run the setup.exe program.
    5. The Win10 installer should launch
    6. Abort the install.

    If you get to step 6, then we can work on fine tuning the steps. We will know all of the parts work, we just need to improve the flow.

  • @george1421 Sure, no problem

    My only goal here is to get to the w10 installation load, just that, because my linux installation is working and loading.

    I will try the MDT :)

  • Moderator

    @motto I don’t intend to confuse you, but I just remembered I had/have a second way to boot this winpe image that may support uefi booting too. I know it works for bios mode.

    I know this talks about lite touch, but mdt lite touch also uses winpe. I may have to alter the files loaded for winpe10. Please understand I’m still trying to find th ideal way to show people how to do advanced things with fog. I don’t load win10 via dvd any more since I use MDT for reference image deployment, so I haven’t had a “need” to perfect the tutorial.

  • @george1421 maybe that was the problem, I will try it right now :) and with the first menu, wich is the one it is supossed to be.

  • Moderator

    @motto said in Super newbie guide for creating image to w10?:

    If I dont pressed anything or a key, it just boots from the local hard drive, so its like its not doing anything.

    This is normal. There is a file you need to remove from the iso image to skip this “feature”. If you were to burn that iso image to a cd or usb flash disk it would do the same thing. There is a file in the root of the iso image, <something>.bin (as said from an early morning memory). If you remove that from the iso image booting will not stop, it will boot straight to winpe.

    edit: I updated the menu , and now the error is different!

    Um, Unedit the menu. What you had was working correctly.

  • @sebastian-roth Hello! I tried with 2 laptops, one with 8gb, so it cant be the problem :S

  • Developer

    @motto Pictures tell more than a thousand words. The MEMDISK error bootstrap too large to load` to me sounds like that machine doesn’t have enough RAM to load that ISO…

  • @george1421 Hello George, here are my 2 photos.

    The problem is still the same, so im 100% sure that im doing something bad or there is something bad with my config.

    I boot using legacy bios, so I assume that it will be more “easy” to solve than in UEFI mode.

    FIrst, I boot the ipxe and choose my menu entry for w10
    initrd nfs://${fog-ip}:/images/os/mswindows/10Pro/WinPE_amd6411.iso
    chain memdisk iso raw
    boot || goto MENU

    Then, it downloads the iso (I added two 1 at the and of the name for testing)

    After it download, it boots with this message (with your iso and mine)

    If I dont pressed anything or a key, it just boots from the local hard drive, so its like its not doing anything.


    edit: I updated the menu , and now the error is different!

    new menu parameters:
    initrd /images/os/mswindows/10Pro/WinPE_amd6411.iso
    chain memdisk iso raw
    boot || goto MENU


  • Moderator

    @motto Well, it works as documented.

    I can tell you I had more issues with my vm I was using as a test system than the process. I reused a vm from another test that was configured for uefi mode. So there was some things I learned during this process.

    1. While I created a universal bios/uefi boot winpe image, memdisk (what we are using in fog to launch the winpe.iso image) only supports bios mode. I need to look into what needs to be done for uefi booting.
    2. My vm was using a vmxnet3 adapter. The winpe iso didn’t have the required driver for this network adapter. Once I switched the vm to the Intel E1000 network adapter I could pull an IP address.
    3. If you made a mistake in the startnet.cmd file you will still be dropped to a command prompt, where I was manually able to connect to the network share with win10 installed and run setup.exe no problem.

    Just to make sure I didn’t have any legacy stuff from previous test left behind I created the winpe ISO starting on a clean Win10 system. This was a VM just setup by FOG imaging specifically for the purpose to create this iso image.
    I downloaded the Win10 1709 ADK from the MS web site as well as the latest Dell WinPE 10 driver cab files from the dell site. From there I executed the instructions in the script verbatim.

    For my fog menu settings I used tftp transport instead of NFS so I just placed the winpe iso image in the /tftpboot on the server. That has no bearing if winpe works or not, its just a delivery tool. I could have use http or nfs transport just as easily.

    For the win10 image, I downloaded a fresh iso of win10 pro v1709 from the MS Volume Licensing Center and install the files under samba on our dev FOG server running fog 1.4.4.

    So I’m not sure what could be wrong here. Its possible since I use the us english version and you are probably using your native language version of windows there is a compatibility issue ??

  • @george1421 said in Super newbie guide for creating image to w10?:

    @motto That is what I’m going to test. That will give me a chance to make sure everything is correct before launching setup.

    Sure, really apreciated :)

  • Moderator

    @motto That is what I’m going to test. That will give me a chance to make sure everything is correct before launching setup.

  • @george1421 So, for my understanding, I need to redo the iso but in the .bat I dont add the “setup.exe” line, right?

    edit: interesting thing, I tried to force an ubuntu.iso (modifying the iso to load) and I get the same response, “press any key blabla” so maybe, even it is downloading the iso, is not executing it or something!!

    My parameters:
    initrd nfs://${fog-ip}:/images/os/mswindows/10Pro/WinPE_amd64.iso
    chain memdisk iso raw
    boot || goto MENU

  • Moderator

    @motto What I’m thinking is that in WinPE if you do not add in the steps for launching setup.exe directly, but do let it connect to the share, winpe should give you a command prompt at the end of the booting process. From there you should be able to inspect the z: drive and manually start the install process as a test. That is what I think I will do so I can be sure where the system breaks.

  • @george1421 Sure! I can make you a video so you can check what’s going on for further investigation if you want.

    The PXE computer is downloading my winpe iso from the pxe server, then trying to boot it, then failing.

    I really appreciate if you redo the w10 setup , really!!! :D

    ps. If I can contact you via email or something (and you want) pls let me know !

  • Moderator

    @motto Interesting, it should not boot from the local hard drive at all since you are booting into WinPE. Let me see if I can setup this design again with Win10. I might have missed something in the documents, but I don’t think so. I will use the MS VLK media for win10 1709 for testing.

  • @george1421 Hello again !

    Im using ubuntu 16 as server, but dont worry, I’ve setup samba OK (I can access from my w10 virtual machine with user and password)

    my problem now is that when I pxe in the laptop to be installed, I can access the ISO, it downloads, then “press any key” and when I press it, it just boot from hard drive (same problem has yesterday)

    But the commands are OK because I’ve tested it, and I think that the bat file is in the iso (how can I check it?)

    any suggestions please? thanks!!

    Im thinking that the problem is on my ISO file, wich is not loading properly, and thats why I get a black screen (its not even starting the .bat file to connect to samba share, and I cant even see the windows GUI, but it downloads the iso…)

    I make the w10 iso as suggested in your tutorial, and I load my winpe_x64.iso over pxe… but fails…

  • Moderator

    @motto OK well done then.

    Just so you know there is a samba setup guide at the bottom of the tutorial that tells you what is required. If the guide is not accurate for your distribution, please let me know what is needed and I’ll update my guide.

  • @george1421 Oh, ok ! So it’s just pointing to the setup.exe I had in the server.

    I’ll check the route, because if I click the setup.exe from a windows machine (accessing via samba) it works , so there is something bad with my connection for sure!

    Maybe because I have no user access or something, ill figure out


Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.