• Senior Developer

    @mwarner In that PCAP I only see three TFTP packets. No DHCP packets at all. Probably your network structured in a way that we don’t see the DHCP broadcasts and answers at all. Can you connect a dumb network hub in front of your Surface client and use another PC to capture the network traffic there. You can even use the GUI version called Wireshark if you like.


  • @george1421 Awesome! I’ll be interested to see what you can pull off and if it will help with our case. Unfortunately our docks aren’t USB-C though. We have the Surface Pro 4’s (2-in-1 device) that have a proprietary plug for the dock connection. It’s definitely not USB. Probably why USB NIC option isn’t working.

  • Moderator

    @mwarner Whelp, I just found out our company owner just purchased a surface book with an external usb-c dock (I think). So I may have one of those to play with in the coming days. I also think it was a bundle from CDW (FWIW).

    If I can’t get it to work, we may just pickup a sub dongle like @Avaryan mentioned just for our imaging bench. It may be worth it to not have to mess around too much just to get it imaged (considering FTE wages spent during the debugging process).


  • @avaryan said in Microsoft Surface Pro 4:

    Are you willing to purchase a different USB NIC?

    Unfortunately not, we have already purchased the full blown docks for our supply of surface pro 4s in a bundle from CDW.


  • @mwarner said in Microsoft Surface Pro 4:

    @sebastian-roth Here is the link to a .pcap file of the surface in question trying to connect. The surface itself loads the FOG menu properly and successfully, as shown by the .pcap, but when I selected the “Perform Full Host Registration” option it seems to recognize that there’s an error with the ethernet connection. Perhaps you could provide some more insight?

    Are you willing to purchase a different USB NIC?

    The Microsoft Surface dongle model# 1663 has been confirmed to work. Alot of the other docks/usb nics don’t work.


  • @sebastian-roth Here is the link to a .pcap file of the surface in question trying to connect. The surface itself loads the FOG menu properly and successfully, as shown by the .pcap, but when I selected the “Perform Full Host Registration” option it seems to recognize that there’s an error with the ethernet connection. Perhaps you could provide some more insight?

  • Senior Developer

    @mwarner Read through all the posts on this topic and see if you find something:

    https://forums.fogproject.org/topic/9894/surface-pro-4 (NIC in USB HUB issue)
    https://forums.fogproject.org/topic/9704/surface-3-unable-to-obtain-dhcp (great discussion with detailed instructions)
    https://wiki.fogproject.org/wiki/index.php?title=Surface_Pro (long list of Surface threads)

    Other than that I’d say we need more information on the network packets, see here and post a link to an uploaded PCAP file so we can check it out.


  • @sebastian-roth Also I’m now testing with v1.5.0-RC-10 and ipxe.efi.


  • @sebastian-roth I tried using a Netgear GS308 per your suggestion of using a mini switch and it did not work (with or without has_usb_nic=1)

  • Senior Developer

    @mwarner Please find a mini switch or old hub to connect between the client and your main network (switch). Has worked for a lot of people in many different situations. If it does we can start elaborating on what exactly the issue is.


  • @Sebastian-Roth Yes, I’ve tried to unplug and replug the dock connector in multiple times and every time it ends up with the same failure to get a DHCP address.

  • Senior Developer

    @mwarner said:

    I’ve only had success (with all devices on my network) with ipxe7156.efi

    Be warned - we removed ipxe7156.efi in the RC (and upcoming) versions because the issue has been fixed in iPXE and we use the very latest code. So be prepared to move back to ipxe.efi when upgrading to the RC version.

  • Senior Developer

    @mwarner said:

    I booted into a Linux live disk to see what the device name is given by default on a unix device and it’s set to enxc49dede708d4

    Kind of a good idea but not worth anything in this case. Please don’t get me wrong. Don’t wanna sound rude. Those NIC names are made up by modern Linux distros and are not the actual name. It’s just some kind of naming schema (obviously has the MAC address in it) to try and get names consistent on every reboot. Not nice I find but that’s how they do it.

    I’ve also tried the “has_usb_nic=1” solution but it does not help - I’m using the dock and not a usb NIC so it has it’s own proprietary connection interface that is not a USB.

    I guess the dock is also using some kind of bus system to connect - maybe that even is USB. Anyhow, using the has_usb_nic=1 kernel parameter do you see it wait on bootup? This is meant as a delay so people can re-plug the NIC and then go on. Can you give that a try. Add that kernel parameter, boot it up till you get to the prompt, unplug it from the dock, replug it and hit enter to proceed. Does it work this way?

375
Online

8.8k
Users

15.5k
Topics

144.5k
Posts