DHCP issue PXE-E51



  • Server
    • FOG Version: 1.2.0
    • OS: ubuntu 15.10
    Client
    • Service Version:
    • OS:
    Description

    Okay so I was runnin into an issue with imaging a lenovo e460 with windows 7. After updating the kernel I started getting an error message on every machine I try to reimage. No matter the model. It says an error has been detected and doesn’t really give a whole lot of information. I have tried different models and different images that I used earlier today. When I tried rolling back the bzimage and bzimage32 files that did not help. Only made it worse by giving me a fatal kernel error. Any ideas?


  • Moderator

    I worked with the OP via IM for a bit and we have things working for dhcp. The root cause is the dhcp config file had a wrong subnet scope defined (10.x.x.x) where the fog server was on the 192.168.1.x subnet. Once we got the configuration file fixed the target computers pxe booted without issue. At this point the OP can pxe boot the computers. He has an issue with imported images from FOG 1.2.0, but that is a story for a new thread.



  • @sebastian-roth Okay so I work for a small mobility firm. I came in and they were using Fog to image their machines. I have no experience with this client at all. So when I came in it was not working. So I am not 100% on why things are the way they are I am just trying to figure it out and get it up and running so I can make new images and start from scratch. If I put the fog server on the main network it will cause our techs to not boot properly.0_1504275695489_image1 (1).JPG


  • Developer

    @slashdotpwn Why are the clients in a totally different subnet?


  • Developer

    @slashdotpwn Ahh, wait a second. Looking at the other screenshot I see you have used 192.168.1.1 by intend? Please tell us the IPs you wanna use for your clients and the IP your FOG server has (post a picture of sudo ip a s).



  • @sebastian-roth My fog server is 192.168.1.1


  • Developer

    @slashdotpwn said in DHCP issue PXE-E51:

    next-server 192.168.1.1;

    This doesn’t look right! What IP address does your FOG server have? Edit the dhcpd.conf file and put your FOG server IP there! Then run sudo systemctl restart isc-dhcp-server.service

    EDIT: Ahh, wait a second. Looking at the other screenshot I see you have used 192.168.1.1 by intend? Please tell us the IPs you wanna use for your clients and the IP your FOG server has (post a picture of sudo ip a s).



  • status

    ● isc-dhcp-server.service - ISC DHCP IPv4 server
       Loaded: loaded (/lib/systemd/system/isc-dhcp-server.service; enabled; vendor
       Active: active (running) since Thu 2017-08-31 16:42:07 EDT; 16h ago
         Docs: man:dhcpd(8)
     Main PID: 6908 (dhcpd)
       CGroup: /system.slice/isc-dhcp-server.service
               └─6908 dhcpd -user dhcpd -group dhcpd -f -4 -pf /run/dhcp-server/dhcp
    
    Sep 01 09:06:45 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:08:19 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:10:39 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:15:01 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:16:09 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:25:01 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:26:50 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:32:18 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:33:34 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    Sep 01 09:35:01 Fogserver dhcpd[6908]: DHCPINFORM from 10.150.18.89 via ens32: n
    lines 1-18/18 (END)
    


  • dhcps.conf

    # DHCP Server Configuration file\n#see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    #Definition of PXE-specific options
    # Code 1: Multicast IP Address of bootfile
    # Code 2: UDP Port that client should monitor for MTFTP Responses
    # Code 3: UDP Port that MTFTP servers are using to listen for MTFTP requests
    # Code 4: Number of seconds a client must listen for activity before trying
    #         to start a new MTFTP transfer
    # Code 5: Number of seconds a client must listen before trying to restart
    #         a MTFTP transfer
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    subnet 10.150.18.0 netmask 255.255.255.0{
        option subnet-mask 255.255.255.0;
        range dynamic-bootp 10.150.18.10 10.150.18.254;
        default-lease-time 21600;
        max-lease-time 43200;
        option routers 192.168.0.1;
        option domain-name-servers 127.0.1.1;
        next-server 192.168.1.1;
        class "Legacy" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
            filename "undionly.kkpxe";
        }
        class "UEFI-32-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-32-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-64-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
            filename "ipxe.efi";
        }
        class "UEFI-64-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
            filename "ipxe.efi";
        }
        class "UEFI-64-3" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
            filename "ipxe.efi";
        }
        class "SURFACE-PRO-4" {
            match if substring(option vendor-class-identifier, 0, 32) = "PXEClient:Arch:00007:UNDI:003016";
            filename "ipxe7156.efi";
        }
        class "Apple-Intel-Netboot" {
            match if substring(option vendor-class-identifier, 0, 14) = "AAPLBSDPC/i386";
            option dhcp-parameter-request-list 1,3,17,43,60;
            if (option dhcp-message-type = 8) {
                option vendor-class-identifier "AAPLBSDPC";
                if (substring(option vendor-encapsulated-options, 0, 3) = 01:01:01) {
                    # BSDP List
                    option vendor-encapsulated-options 01:01:01:04:02:80:00:07:04:81:00:05:2a:09:0D:81:00:05:2a:08:69:50:58:45:2d:46:4f:47;
                    filename "ipxe.efi";
                }
            }
        }
    }
    


  • Okay so I found out that dhcp was turned off. It looks like my dhcpd.conf file is maybe wrong. It looks like it isn’t assigning ip addresses. I am leaving the office for tonight. I will be back in the morning to hopefully figure this out.



  • It isn’t connecting to the internet though. I am setting a static IP and connecting to it that way.


  • Developer

    @slashdotpwn What do you mean by standalone? Don’t you have a router/gateway in your network to access the internet? Just put in this address when the installer asks you for it.



  • When setting up the DHCP. It said no router address found. I am setting it up as a stand alone. What should I put in this case.



  • Okay retrying the install now. Will let you know the results. Thanks for your patience by the way. I am usually pretty good with this kind of stuff.


  • Developer

    @slashdotpwn How do you run the installer? Best if you switch to the proper root account for running it. I’d say, remove the config ands start over:

    sudo su -
    rm /opt/fog/.fogsettings
    cd /dir/where/fog/is
    cd bin
    ./installfog.sh
    


  • Even after changing the fogsettings file it skipped the dhcp setup :(


  • Developer

    @slashdotpwn On the console run sudo chmod 666 /opt/fog/.fogsettings && sudo chmod 777 /opt/fog/ (not nice but should fix this for you!)



  • Okay I was able to use CHOWN to take control and edit the file. Rerunning the installer. Wish me luck.


  • Developer

    @slashdotpwn In Linux files starting with a dot are “hidden”. So you need to use the -a option with ls to actually see it. ls -al /opt/fog/ should show the file!

    In case you want to edit it using a GUI editor you probably need to fiddle with the file explorer options to make it show hidden files.



  • Okay now when I try to run the installer it says a previous version of fog settings is there. When I go to /opt/fog/ I see nothing. 0_1504199996209_image2.JPG 0_1504200012892_image1.JPG


Log in to reply
 

412
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.