Login / Update Buttons not working



  • Server
    • FOG Version: 1.5.0 RC6
    • OS: Ubuntu
    Client
    • Service Version: 0.11.12
    • OS: Windows 7 / 10
    Description

    Some of the “confirmation” buttons don’t do anything. For example:

    Opening the Web Interface via: http://fog.lfdw.local/fog/management/index.php?node=group&sub=membership&id=6 doesnt work - the page just sits there. When I truncate the url to …/fog/management and try it works.

    When trying to add Hosts to a group from the groups membership menu the button “Add” again doesn’t do anything. Haven’t found a workaround yet.

    Tried with both Internet Explorer and Google Chrome. No scripts being blocked in either from the browser side.



  • Great work, thanks :)


  • Senior Developer

    Now that I understand the full scope of the problem, I more clearly was able to take and fix this issue. Login should’ve worked for any page but it was loading page specific js code even when no user was logged in. I have since corrected this in working branch.



  • When I go to:

    http://fog.lfdw.local/fog/management/index.php?node=about&sub=settings
    (this is saved in chrome as a visited link and comes up when I enter fog.lfdw and then autocomplete)
    the login page shows up, but clicking on “Login” doesnt do anything. The page doesnt change.

    If i manually go to http://fog.lfdw.local/fog/management the same login page shows up and clicking on login logs me in and brings me to the dashboard.

    Cleared Cache (Strg+F5 to reload) - same “problem”.

    EDIT: Upgraded to working branch - Version 20, same thing happens.

    EDIT2: This happens from ?node=about and ?node=groups. ?node=host, ?node=image and ?node=storage work fine.


  • Senior Developer

    What do you mean “login” not working? Do you mean simply “update” buttons not working?

    if that’s the case, working branch already has this issue fixed. This issue is only, to my knowledge, present on Group page, which was fixed a few days ago.



  • Workaround for the group thing:

    From “List all Hosts”: selecting and adding Hosts to a group works.


Log in to reply
 

350
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.