Dell 5289 MAC issues



  • Hello,

    Server version is 1.4.4
    Using EFI PXE booting rather than legacy

    I am having issue where using a USB-C dock with NIC in it to image. The problem is that when you register and image the computer it uses a4:4c:c8:aa:9e:c5 MAC, which is fine and they image fine.

    When its done imaging and windows boots, then the dock uses the ‘correct’ MAC d4:81:d7:8a:44:64 that is actually printed on it and is actually associated with the dock and not the laptop, which is its own problem.

    So I thought a solution was to approve the wireless card MAC and let the FOG Client use that MAC to identify and join the domain, the problem is that it doesn’t unless I make it the primary MAC, which then breaks the iPXE part of imaging fog. So I cant have both working.

    So my question is what is the point of the additional MACs if FOG cant use them to identify and perform tasks using other MAC than the primary one? I thought that was the point so that we didn’t end up with ‘duplicate’ clients in FOG.

    I understand that if the MAC is NOT approved it shouldn’t be able to do any functions, however once approved why cant it?

    Thanks,



  • Here is the errors from the FOG client.

    7/14/2017 11:44 AM Service Sleeping for 334 seconds
     7/14/2017 11:49 AM Middleware::Communication URL: http://fogserver/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     7/14/2017 11:49 AM Middleware::Response Success
     7/14/2017 11:49 AM Middleware::Communication URL: http://fogserver/fog/management/index.php?sub=requestClientInfo&mac=F8:59:71:B0:43:44|F8:59:71:B0:43:43|F8:59:71:B0:43:47&newService&json
     7/14/2017 11:49 AM Middleware::Response Invalid host
     7/14/2017 11:49 AM Middleware::Communication URL: http://fogserver/fog/service/getversion.php?clientver&newService&json
     7/14/2017 11:49 AM Middleware::Communication URL: http://fogserver/fog/service/getversion.php?newService&json
    
     7/14/2017 11:49 AM Service Creating user agent cache
     7/14/2017 11:49 AM Middleware::Response Module is disabled globally on the FOG server
     7/14/2017 11:49 AM Middleware::Response No Printers
     7/14/2017 11:49 AM Middleware::Response Module is disabled globally on the FOG server
    

Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.