WOL not working for all hosts in group



  • Server
    • FOG Version: 1.4.4
    • OS: Cent0S 7.3
    Client
    • Service Version:
    • OS: Win10
    Description

    I upgraded from 1.2 to 1.4.4. Now wol for single host works normally. Wol for groups doesn’t. What i found out is that if the group has low number of hosts of no more than 6 then it works even for the groups. But if there is more it doesn’t. Then some computers wake up and some don’t.



  • @Tom-Elliott Thank you for the workaround. It works now, so that will give me the time to look into network issue. Thanks again, you always come through.


  • Senior Developer

    @Dark000 For your own needs, I’ll say, open the file: /var/www/fog/lib/fog/wakeonlan.class.php

    At line 70 insert a newline after $mac->wake($SendTo, self::$_port); that reads sleep(1);



  • Then it is definitely network issue. If it is not too much of a trouble is it possible to get fog 1.2 wol functionality back (where its 1 host at a time). I know the new way is more efficient but just until i can figure out the network issue.


  • Senior Developer

    If I had to guess, it sounds like a network problem. In 1.2.0 WOL occurred 1 host at a time. While this worked, if you had a large group, it blocked the FOG Server until all hosts in the group had received the wol packet. In newer versions of FOG we are handling it much more efficiently, but it’s likely “spamming” the network all at once causing the problem you’re seeing.

    Again this is only a guess. I would highly suggest looking at the network though as it’s the first guess I can think of causing the systems to not boot all at once.



  • Yes that is correct (the topic title could be better formed). If i put those hosts that didn’t power on into new group (or individual host wol) the wol works but again only until there are less than 6 members. I am guessing that Multicast filtering is enabled because the thing is that wol worked for the whole group (more than 6) in 1.2 version of fog. Can i somehow troubleshoot the issue inside the fog or do you think this could be network issue.


  • Senior Developer

    So WOL IS working for groups? It’s only after a certain number that it doesn’t for “some” machines? Just guessing, but Multicast filtering is enabled on your network?


Log in to reply
 

356
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.