Seems that TFTP was not prepared by installer



  • Hi there,

    first of all a short hello to everybody. I am new to fog and trying to make it work since yesterday, but I still have many issues. Some are solved and with others I have no idea anymore.
    I have set up a physical machine with 2 NICs, one with the ip 10.203.8.31/24 (Internet-access) and the other one with 192.168.100.1/24 (the network for imaging).
    DHCP on 192.168.100.1 works fine but TFPT does not.

    # cat /etc/default/tftpd-hpa 
    # /etc/default/tftpd-hpa
    
    TFTP_USERNAME="tftp"
    TFTP_DIRECTORY="/srv/tftp"
    TFTP_ADDRESS="0.0.0.0:69"
    TFTP_OPTIONS="--secure"
    

    I read somewhere, that there should be a line which says “Modified by FOG” or something like that.
    Directory /srv/tftp is empty, and copying images from the install-Directory does not help much. daemon.log says:

    Jul 11 12:52:34 debian-linux in.tftpd[12113]: RRQ from 192.168.100.11 filename undionly.kkpxe
    Jul 11 12:52:34 debian-linux in.tftpd[12113]: tftp: client does not accept options
    Jul 11 12:52:34 debian-linux in.tftpd[12114]: RRQ from 192.168.100.11 filename undionly.kkpxe
    [...]
    Jul 11 12:52:37 debian-linux in.tftpd[12115]: RRQ from 192.168.100.10 filename default.ipxe
    Jul 11 12:52:37 debian-linux in.tftpd[12115]: sending NAK (1, File not found) to 192.168.100.10
    

    In the management console I can see, that for the TFTP-Server the correct IP is set.

    Any help is appreciated!
    Thanx
    Rainer



  • @george1421 It is a physical machine with 1 onboard NIC and (now) one TP-Link networkcard.
    Works fine now.

    Thanx for the help!



  • Ok. Problems that came up with the dhcp-issue were related to the network-card in the fog server.
    Strange thing, since the network card worked for some minutes and then stopped even pinging, which worked before.

    Changed the network card, built an image from one machine an cloned it to another machine. Everything worked fine.

    No comes the fine tuning.

    Thank you for your help everybody!


  • Moderator

    @Tywyn In regards to the second nic. Is the FOG server a physical machine or a VM? If it is physical, is this a server with 2 built in nics or did you add the second nic as an add in card? If the nic is an add in card is it a generic one or is it a name brand one like intel or broadcom?

    This situation seems very strange in that the problem is rolling from one thing to the other. A bad nic might give us that experience, but something tells me there is another thing going on here. Unless you use one of those cheap network card, I suspect the issue is somewhere else.



  • I think, the network-card in the fog-server is broken. No more connects into the 192.168.100.0/24 network anymore (ping). Firewall configuration is unchanged.

    What was very strange before: I tried to capture a host, that I successfully registered before.
    Started well and then from the sudden the transmission of the image stopped after 850 MB. To make sure that it is not a client issue I changed the client to another machine I then I did not get any ip-Adresses anymore from pxe boot and later also in Windows.


  • Moderator

    @Tywyn Can you communicate from the client to the server? (ping and ftp for example)

    Another possibility for why it’s not working might be the firewall on debian. You could turn it off for testing.

    https://forums.fogproject.org/topic/6162/firewall-configuration

    Explains a bit how to set it up so you can still use it.



  • Replaced the cicso switch by an tp-link switch (Easy Smart Switch TL-SG108E).

    Same thing. No ip-Addresses anymore …


  • Moderator

    @Tywyn This might be relevant for your situation:

    https://wiki.fogproject.org/wiki/index.php/Not_passing_PXE,_or_ProxyDHCP…NO_PROBLEM_Cisco

    Either that, or try and get a “dumb” switch and see if that works.



  • @Quazz
    Cannot do a screenshot, but will type in, what it says

    Intel UNDI, PXE-2.1 (build 082)
    Copyright (C) 1997-2000 Inten Corporation
    
    For Realtek RTL8111B/8111C Gigbit Ethernet Controller v2.08 (070827)
    
    CLIENT MAC ADDR: 00 25 11 31 B6 07 GUID: 00251131-B607-2009-0621-034515000000
    PXE-E51: No DHCP or proxyDHCP offers were received.
    
    PXE-M0F: Exiting PXE ROM.
    

    After booting windows now, it does not offer an IP-Address either anymore, although it did 20 Minutes ago:

    # /etc/init.d/isc-dhcp-server status
    ● isc-dhcp-server.service - LSB: DHCP server
       Loaded: loaded (/etc/init.d/isc-dhcp-server; generated; vendor preset: enabled)
       Active: active (running) since Wed 2017-07-12 10:59:47 CEST; 32min ago
         Docs: man:systemd-sysv-generator(8)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/isc-dhcp-server.service
               └─7977 /usr/sbin/dhcpd -4 -q -cf /etc/dhcp/dhcpd.conf enp3s1
    
    Jul 12 11:18:00 debian-linux dhcpd[7977]: reuse_lease: lease age 5006 (secs) under 25% threshold, reply with unaltered, existing lease for 192.168.100.10
    Jul 12 11:18:00 debian-linux dhcpd[7977]: DHCPDISCOVER from 00:25:11:31:b7:42 (409TN06) via enp3s1
    Jul 12 11:18:00 debian-linux dhcpd[7977]: DHCPOFFER on 192.168.100.10 to 00:25:11:31:b7:42 (409TN06) via enp3s1
    Jul 12 11:18:00 debian-linux dhcpd[7977]: reuse_lease: lease age 5006 (secs) under 25% threshold, reply with unaltered, existing lease for 192.168.100.10
    Jul 12 11:18:00 debian-linux dhcpd[7977]: DHCPDISCOVER from 00:25:11:31:b7:42 (409TN06) via enp3s1
    Jul 12 11:18:00 debian-linux dhcpd[7977]: DHCPOFFER on 192.168.100.10 to 00:25:11:31:b7:42 (409TN06) via enp3s1
    Jul 12 11:18:00 debian-linux dhcpd[7977]: DHCPDISCOVER from 00:25:11:31:b7:42 via enp3s1
    Jul 12 11:18:00 debian-linux dhcpd[7977]: DHCPDISCOVER from 00:25:11:31:b6:07 via enp3s1
    Jul 12 11:18:01 debian-linux dhcpd[7977]: DHCPOFFER on 192.168.100.12 to 00:25:11:31:b7:42 via enp3s1
    Jul 12 11:18:01 debian-linux dhcpd[7977]: DHCPOFFER on 192.168.100.13 to 00:25:11:31:b6:07 via enp3s1
    

  • Moderator

    @Tywyn Would it be possible to provide a screenshot of the client failing to get an IP?



  • @Quazz You are right. I was looking in /etc/fog (for what reason ever :))
    There is no router involved.
    I have the fog-server connected to a switch (cisco SF100D-05) and my test-client connected to the same switch.
    Strange thing is: in the beginning I got ip-adresses on pxe boot via dhcp.
    Now not anymore. But: starting Windows and setting network to use dhcp immediatly gets an ip address.
    dhcp-Server is the fog-server


  • Moderator

    I’m guessing you deleted your message because you found the .fogsettings file after all.

    As for your DHCP concerns, this might be because your router is also handing out DHCP information.

    If you cannot modify your router’s DHCP settings to hand out TFTP/PXE bootfiles and if you cannot turn it off, then you should like into using ProxyDHCP



  • This post is deleted!

  • Moderator

    @george1421 More specifically CTRL+C tries to abort the current command/script in terminal, this is also true on Windows. (making it one of the more confusing key strokes)



  • @Tom-Elliott said in Seems that TFTP was not prepared by installer:

    @Tywyn it only uses ifconfig if needed. We try ip addr too

    Thought I saw an error message there …


  • Senior Developer

    @Tywyn it only uses ifconfig if needed. We try ip addr too



  • Additional info about installing on debian 9.0.0: It seems, that /sbin/ifconfig is not installed by default anymore, but the installer looks for it.
    So you have to install net-tools.


  • Moderator

    @Tywyn said in Seems that TFTP was not prepared by installer:

    no /opt/fog/.fogsettings == no installer finish.

    I have done that a few times where I use putty for installation and want to copy the url out of the putty window and I hit crtl-c to copy (which is the wrong keystroke for linux and the installer aborts).



  • @Quazz

    Hm … seems I have no /opt/fog/.fogsettings:

    # ls -la /opt/fog
    insgesamt 12
    drwxr-xr-x 3 root root 4096 Jul 11 12:31 .
    drwxr-xr-x 3 root root 4096 Jul 10 13:48 ..
    drwxr-xr-x 3 root root 4096 Jul 10 13:48 snapins
    -rw-r--r-- 1 root root    0 Jul 11 12:31 undionly.kpxe
    

  • Moderator

    @Quazz said in Seems that TFTP was not prepared by installer:

    You can change this information in /opt/fog/.fogsettings

    Just a small amendment to Quazz’s post.

    You can / fix change this information in /opt/fog/.fogsettings and then just rerun the installer. No need to do a clean install


Log in to reply
 

378
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.