Unable to use FOG for PXE booting because of unresponsive menu



  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 16.04.2 LTS
    Client
    • Service Version:
    • OS:
    Description

    I am having an issue to where when the client PC’s PXE boot the background image is not loaded but the menu does appear. The issue is any selection from the menu results in it going back to the menu making a never ending loop as boot to hard disk is supposed to be selected. The kernel versions in my GUI are showing up blank. Tried to download the latest kernel and even went back to 4.11 and is still failing to appear. I have also tried to run the installer again to see if it would have fixed the issue.

    Is there any logs that I can collect? I am totally at a loss at this point, so anything would be greatly appreciated!

    Thank you! :)

    0_1499711348903_Capture2.PNG



  • @Tom-Elliott @george1421 Moving those folders and running the installer again has resolved the issues. Thank you again!


  • Moderator

    @Tom-Elliott I can/will/did, but how the hell did that / go missing and thing still work? Oh well I guess that is a discussion for another thread…


  • Senior Developer

    Also, please let’s make sure the links are all correct.

    Would you mind doing:

    mv /var/www/fog /var/www/fog_orig
    mv /var/www/html/fog /var/www/html/fog_orig
    

    Rerun the installer. This should help ensure the links are created/setup properly. It nearly sounds like it can’t find the right links.

    For simplicity, run the installer with the -y argument so things will be more automated as the fact the tftp server settings were all blank leads me to think the installer wasn’t performed fully.


  • Senior Developer

    @george1421 Can you edit the TFTP_PXE_KERNEL_DIR so it reads as /var/www/html/fog/service/ipxe instead of /var/www/html/fogservice/ipxe (missing / between fog and service)



  • @george1421 Here is the results of a manual registration and deploy:

    #!ipxe
    set fog-ip 10.86.96.177
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=10.86.96.177/fog/ consoleblank=0 rootfstype=ext4 acpi=off mac=00:26:55:3f:14:45 ftp=10.86.96.177 storage=10.86.96.177:/images/ storageip=10.86.96.177 osid=9 irqpoll hostname=TEST-PC chkdsk=0 img=DISTWIN10 imgType=n imgPartitionType=all imgid=1 imgFormat=0 PIGZ_COMP=-9 hostearly=1 type=down acpi=off
    imgfetch init_32.xz
    boot
    

  • Moderator

    @quinniedid Has this computer been registered, or are you trying to register it right now?

    If you are trying to register it, (stick with me here) manually register this host and then schedule an image capture or image deploy. It doesn’t matter we will not do either. Once the task is schedule, use the url I gave you before, this time use the mac address of the target computer and key that into a browser (you can leave the target computer off for this test). Post the results of the browser query here. As compared to the first time you did this setup, the results from this one should be very small about 5 or 6 lines long. I want to ensure what the client is being told to do.

    Also can you confirm the target computer is in bios (legacy mode) and not uefi. If its in uefi mode you will need to disable secure boot and then change your ipxe boot kernel sent by dhcp option 67.



  • @george1421 Here are the settings that are currently configured.

    0_1499786213360_Capture3.PNG


  • Moderator

    @quinniedid I’m getting the idea you have a botched install.

    Looking at the screen shot I see bzImage (OS kernel) is transferred ok, but I don’t see init.zx (virtual hard drive) being sent to the target computer. They need to be passed in pairs.

    I wonder if you are missing other values in the fog configuration page for the tftp server contains the correct info (specifically the *Image values)

    0_1499786028038_fog_settings.png



  • @george1421 Apologies for the vague details. The menu comes up now and is able to boot to the first hard drive. It was not able to do that till yesterday which you helped me with resolving. Now the issue is after I select Deploy Image and login, I do get a list of all the images. It is not until I select an image to deploy that this message comes up.
    0_1499785555024_rsz_1img_20170711_085830_li.jpg


  • Moderator

    @quinniedid It would help if you posted a clear screen shot of the actual error taken with a mobile phone. The context of the error is almost as important as the actual error message.

    My intuition is telling me that you are trying to send a bios boot kernel (undionly.kpxe) to a uefi system which is expecting ipxe.efi (or the other way around).



  • @george1421 This is the same PC’s that I have used before in the past to image, should be BIOS. For DHCP, I am using undionly.kpxe.


  • Moderator

    @quinniedid said in Unable to use FOG for PXE booting because of unresponsive menu:

    Any ideas?

    Lots of ideas, none to make me a million dollars overnight though…

    What system are you trying to pxe boot?

    Is this device in uefi mode or bios (legacy mode)?

    What exactly do you have set for dhcp option 67 {boot-file}?



  • @george1421 I have run into one more problem. I cannot image anything. This is the error that I am getting:

    Could not select: Exec format error (http://ipxe.org/2e008001)
    Could not boot: Exec format error (http://ipxe.org/2e008001)
    Chainloading failed, hit’s for the iPXE shell

    Any ideas?


  • Moderator

    @quinniedid Thank you for sticking with me on this. I’m trying to take care of some honey-do projects the same time I’m “playing” on the computer. So my responses are a bit haphazard tonight.



  • @george1421 That was it!!!

    Thank you so much for your time on this!!!


  • Moderator

    @quinniedid Here is what I have, at least it might get you started:

    0_1499730511173_web_server.png



  • @george1421 I think we found it!

    Is there supposed to be anything else populated in those fields?

    0_1499730156671_6f073313-d615-47da-a9a2-9f30d6dfebda-image.png


  • Moderator

    @quinniedid OK there are two other places for the IP address to hide:

    In the fog settings page again under Web Server->FOG_WEB_HOST

    And then in the storage node configuration for the fog server -> IP Address.

    If those are populated then we might need to get the developers involved to tell us where that value comes from. But now that I thing about it, I would lay odds on the FOG_WEB_HOST not being populated.



  • The fields are all populated in settings. I even clicked on save changes again and checked the file and it is still showing the same thing.

    0_1499727223747_d5f31eb9-8664-4bd7-bc19-61b614dc056f-image.png


Log in to reply
 

378
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.