FOG - Single Snappin



  • Server
    • FOG Version: 1.4.2
    • OS: Kubuntu
    Client
    • Service Version: Legacy Client
    • OS: Windows 10
    Description

    Hello,

    I currently use FOG to deploy Windows 10 to my machines and have been very successful. I was trying to get fancy and use the snappin’s feature to start deploying applications as well. I was trying to install a program called Team Mate using the single snappins feature. If I understand this correctly it will take the installer file, as well as the batch file and place them in the fog temp folder, and will then preform a silent install. It says the task was completed but the program was not installed on the machine. I was wondering if there are any type of instructions, or if someone could walk me through setting up this single snapin. Thanks for all your help and hard work!

    Michael S


  • Moderator

    @george1421 The Teammate software installed correctly on a virgin build of 1703 without an application (minus the ones that come with 1703 ) I’m not sure what else I can say to help your setup, it works for me.

    0_1501006641808_1703_Install.png


  • Moderator

    I setup our MDT server last night to create our standard image using Win10 1703. I was able to capture it and deploy it this morning with FOG. I was able to install the teammate software with the same snapin that worked with 1607.

    So it works as it should. Understand that the system I’m testing on, which as freshly built, has all of our applications on it as well as some management tools. These applications may have installed a dependency that teammate needs. That is why it works in my environment. This is not a FOG issue, but an application issue.

    I’m in the process of building a virgin win10 1703 image without any add on applications or windows updates. I will test again to see if the snapin deploys correctly.

    If that test is successful then I don’t know what to tell you other than its not a FOG issue.



  • @george1421 @Tom-Elliott any ideas on why it deploys to George’s 1607 build but not my 1703 build?


  • Moderator

    @Tom-Elliott Just to close the loop on this. I had to extract the teammate program to get to the MSI and install files. Once I did that I created a zip of the contents and then deployed as a snapin pack with a template of MSI. This worked on my dev instance of Win10 1607 but did not install according to the OP on Win10 1703. I don’t have a dev build of Win10 1703 yet to test with to confirm if there is something different. But as the system is currently configured I can install it once I extracted the contents out of the .exe. I could not deploy the .exe directly because it threw a 1619 error when I did.


  • Senior Developer

    @Wayne-Workman I think this depends on the file. Some exe files are self extracting zip files. These often have a script that auto runs which can cause any number of issues.


  • Moderator

    If only a single file is being deployed, you don’t need to use SnapinPacks, a regular snapin will work and be more simple.



  • 0_1500922722048_reviewsettings.PNG

    Do these look okay @george1421


  • Moderator

    @george1421 I was able to deploy the application with these settings

    [0_1500920876828_Thumbs.db](Uploading 100%) 0_1500920883633_tmr11.png


  • Moderator

    @msaglioc99 None so far, I just wanted to see if the installer ran to completion without any errors. The next step was to deploy via snapin. But since there was an error I stopped.



  • @george1421 what template and snapin settings did you use to deploy what you were able to install


  • Moderator

    @msaglioc99 After testing with this application I see its throwing the following error and returned a not successful response to the fog snapin tool

    0_1500661182191_tm_fail.png

    But it looks like it installed something though
    0_1500661216430_tm_menu.png


  • Moderator

    {from discussion via IM}

    I might assume this might get you pretty close.
    0_1500650876914_sn_team_mate.png


  • Moderator

    @msaglioc99 Lets do a quick recap here since you are new to package building and it does require a bit of the black arts to make things work well.

    Some applications have features to allow software to be installed in an unattended or silent manner. These usually take command line switches to set the installer options. The user is typically not presented with any panels asking questions it is just installed automatically. These are the easiest to be deployed no matter what the deployment tool you’re using.

    The other and typically older kind require the installer to click through several panels making option selections sometimes these type of installers can be launched in a admin or configuration mode where they will write the users selections out to a setup file that can be used on the next deployment where you just reference the setup file [setup.iss] for all of the selections. When run this way the user is not presented with any setup panels. The application just installs.

    The last kind are the ones that don’t support automated installs in any manner. These type require a different kind of tool that takes a snapshot of a sample computer before you install the software and then just after you install the software. The difference between the two becomes your automated installation package. These tools are expensive and not typically needed now days.



  • If I type

    C:\Users\username\Desktop\TeamMate_R11.0.2_Desktop /r the installer does open. Is this what you’re asking?



  • @Avaryan Do I have to runthe installer via command prompt? Or can I just double click and run the installer? Idk how to run the installer via command prompt?



  • @msaglioc99 Ok, then until you can find a way to install the application silently, uploading it to FOG is useless.

    Since it’s an InstallShield installer, you may be able to create a response file. Basically, this records the settings you choose during your installation and lets use that file to silent install the application.

    To try this, open a command prompt at the location of your file. Type TeamMate_R11.0.2_Desktop.exe /r

    The installer should appear to run normally. Install the application the way your normally would.

    Find the response file. Default location will be C:\Windows\setup.iss. The modified data on the file should match the time you ran the installer.

    More directions can be found here:
    http://publib.boulder.ibm.com/tividd/td/framework/GC32-0804-00/en_US/HTML/instgu25.htm



  • @Avaryan said in FOG - Single Snappin:

    o

    This didin’t work?



  • The screenshot in the 2nd or 3rd post very clearly indicated that the installer is a .exe. You do not want/need to use the msi template.

    Before uploading anything to fog you should be trying to install the application silently on a computer. Try opening a command prompt and typing the filename with /S after it. It’s an InstallShield installer, so if it supports silent installation that will be the switch for it.



  • I believe this file is .exe not .msi


Log in to reply
 

491
Online

39006
Users

10720
Topics

101778
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.