Could not boot:not enough space(http://ipxe.org/31062006)



  • Server
    • FOG Version: 1.4.2
    • OS: unbuntu 16.04
    Client
    • Service Version:
    • OS: win 7 and win 10
    Description

    hi i am having a problem when i try to deploy images from fog. i get the above error message when the computers are trying to load init.gz. i have tried this on two different computer models a levono thinkcentre and a hp deskpro g400. both machines give the same error message, sometimes i get the error message could not boot: connection reset.

    i have 2 seperate vlans on the network that pc’s reside on. the first one vlan1 has the server on it and it has a fixed ip address. the dhcp server is windows 2003 and it has the entries in the dhcp for pxe . on the second vlan 292 it has the similar network setup but the dhcp server is windows 2012. i am running the latest kernel on fog but i have also gone back to earlier versions and i get the same error message.

    i also get the error message about chainloading but i do not think that this is the problem as i get the error message on both vlans. i have have not used the server for several months, i had problems with fog after i upgraded to unbuntu 160.4 but i resolved these(to do with the wrong php version). i was wondering if anybody had come across this error and a hopefully might have a solution for it.
    thanks,
    stephen.


  • Senior Developer

    I’m confused how init.gz was even a thing? Were you building custom init’s (or reworking the original init’s) and re-zipped as .gz?


  • Developer

    @stepryan Alright, thanks for reporting pack. Great to hear that this seems fixed with the most current initrd files. I have no idea how those old ones made it onto your server as the installer always downloads the newest ones and would fail if it cannot download those. Anyhow, marking this solved.



  • @george1421 said in Could not boot:not enough space(http://ipxe.org/31062006):

    @Sebastian-Roth What I’m really confused about is how is this even possible? If fog 1.4.2 was installed the new inits must be there or the install will fail. What currently exists shouldn’t be (like pink unicorns).

    I assume FOG was upgraded from a previous release. What release was fog upgraded from?

    i can’t remember all the versions but i think it was 0.32 -> 1.0 , 1.1, 1.2 , 1.3, 1.4 , 1.42 .



  • @Sebastian-Roth said in Could not boot:not enough space(http://ipxe.org/31062006):

    @stepryan Ok, let’s try updating the initrd files to the latest version and then see if you still have the same error.

    1. On the terminal run the following commands:
    sudo -i
    cd /var/www/html/fog/service/ipxe/
    wget https://fogproject.org/inits/init.xz
    wget https://fogproject.org/inits/init_32.xz
    chown fog:www-data init*
    
    1. On the FOG web interface in FOG settings change FOG_PXE_BOOT_IMAGE to init.xz and FOG_PXE_BOOT_IMAGE_32 to init_32.xz

    2. Boot up the client and see if you still get the same error.

    I am still wondering why you had those quite old initrd files (Oct 2014!!) in use. Maybe one of your colleagues had modified and installed those by intention?

    hi sebastian,
    i have tried those commands and it updated the files. when i turned on one of the pc’s i was trying to image it came up with some sort of error about udev which went past on the screen. partclone kicked in and it seems to be imaging the machine now, thanks for all your help. as for how it stayed on the old files i do not know. i am the only person who works on it. generally i have upgraded from previous versions and i have let the install file do the upgrade. the only reason i could think why the old files are there was if i was trying to fix something in the past and i was following some old instructions which referred to the old .gz file instead of the new xz file.


  • Moderator

    @Sebastian-Roth What I’m really confused about is how is this even possible? If fog 1.4.2 was installed the new inits must be there or the install will fail. What currently exists shouldn’t be (like pink unicorns).

    I assume FOG was upgraded from a previous release. What release was fog upgraded from?


  • Developer

    @stepryan Ok, let’s try updating the initrd files to the latest version and then see if you still have the same error.

    1. On the terminal run the following commands:
    sudo -i
    cd /var/www/html/fog/service/ipxe/
    wget https://fogproject.org/inits/init.xz
    wget https://fogproject.org/inits/init_32.xz
    chown fog:www-data init*
    
    1. On the FOG web interface in FOG settings change FOG_PXE_BOOT_IMAGE to init.xz and FOG_PXE_BOOT_IMAGE_32 to init_32.xz

    2. Boot up the client and see if you still get the same error.

    I am still wondering why you had those quite old initrd files (Oct 2014!!) in use. Maybe one of your colleagues had modified and installed those by intention?



  • @Sebastian-Roth said in Could not boot:not enough space(http://ipxe.org/31062006):

    @stepryan Good find that post about the PXE issue. I remember this but didn’t know that this was the same iPXE error. I remember thinking that although the issue seemed solved I doubt it was due to changing from ubuntu server to ubuntu desktop. But hey, you never know till you provide the evidence.

    So nothing in the apache error logs, ok. And your FOG version is obviously up to date. But still I am wondering why the client boots init.gz! Please check the FOG settings (section TFTP Server). What is FOG_PXE_BOOT_IMAGE set to?? As well, please run the following command on your FOG server console and post the output here: ls -al /var/www/fog/service/ipxe/init*

    0_1497603507298_tftp server.jpg
    these are the tftp settings.
    0_1497603787951_20170616_095726.jpg
    this is the result of the command.


  • Developer

    @stepryan Good find that post about the PXE issue. I remember this but didn’t know that this was the same iPXE error. I remember thinking that although the issue seemed solved I doubt it was due to changing from ubuntu server to ubuntu desktop. But hey, you never know till you provide the evidence.

    So nothing in the apache error logs, ok. And your FOG version is obviously up to date. But still I am wondering why the client boots init.gz! Please check the FOG settings (section TFTP Server). What is FOG_PXE_BOOT_IMAGE set to?? As well, please run the following command on your FOG server console and post the output here: ls -al /var/www/fog/service/ipxe/init*



  • @Sebastian-Roth said in Could not boot:not enough space(http://ipxe.org/31062006):

    @stepryan The connection reset to me sounds like something is killing the TCP connection (sending TCP reset packets) while transfer of init.gz is going on. Well … I just noticed init.gz. We don’t use GZIP compressed initrds anymore. This has been used years ago. Are you sure you have a FOG server version 1.4.2 running?!? Please let us know more about your setup.

    Do you see anything in the apache error logs when this is happening on the client. See my signature on where to find those logs on your FOG server.

    this is the contents of the apache error log:
    [Fri Jun 16 07:38:40.872368 2017] [mpm_prefork:notice] [pid 1954] AH00163: Apache/2.4.25 (Ubuntu) OpenSSL/1.0.2l configured – resuming normal operations
    [Fri Jun 16 07:38:40.872412 2017] [core:notice] [pid 1954] AH00094: Command line: ‘/usr/sbin/apache2’



  • @Sebastian-Roth said in Could not boot:not enough space(http://ipxe.org/31062006):

    @stepryan I have never seen this error and searching the internet tells me that pretty much no one else ever ran into such a thing. Checking the iPXE URL I see this a a valid error but right now I have no idea what could be causing this. Don’t worry, I am pretty sure we are able to figure this one out.

    i also get the error message about chainloading…

    I am wondering if this is related. Could you please take a picture of that error and post here.

    i have 2 seperate vlans on the network that pc’s reside on. the first one vlan1 has the server on it and it has a fixed ip address.

    Does the VLANs end on the switch? Possibly you’ve configured VLANs all the way to the client. With that PXE boot just wouldn’t work I suppose.

    link text i found this post which seems like someone else had the problem previously.



  • @Sebastian-Roth said in Could not boot:not enough space(http://ipxe.org/31062006):

    @stepryan The connection reset to me sounds like something is killing the TCP connection (sending TCP reset packets) while transfer of init.gz is going on. Well … I just noticed init.gz. We don’t use GZIP compressed initrds anymore. This has been used years ago. Are you sure you have a FOG server version 1.4.2 running?!? Please let us know more about your setup.

    Do you see anything in the apache error logs when this is happening on the client. See my signature on where to find those logs on your FOG server.

    0_1497601304721_fogversion.jpg here is a screenshot of the version



  • @george1421 said in Could not boot:not enough space(http://ipxe.org/31062006):

    @Sebastian-Roth Excellent catch there.

    @stepryan did someone change the default (global) or define a host specific init file for this host? I would also have to question where you might find the init.gz file from to start with.

    i would not know how to change the init file or even where it is . i generally only change settings through the web gui.



  • @Sebastian-Roth said in Could not boot:not enough space(http://ipxe.org/31062006):

    @stepryan The connection reset to me sounds like something is killing the TCP connection (sending TCP reset packets) while transfer of init.gz is going on. Well … I just noticed init.gz. We don’t use GZIP compressed initrds anymore. This has been used years ago. Are you sure you have a FOG server version 1.4.2 running?!? Please let us know more about your setup.

    Do you see anything in the apache error logs when this is happening on the client. See my signature on where to find those logs on your FOG server.

    from what i can remember it has always come up for me when i have used fog even when i have gone from one version to another. i do not really understand the whole boot process so i do not mess with it other than to upgrade the kernel. i will post a screenshot of the version when i get to work.



  • @Sebastian-Roth said in Could not boot:not enough space(http://ipxe.org/31062006):

    @stepryan I have never seen this error and searching the internet tells me that pretty much no one else ever ran into such a thing. Checking the iPXE URL I see this a a valid error but right now I have no idea what could be causing this. Don’t worry, I am pretty sure we are able to figure this one out.

    i also get the error message about chainloading…

    I am wondering if this is related. Could you please take a picture of that error and post here.

    if you look closely it appears at the bottom of both pictures.

    i have 2 seperate vlans on the network that pc’s reside on. the first one vlan1 has the server on it and it has a fixed ip address.

    Does the VLANs end on the switch? Possibly you’ve configured VLANs all the way to the client. With that PXE boot just wouldn’t work I suppose.

    the vlans exist on all switches on the network and communicate with each other. the server and the machines in question are plugged into the same stack but not necessarily the same 3com switch. the error occurs even if they are on ports that are on the same vlan on the stack.


  • Moderator

    @Sebastian-Roth Excellent catch there.

    @stepryan did someone change the default (global) or define a host specific init file for this host? I would also have to question where you might find the init.gz file from to start with.


  • Developer

    @stepryan The connection reset to me sounds like something is killing the TCP connection (sending TCP reset packets) while transfer of init.gz is going on. Well … I just noticed init.gz. We don’t use GZIP compressed initrds anymore. This has been used years ago. Are you sure you have a FOG server version 1.4.2 running?!? Please let us know more about your setup.

    Do you see anything in the apache error logs when this is happening on the client. See my signature on where to find those logs on your FOG server.



  • @george1421 0_1497557343581_20170615_1400312.jpg Connection reset screenshot0_1497557459030_20170615_1525282.jpg Not Enough Space Screenshot


  • Developer

    @stepryan I have never seen this error and searching the internet tells me that pretty much no one else ever ran into such a thing. Checking the iPXE URL I see this a a valid error but right now I have no idea what could be causing this. Don’t worry, I am pretty sure we are able to figure this one out.

    i also get the error message about chainloading…

    I am wondering if this is related. Could you please take a picture of that error and post here.

    i have 2 seperate vlans on the network that pc’s reside on. the first one vlan1 has the server on it and it has a fixed ip address.

    Does the VLANs end on the switch? Possibly you’ve configured VLANs all the way to the client. With that PXE boot just wouldn’t work I suppose.



  • Hi, i have undionly.kxpe as option 67. i have the bios in both machines to network boot in legacy mode, i turned off uefi


Log in to reply
 

718
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.