Upgrade from Trunk to 1.4.2 Failed



  • Server
    • FOG Version: Trunk (Pre 1.3)
    • OS: Ubuntu 14.04
    Client
    • Service Version:
    • OS:
    Description

    Here’s what happens when I try to update our live server to 1.4.2 from last years Trunk build.

     * Creating SSL Certificate....................................OK
     * Creating auth pub key and cert..............................OK
     * Resetting SSL Permissions...................................OK
     * Setting up SSL FOG Server...................................OK
     * Starting and checking status of web services................OK
     * Changing permissions on apache log files....................OK
     * Backing up database.........................................Failed!
    

    How do I got about getting this to work?



  • @george1421 said in Upgrade from Trunk to 1.4.2 Failed:

    @Avaryan Now that you know your password attempt to log into your database from the linux command line mysql -u root -p fog then provide your database password.

    Our live FOG server is now on 1.4.2, revision 6072. Thanks! Now to figure out how that password got changed…

    edit: You can mark this as solved.


  • Senior Developer

    That /opt/fog/.fogsettings file, pelase edit the snmysqlpass line to make it match what you “know” what it is. THen rerun the installer. Apparently it got changed at some point in time.



  • @george1421 said in Upgrade from Trunk to 1.4.2 Failed:

    @Avaryan Now that you know your password attempt to log into your database from the linux command line mysql -u root -p fog then provide your database password.

    This was the output when I tried the password listed in .fogsettings

    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
    

    However, I tried another password and got this:

    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 28556
    Server version: 5.5.55-0ubuntu0.14.04.1 (Ubuntu)
    
    Copyright (c) 2000, 2017, Oracle and/or its affiliates. All rights reserved.
    
    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    

    Assuming that is what I should see on a correct login, I at least know what the password is.


  • Moderator

    @Avaryan Now that you know your password attempt to log into your database from the linux command line mysql -u root -p fog then provide your database password.



  • @Tom-Elliott said in Upgrade from Trunk to 1.4.2 Failed:

    @Avaryan this is where things get tricky I suppose as I have no idea of knowing.

    Can you check in /opt/fog/.fogsettings and look for snmysqlpass?

    The password should be there, though I suspect that’s where things might be also breaking.

    snmysqlpass='XXXXXXXX'

    Moderator note: I removed the password to your mysql database. The important part is that YOU know what it is


  • Moderator

    @Avaryan ls -la /opt/fog please try



  • @Tom-Elliott I don’t see a .fogettings in /opt/fog

    Only thing in there is log, service, snapins, utils directories.

    Edit: Nevermind. It showed up when I manually typed it in.


  • Senior Developer

    @Avaryan this is where things get tricky I suppose as I have no idea of knowing.

    Can you check in /opt/fog/.fogsettings and look for snmysqlpass?

    The password should be there, though I suspect that’s where things might be also breaking.



  • @Tom-Elliott Good question. No clue! I didn’t set the server up.

    How would I go about checking? And how would I go about changing it and/or removing if that’s what I need to do.


  • Senior Developer

    @Avaryan Do you have a root password defined for Mysql access?



  • @Tom-Elliott said in Upgrade from Trunk to 1.4.2 Failed:

    @Avaryan ANd what’s the output of mysql -v?

    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 575
    Server version: 5.5.55-0ubuntu0.14.04.1 (Ubuntu)
    
    Copyright (c) 2000, 2017, Oracle and/or its affiliates. All rights reserved.
    
    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.
    
    Reading history-file /home/user/.mysql_history
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    

    If I sudo that or log in with root I get access denied message.


  • Senior Developer

    @Avaryan ANd what’s the output of mysql -v?



  • @Tom-Elliott said in Upgrade from Trunk to 1.4.2 Failed:

    @Avaryan What’s output of php -v?

    PHP 7.1.5-1+deb.sury.org~trusty+2 (cli) (built: May 22 2017 13:39:01) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
        with Zend OPcache v7.1.5-1+deb.sury.org~trusty+2, Copyright (c) 1999-2017, by Zend Technologies
    
    

  • Senior Developer

    @Avaryan What’s output of php -v?



  • @Tom-Elliott said in Upgrade from Trunk to 1.4.2 Failed:

    Can you provide output of lsb_release -a?

    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 14.04.5 LTS
    Release:        14.04
    Codename:       trusty
    

    Note: The ‘Backing up datebase’ part while installing 1.3.0 seemed to have worked, while in 1.4.2 it did not.


  • Senior Developer

    Can you provide output of lsb_release -a?



  • So, on a whim, I decided to checkout revision 07fc221, the first FOG 1.3.0 that I saw. It installed. Thought behind this was that maybe there have been too many changes from the pre 1.3 trunk build to the current 1.4.2 build and that I could update incrementally.

    However, on loading the webpage I get this:

    Your database connection appears to be invalid. FOG is unable to communicate with the database. There are many reasons why this could be the case. Please check your credentials in /var/www/html/fog/lib/fog/config.class.php. Also confirm that the database is indeed running. If credentials are correct, and if the Database service is running, check to ensure your filesystem has enough space.
    


  • @Tom-Elliott said in Upgrade from Trunk to 1.4.2 Failed:

    @Avaryan What’s the last few lines of the bin/error_logs/fog_1.4.2_error.log?

    Enabling module ssl.
    See /usr/share/doc/apache2/README.Debian.gz on how to configure SSL and create self-signed certificates.
    To activate the new configuration, you need to run:
      service apache2 restart
    Enabling site 001-fog.
    To activate the new configuration, you need to run:
      service apache2 reload
     * Stopping Apache httpd web server apache2
     * 
     * Starting Apache httpd web server apache2
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/001-fog.conf:1
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
     * 
    stop: Unknown instance: 
    php7.1-fpm start/running, process 22328
     * apache2 is running
    php7.1-fpm start/running, process 22328
    --2017-06-05 10:53:01--  http://10.10.1.41//fog//maintenance/backup_db.php
    Connecting to 10.10.1.41:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: ?node=schema [following]
    --2017-06-05 10:53:01--  http://10.10.1.41//fog//maintenance/backup_db.php?node=schema
    Connecting to 10.10.1.41:80... connected.
    HTTP request sent, awaiting response... 500 Internal Server Error
    2017-06-05 10:53:01 ERROR 500: Internal Server Error.
    


  • I commented out the lines mentioned in previous post. I’ll get the error log if it fails.

    Also:

    Starting Debian based Installation
    
    
     *** Detected a potential need to reinstall apache and php files.
     *** This will remove the /etc/php* and /etc/apache2* directories
     ***  and remove/purge the apache and php files from this system.
     *** If you're okay with this please type Y, anything else will
     ***  continue the installation, but may mean you will need to
     ***  remove the files later and make proper changes as
     ***  necessary. (Y/N):
    y
     * Removing apache and php files...............................Done
     * Stopping web services.......................................Failed
     * Removing the apache and php packages........................Done
     * Resetting our variables to specify php version 7.1..........Done
    

    edit: Still failed.


Log in to reply
 

444
Online

39003
Users

10717
Topics

101764
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.