Advanced Menu



  • How do I go about setting up the Advanced Menu? Test server is on 1.4.1, basically stock settings.

    The documentation on this, that I’ve seen, appears to be outdated.



  • @Tom-Elliott Ok, thanks. I think everything is working now.


  • Senior Developer

    @Avaryan Advanced login should be on the “All Hosts” item. Advanced (no login) shouldn’t even show up if advanced login is turned on. YOu do not need the “hide menu” selected for advanced login to work though either. Is it possible the “hide menu” is forcing the signin and not requiring it for the Advanced login (as you’ve already authenticated?)



  • @Tom-Elliott Yes.

    Under iPXE Boot Menu I have the checkbox next to ‘Advanced Menu Login’ marked.
    I have ‘Boot Key Sequence’ set to CTRL + A.

    My ‘Advanced Configuration Options’ are:

    menu
    item --gap -- ---------------- iPXE Advanced Boot Menu ----------------
    item dart7 Microsoft Diagnostics and Recovery Toolset (DaRT7)
    item return Return to Previous Menu
    choose --default return --timeout 15000 target && goto ${target}
    :dart7
    kernel http://10.10.1.41/DaRT7/wimboot
    initrd http://10.10.1.41/DaRT7/boot/bcd BCD
    initrd http://10.10.1.41/DaRT7/boot/boot.sdi boot.sdi
    initrd http://10.10.1.41/DaRT7/sources/boot.wim boot.wim
    boot
    :return
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
    prompt
    goto MENU
    autoboot
    

    Under ‘iPXE Menu Configuration’ menu.
    I see fog.advanced and fog.advancedlogin.

    Which should be used and what menu should they be shown on?


  • Senior Developer

    @Avaryan you have “Advanced Login” selected?



  • Alright, so I’ve got the menu working as I want it, but I can’t get the login part to work right. Not really sure why.



  • @Tom-Elliott Oooo… so that’s what that is for. I saw that, but had no idea what it was.

    I think I’ll be able to figure out the rest based on the examples in the documentation.


  • Senior Developer

    From FOG Configuration Page->iPXE Boot Menu->Advanced Configuration Options.


Log in to reply
 

476
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.