Sysprepped image failing after first reboot



  • Server
    • FOG Version: 1.3.5
    • OS: Ubuntu Server 16.04
    Client
    • Service Version: 1.2.0
    • OS: Windows 10
    Description

    I’m having trouble getting Windows installs to finalize. I’m perplexed because this image was working beautifully for 40 machines before this error began happening. When I check the log at C:\windows\panther\unattendgc\setuperr.log, I see this:

    [msoobe.exe] COMMIT: failed for plugin LocalUser Plugin with hr=0x80070490

    Googling the error code gives nothing except for Windows Update errors, and this seems to have not a thing to do with Windows Update. I’m wondering if it’s failing at the LocalUser Plugin because I have CopyProfile enabled. I’m in the middle of testing this theory now, and I’m going to remove the AutoLogon script next. Anyone else have any suggestions?

    Thanks so much,
    Ryan



  • @wciws
    Just checking to see if there have been any updates on your end of things?



  • @BedCruncher @wciws
    I would agree. i use the setupcomplete.cmd to create/activate logins and check installs.
    You will likely need to create the scripts directory though. I believe I have another script run from the sysprep.xml file though that does some installs, adds to domain and registers/activates windows. I don’t rem. where in the file though.



  • @wciws
    I don’t think FOG Client would mess the actual install part…
    FOG CLIENT WITH SYSPREP
    that is as long as you did the steps in the wiki.

    Here is my auto login part of the unattended.xml file

                 <AutoLogon>
                    <Password>
                        <Value>REMOVED</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Enabled>true</Enabled>
                    <LogonCount>3</LogonCount>
                    <Username>Administrator</Username>
                </AutoLogon>
    

    and my Copy Profile line

    <CopyProfile>true</CopyProfile>
    

    One way you could introduce the net user command would be to add it to the file SetupComplete.cmd located in c:\windows\setup\scripts (I think that’s the right path) and then do net user administrator password /active:yes
    that would allow you to get the password injected if the sysprep route still fights with you.



  • @BedCruncher Everything seems to be working with no AV, no FOG Client, and no AutoLogon/CopyProfile. Only problem now is that the administrator account is NOT enabled because there is no “net user administrator /active:yes”, so I need to reintroduce AutoLogon and see if everything breaks again.

    EDIT: I also took a snapshot within VirtualBox for my “PreSysprep”, which means I’m not sysprepping the “same” image 5000 times over.



  • @wciws
    Yeah, always best to remove AV from the presysprep images, it causes too many headaches.



  • I’m in the process of building a new image and removing the FOG Client and McAfee Agent (I’ll install these from a pendrive post-install). Also will remove the auto-login lines from the unattended install.



  • @wciws
    I also have the copyprofile flag turned on in my images. I will check into your error and see if I can uncover anything.



  • One interesting quirk is that the installation never fails on the virtual machine, and none of the virtual machine’s drivers are being carried over to the image. It also plays nice with certain hardware and not others. One thing is for certain: this isn’t an issue with the image itself. I have tried building an image on the hardware I’m attempting to deploy to using the same unattended file and still continue to receive the same error. That’s why I’m pointing to the CopyProfile flag and will definitely update you all if this thing works without it.



  • @wciws
    There is a method out there I have seen to get around the sysprep limit. I don’t recall off the top of my head where I saw that, but I know it is out there. One thing I would suggest at least in my case is taking a “PreSysprep” image and a “PostSysprep” image. That way I can always redeploy the “Pre” image, update, then recapture. I then do a “Post” image once I start the sysprep phase so that I can push it out to all clients I have registered.

    I have done things both ways(audit mode and normal install). I don’t see a clear advantage of either.

    I also recently started doing the audit mode scenario and remember seeing that when updating that way, you need to choose the “Enter Audit Mode” on the sysprep popup and then choose “Quit” so that windows updates will successfully apply.

    Below are links to some articles that I used to help guide me. I picked and chose the parts to apply to my scenario, but otherwise they are full of useful info.

    Audit Mode 1
    Sysprep 1



  • @BedCruncher Audit mode at first, then there were a few modifications I had forgotten to make and so I logged in as the local Admin and sysprepped as necessary. I’m thinking that the fact that I sysprepped about 3000 times might have something to do with it but I set SkipRearm to 1 so I don’t think I’m running into the “3 and done” thing.



  • @wciws @KnightRaven

    When you were applying the updates, how did you do that exactly? Did you first go the route of installing windows and then sysprep the machine, or did you go the audit mode route? Let me know and I will offer help in either case if I am able.



  • @wciws
    Ugh. I feel your pain. I hate how picky and unforgiving sysprep is. I have had quirks with copyprofile. If you used a diffrent profile other than administrator it could be “confused” so to speak. Since your error mentions localuser that is where I’d start. Remove the copyprofile line(s) or set it to false and test.

    Also if you have made any changes to backgrounds, or anything that would have a path in your <sysprep>.xml file double check that the paths are correct.

    Double check any post scripts you may have as well, although If the path to them is correct the error would be different I would think.

    Make sure you don’t have any Antivirus services running or the3 Fog Client service. These services will bomb out the sysprep and cause it to crash. For instance we use Avast and just to be safe Avast is uninstalled just before prepping. I have a script that re-installs it after the fact. I don’t use the Fog Client but it is the same way. You have to stop the services or install it later.

    Sorry I can’t give more specifics. But maybe can get you in the right direction.

    Jason Bradley


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.