Problems with fog homepage


  • Moderator

    Did you happen to have a redirection in place where if you keyed in http://<fog_IP> it would redirect you to the fog login page?

    It sounds similar to this issue: https://forums.fogproject.org/topic/10093/updated-to-fog-1-4-0-getting-blank-white-page/6



  • @KnightRaven There are no words to describe how happy I am right now. I finally got it working and I’m in fog again and everything looks okay! Knight I want to thank you so much for your help you had me on the right path all along, however, I did have to do a few extra steps. I’m going to explain so if anyone has this issue later on and they stumble upon this post hopefully it will help them out.

    First thing is the reason I could never get mysqld to start is during the installation of mySQL it never created the directory /var/run/mysqld so that’s why it would never start a mysql instance. So using these commands you can accomplish that.

    mkdir -p /var/run/mysqld
    chown mysql:mysql /var/run/mysqld
    

    Once that was done, make sure all instances of regular mysql is gone. I used killall mysql and then to verify killall -9 mysql Then I ran the following command

    mysqld_safe --skip-grant-tables --skip-networking &
    

    Once that is done you’ll need to open a different terminal. And do the following:

    mysql -u root
    

    If all is well you should now be in the database once more, here I checked for the user account like you mentioned Knight, but mine seemed to still be in there. So if the user is there use the following commands (this is what I had to do in my case, since my root user still existed)

    use mysql;
    update user set authentication_string=PASSWORD('<YOURPASSWORDHERE>') where user='root';
    flush privileges;
    \q
    

    So now your password should be updated, so now to verify kill all of the mysqld instances and start the regular mysql ones. This can be accomplished by the following.

    killall mysqld
    service mysql start
    #now you can check your new password...
    mysql -u root -p
    #Enter your password and you should be brought to the following prompt...
    mysql>
    

    After that I was able to get to the fog homepage and update my schema, and now I’m back in with everything in tact. After this was done I followed Tom’s advice and disabled automatic updates because I’m really tired of Ubuntu breaking everything lol.

    I hope this helps any future readers, so you don’t have to go through this madness like I did. Turn off automatic updates as soon as you can, because from my experience it only causes issues, and if you have to update your Ubuntu fog machine prepare for problems.

    I also want’s to extend one last thanks to @KnightRaven @Tom-Elliott and @george1421 for their help on this, you guys rock!

    Along with everyone else’s references here is the one I used: https://askubuntu.com/questions/489098/unable-to-reset-root-password-of-mysql


Log in to reply
 

376
Online

6.5k
Users

13.9k
Topics

131.4k
Posts