Database Schema error after installation



  • Server
    • FOG Version: 1.3.5
    • OS: Ubuntu Server 16.04
    Client
    • Service Version:
    • OS:
    Description

    Hi all,
    I’m really “new” with fog so please forgive me if I’m asking something already covered.

    here is my problem. I set up a ubuntu server v. 16.04 LTS, installed the lamp suite, verified that all was ok. So phpmyadmin was installed and working, sql server was working and so on…

    I’ve installed FOG and all seemed to be ok.
    After installation, if in a browser I try to reach the address http://ipaddress/fog I’m redirected to http://ipaddress/fog/management/index.php?node=schema and a warning message titled “Database Schema Installer / Updater” warns me about my database connection that appears invalid.

    After the installation phpmyadmin doesn’t work anymore.

    Can you please help me solving this problem?

    thanks,
    Andrea



  • @Tom-Elliott said in Database Schema error after installation:

    I’m lost. What question are you asking?

    When I responded to it the message was asking for the login information.

    As for phpmyadmin, I don’t know what is or isn’t on your system. You shouldn’t have to do anything special to work with phpmyadmin though. How did you install phpmyadmin? YOu might look into using the “source” information rather than the package as Ubuntu has a nasty habit of telling packages exactly what packages MUST be used for things. While this is normal and fine for most things, when it comes to phpMyAdmin, they have decided it MUST contain PHP version 5, but FOG installs PHP version 7.

    Well… let’s say that in the first “blank” installation I’ve installed ubuntu server than using apt-get command I’ve installed, in order, apache2, mysql and php7.
    Then I’ve installed phpmyadmin with the command sudo apt-get install phpmyadmin apache2-utils.
    After that everything was working fine.

    Then I’ve installed Fog 1.3.5.
    The setup seemed to be ok but I’ve received an error when udpating the database.
    This is the output:

    • Configuring services
    • Setting up fog user…OK
    • Setting up fog password…OK
    • Stopping FOGMulticastManager.service Service…OK
    • Stopping FOGImageReplicator.service Service…OK
    • Stopping FOGSnapinReplicator.service Service…OK
    • Stopping FOGScheduler.service Service…OK
    • Stopping FOGPingHosts.service Service…OK
    • Stopping FOGSnapinHash.service Service…OK
    • Stopping FOGImageSize.service Service…OK
    • Setting up and starting MySQL…OK
    • Backing up user reports…Done
    • Stopping web service…OK
    • Setting up Apache and PHP files…OK
    • Testing and removing symbolic links if found…OK
    • Backing up old data…OK
    • Copying new files to web folder…OK
      find: /home//fog_web_1.3.5.BACKUP/management/other/: No such file or directory
    • Creating config file…OK
    • Downloading binaries needed…OK
    • Unzipping the binaries…Done
    • Copying binaries where needed…Done
    • Enabling apache and fpm services on boot…OK
    • Creating SSL CA…OK
    • Creating SSL Private Key…OK
    • Creating SSL Certificate…OK
    • Creating auth pub key and cert…OK
    • Resetting SSL Permissions…OK
    • Setting up SSL FOG Server…OK
    • Restarting Apache2 for fog vhost…OK
    • Changing permissions on apache log files…OK
    • Backing up database…OK
    • Updating Database…Failed!

    Then phpmyadmin was still working BUT pointing to http://ipaddress/fog I received the error i told you before: Database Schema Installer / Updater etc…

    Using the command mysql -D fog I received a message about the database non existing.

    I’ve solved the FOG problem with the mysql command ALTER USER ‘root’@‘localhost’ IDENTIFIED WITH mysql_native_password BY ‘’;
    So I’ve installed the database and FOG was up and running but phpmyadmin stopped working (???).

    Then I’ve “resetted” the phpmyadmin installation with the command sudo dpkg-reconfigure phpmyadmin setting user:root password: password

    After that phpmyadmin was ok BUT fog presented the warning messagge “Database Schema Installer/ Updater bla bla bla…”

    Finally in the /var/www/html/fog/lib/fog/config.class.php I’ve set the parameter define(‘DATABASE_PASSWORD’, “password”);

    Now FOG and phpmyadmin are working.



  • @Tom-Elliott

    Thanks Tom,

    unfortunately the installer ended with an error before complete so I’ve missed the message.

    I confirm you that now everything is up and running.

    thanks again,
    Andrea


  • Senior Developer

    I’m lost. What question are you asking?

    When I responded to it the message was asking for the login information.

    As for phpmyadmin, I don’t know what is or isn’t on your system. You shouldn’t have to do anything special to work with phpmyadmin though. How did you install phpmyadmin? YOu might look into using the “source” information rather than the package as Ubuntu has a nasty habit of telling packages exactly what packages MUST be used for things. While this is normal and fine for most things, when it comes to phpMyAdmin, they have decided it MUST contain PHP version 5, but FOG installs PHP version 7.


  • Senior Developer

    It tells you the default information when the installer completes.

    Username: fog
    Password: password



  • Hi,
    I’ve solved using this command in SQL:

    ALTER USER ‘root’@‘localhost’ IDENTIFIED WITH mysql_native_password BY ‘’;

    (found on this forum… sorry for the duplicated post).

    I’ve then installed the database “Fog”. Now I’m in the Management Login page.

    anyway the http://ipaddress/phpmyadmin doesn’t work anymore. How can I restore this functionality?

    thanks again.
    Andrea


Log in to reply
 

557
Online

39008
Users

10721
Topics

101807
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.