Auto Domain joining no working



  • I have two FOG servers a main and storage node that does TFTP and PXE set up mostly following this wiki page: [url]http://www.fogproject.org/wiki/index.php/Multiple_TFTP_servers[/url]. I have done testing and I can get my clients that connect to the storage node (on a separate subnet) to retrieve an image, run FOG and rename the client. But they won’t auto join the domain. There are no issues if they connect to the main server.

    One clue that leads me to believe it has to do with a sync issue between the servers is that I was working on one of the clients when it just rebooted and joined the domain.

    I have used the Fog management page to start the deploy with auto join selected and also tried doing a full register and join the domain after imaging, neither makes a difference.

    How does FOG ‘tell’ a client it should join the domain. Is it in a config file or is there some message sent?

    Mark



  • You set the IP or FQDN of the FOG server when you install the FOG client. That is stored in a config file inside the FOG client install directory. I can’t remember the path off the top of my head but it’s something like C:\Program Files (x86)\FOG\etc\config.ini …or something like that.



  • More info from fog.log
    I left the PC running and sometime during the night it joined the domain. Looking at fog.log which began at 6:50am today I see two groups of entries. Snapin client and Taskreboot . They are running every 10 minutes or so. Taskreboot always reports no tasks waiting. The weird thing is with snapin client. One time they will run and report no tasks waiting, then the next time they run they report they can’t connect to the fog server. It cna’t resolve tco-fog, which is the main server. I thought it should be looking for ths-fog the local server. I think it should have the domain added to the end. Where is the config file I need to edit to change this?

    Here is a small section of the log file:
    7/24/2012 6:51 AM FOG::SnapinClient The remote name could not be resolved: 'tco-fog’
    7/24/2012 6:51 AM FOG::SnapinClient at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    at System.Net.WebClient.DownloadString(Uri address)
    at System.Net.WebClient.DownloadString(String address)
    at FOG.SnapinClient.startWatching()
    7/24/2012 6:51 AM FOG::SnapinClient Sleeping for 1 minute.
    7/24/2012 6:52 AM FOG::TaskReboot Module is active…
    7/24/2012 6:52 AM FOG::TaskReboot Attempting to connect to fog server…
    7/24/2012 6:52 AM FOG::TaskReboot No job exists for 00:1B:78:3E:C3:2D
    7/24/2012 6:52 AM FOG::TaskReboot No task found for client.
    7/24/2012 6:52 AM FOG::SnapinClient Attempting to connect to fog server…
    7/24/2012 6:52 AM FOG::SnapinClient Module is active…
    7/24/2012 6:52 AM FOG::SnapinClient No Tasks found for: 00:1B:78:3E:C3:2D
    7/24/2012 7:04 AM FOG::SnapinClient Attempting to connect to fog server…
    7/24/2012 7:04 AM FOG::SnapinClient Failed to connect to fog server!
    7/24/2012 7:04 AM FOG::TaskReboot Attempting to connect to fog server…
    7/24/2012 7:04 AM FOG::SnapinClient The remote name could not be resolved: 'tco-fog’
    7/24/2012 7:04 AM FOG::SnapinClient at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    at System.Net.WebClient.DownloadString(Uri address)
    at System.Net.WebClient.DownloadString(String address)
    at FOG.SnapinClient.startWatching()

    I will reimage the PC later today and check the log after imaging and see if it tries to join the domain.



  • I will look at the log file today.

    Yes the fog client is installed and the exact same image worked on my bench before I rolled it out to the other building.

    I verified the domain\username was used and that the password is encrypted with fog crypt. I did not use an ou letting it go to the default and then in AD moving the computers to the correct ou.



  • I had a similar issue with domain joining. Look on the client pc that is trying to join and check the fog log in the root c folder. Can you see a message about joining the domain?

    If so there may be two issues:

    1. Have you entered the correct domain username and have you used fog crypt to generate the encrypted password for that user?
    2. If 1 above is correct, try removing the OU settings from fog.

    Those two above sorted that issue for me.



  • Have you installed the fog client in the image you are deploying? [url]http://localhost/fog/client[/url]



  • Works great for me.
    What does the C:\fog.log on the client say? Did you remember to encrypt the password with FOGCrypt? Are you using “domain/username” or just “username”? …etcetera, etcetaera.


Log in to reply
 

438
Online

38939
Users

10697
Topics

101495
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.