Git pull failed



  • Server
    • FOG Version: 1.4.0-RC-9.3
    • OS: CentOS Release 6.8
    Description

    I successfully did a git pull on one system, but when I went to do another, I never got the database schema update screen to load fully and give me the button to update the schema. See attached shots.
    0_1493854447485_fog-update-script.png
    when script gets to this point, here’s what my browser looks like:
    0_1493854467601_fog-update-browser.png
    I have verified that it worked just fine on the other server. Where might I be able to find the error to this server. I have a deployment very soon and this is inconvenient :)



  • Which, after running the install script again, worked fine. Thanks, @Tom-Elliott



  • Here are the results of that:

    [] cd /root/fogproject
    [] git reset --hard
    HEAD is now at ded2598 Use predefined set of cores - 1 for zstd reasonings. Use PIGZ to decompress gzip compressed images rather than relying on seemingly faulty zstd decompression of gzip.
    [] git checkout master
    Branch master set up to track remote branch master from origin.
    Switched to a new branch 'master'
    [] git pull
    Already up-to-date.
    [] git checkout dev-branch
    Switched to branch 'dev-branch'
    [] git pull
    Already up-to-date.
    

  • Senior Developer

    I don’t know what was wrong, but you could simply reclone the repository.

    (It seems to me something was not applied properly).

    Maybe you can try:

    git reset --hard
    git checkout master
    git pull
    git checkout dev-branch
    git pull
    

Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.