Dell 2330 All in One Network issue



  • We have just received a Dell Inspiron All-in-One Pc 2330, very Mac like computer. We currently use Fog for all of our imaging and we really want to use it for this setup. I have tried several kernels to no avail. This says it has an Atheros Chipset and I am able to get to the Fog screen but unable to image it or inventory. I have run debug mode and the network always fails. I was wondering if anyone has made a custom kernel that I could try or if anyone has tried to image the All-In-Ones from Dell. They are new this summer and would be great to get rid of all the wires we currently have to deal with. I says during PXE boot…
    Intel UNDI PXE 2.0
    Atheros PCIE v2.1.0.9

    Like I said I can get to the FOG screen but never image it or inventory the PC…

    Thanks for any input.

    Andy



  • Excellent. Copying the file from pen drive to the \kernel folder proved to be a problem, but managed to resolve that. It took a while to load but full inventory of computer completed successfully and imaging the laptop now.

    Really, really appreciate your help, don’t know how to thank you.

    Brilliant.
    RRM



  • The School I work at use eduproxy.bgfl.org and it seem to block everything !!!
    I’m downloading on a Windows computer at home now, it’s coming down as a .txt file?

    Really appreciate your help with this. Thank you so much.
    RRM


  • Senior Developer

    Who’s firewall is preventing access? I’m sure my side is proper. Also, add the note that I recreated the kernel yesterday and we now have 3.12.1 up, same as before though with networking.



  • Hi Thanks, can’t get to the file from work, the firewall preventing access will have to download tonight or find another way to get it and try.
    Will let you know how I get on.
    Cheers
    RRM


  • Senior Developer

    Try my kernel.

    [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]

    It’s based on 3.12.0 and has support for, basically, all linux network drivers available within the kernel including 817x



  • Brilliant thank you so much for the help.
    It reports
    Network …[Fail]
    Disk…[Pass]

    [FONT=Calibri][COLOR=#1f497d]It’s an Atheros AR8171/8175 PCI-E Gigabit Ethernet Controller(NDIS 6.30) in the laptop. Which is slightly newer(?) than the one mentioned in this thread.[/COLOR][/FONT]

    [FONT=Calibri][COLOR=#1f497d]I tried update kernel via the FOG server and it never seems to do anything.[/COLOR][/FONT]

    [FONT=Calibri][COLOR=#1f497d]Will try what you suggested.[/COLOR][/FONT]

    [FONT=Calibri][COLOR=#1f497d]Thanks[/COLOR][/FONT]
    [FONT=Calibri][COLOR=#1f497d]RRM[/COLOR][/FONT]


  • Developer

    [FONT=Tahoma]RRM,[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]Please open a new thread, this is an old thread, pertaining specifically to the Dell 2330. Yes it does have the Atheros card, but is the atheros card the exact same? the unit included in the dells is the Atheros AR8161/8165.[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]While you are welcome to try the kernel suggestions in this thread, it would be more beneficial to start your own.[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]That being said. Welcome to the forums. I need you to first try to run a [/FONT]compatibility test on the units in question, this will tell us specifically the part that is not supported.
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]To [/FONT]Run a compatibility test.
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]From the fog PXE boot menu, you will see:[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]Boot from hard disk[/FONT]
    [FONT=Tahoma]Run memtest86[/FONT]
    [FONT=Tahoma]Quick host registration and Inventroy[/FONT]
    [FONT=Tahoma]Perform full host registration and Inventory[/FONT]
    [FONT=Tahoma]Quick Image[/FONT]
    [FONT=Tahoma]Client system information[/FONT]
    [FONT=Tahoma]Debug Mode[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]A. Choose Client System Information[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]B. Your computer will load another menu and it will look like this:[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]1.) Reboot[/FONT]
    [FONT=Tahoma]2.) IP Information[/FONT]
    [FONT=Tahoma]3.) Partition Information[/FONT]
    [FONT=Tahoma]4.) Check FOG compatability[/FONT]
    [FONT=Tahoma]5.) Ping a Host[/FONT]
    [FONT=Tahoma]6.) Display MAC Address[/FONT]
    [FONT=Tahoma]7.) Show DMI Information[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]C. Type 4 and press Enter[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]This will return the problem devices.[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]After collecting the information on the devices not supported, you can create a custom kernel tailored specifically to YOUR needs.[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]Ozzy has made a WONDERFUL walkthru on how to create a custom kernel AND include the drivers you need,[url]http://fogproject.org/forum/threads/request-for-kernel-compiling-info-please-read.4045/[/url][/FONT]
    [FONT=Tahoma]Look at post number 2.[/FONT]
    [FONT=Tahoma] [/FONT]
    [FONT=Tahoma]If you still have issues, we would be happy to help you troubleshoot them, just create your own thread.[/FONT]

    [FONT=Tahoma] [/FONT]



  • Hi all,
    new to this, I unzipped the driver supplied and replaced it for the original bzImage file. Tried to boot to FOG and I still get the same problem. It’s a Toshiba Satellite Pro C50-A-15Q. It is an Atheros network card, any help really appreciated. Be gently and give detailed instructions as I am new to both Linux and FOG.

    Thanks
    RRM



  • We have a new laptop, using the Atheros 8161 ethernet controller problem, so we’ve compiled compatible with kernel version 3.5.4 kitchensink driver (ALX).



  • Here’s an issue my customer is having with her computer. She has Windows 8 BTW:

    [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff][SIZE=3][COLOR=#000000]PLATFORM VERSION INFO
    Windows : 6.2.9200.0 (Win32NT)
    Common Language Runtime : 4.0.30319.18051
    System.Deployment.dll : 4.0.30319.17929 built by: FX45RTMREL
    clr.dll : 4.0.30319.18051 built by: FX45RTMGDR
    dfdll.dll : 4.0.30319.17929 built by: FX45RTMREL
    dfshim.dll : 4.0.41209.0 (Main.041209-0000)[/COLOR][/SIZE][/COLOR][/FONT][/SIZE]
    [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
    [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff][SIZE=3][COLOR=#000000]SOURCES
    Deployment url :[/COLOR][/SIZE][COLOR=#2862c5][U][SIZE=3][COLOR=#000000]file:///C:/Users/Gloria/AppData/Roaming/Microsoft/Windows/Start%20Menu/Programs/Dell/Dell%20System%20Detect.appref-ms%7C[/COLOR][/SIZE][/U][/COLOR]
    [SIZE=3][COLOR=#000000] Server : Microsoft-IIS/7.0
    X-Powered-By : [URL=‘http://asp.net/’][COLOR=#2862c5][U]ASP.NET[/U][/COLOR][/URL]
    Deployment Provider url :[/COLOR][/SIZE][URL=‘http://downloads.dell.com/tools/dellsystemdetect/DellSystemDetect.application’][COLOR=#2862c5][U][SIZE=3][COLOR=#000000]http://downloads.dell.com/tools/dellsystemdetect/DellSystemDetect.application[/COLOR][/SIZE][/U][/COLOR][/URL][/COLOR][/FONT][/SIZE]
    [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
    [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff][SIZE=3][COLOR=#000000]ERROR SUMMARY
    Below is a summary of the errors, details of these errors are listed later in the log.

    • Activation of C:\Users\Gloria\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Dell\Dell System Detect.appref-ms| resulted in exception. Following failure messages were detected:
    • Value does not fall within the expected range.[/COLOR][/SIZE][/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff][SIZE=3][COLOR=#000000]COMPONENT STORE TRANSACTION FAILURE SUMMARY
      No transaction error was detected.[/COLOR][/SIZE][/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff]WARNINGS
      There were no warnings during this operation.[/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff]OPERATION PROGRESS STATUS
    • [9/24/2013 12:38:10 PM] : Activation of C:\Users\Gloria\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Dell\Dell System Detect.appref-ms| has started.
    • [9/24/2013 12:38:10 PM] : Performing necessary update check as specified by the deployment.[/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff]ERROR DETAILS
      Following errors were detected during this operation.
    • [9/24/2013 12:38:12 PM] System.ArgumentException
    • Value does not fall within the expected range.
    • Source: System.Deployment
    • Stack trace:
      at System.Deployment.Application.NativeMethods.CorLaunchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)
      at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
      at System.Deployment.Application.SubscriptionStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
      at System.Deployment.Application.ApplicationActivator.Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)
      at System.Deployment.Application.ApplicationActivator.ProcessOrFollowShortcut(String shortcutFile, String& errorPageUrl, TempFile& deployFile)
      at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
      at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)[/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff]COMPONENT STORE TRANSACTION DETAILS
      No transaction information is available.[/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff] [/COLOR][/FONT][/SIZE]
      [SIZE=3][FONT=Comic Sans MS][COLOR=#8000ff]Can someone please tell me what this means. Thanks. [/COLOR][/FONT][/SIZE]


  • [quote=“kingofl337, post: 12809, member: 6032”]Does anyone know how DaveO incorporated the 8161 driver into the kernel? I’d like to learn how for future use.

    All the examples I’ve found are to build a module, instead of incorporating it into the kernel image.[/quote]

    Found some notes on how we did it. I will just paste them here. It has been a long time since this was done so hopefully these still help. Looks like you will need to find a new location to download the add-alx-next-20120228 patch.


    Compile kernel with ar8161 support

    $ cd /usr/src

    $ wget [B][url]http://www.kernel.org/pub/linux/kernel/v3.x/linux-3.5.4.tar.bz2[/url][/B]

    $ sudo tar -xf linux-3.5.4.tar.bz2

    $ cd linux-3.5.4

    $ wget [B][url]http://bombadil.infradead.org/~mcgrof/2012/02/28/add-alx-next-20120228.patch[/url][/B]

    $ sudo patch -p1 < add-alx-next-20120228.patch

    $ sudo cp /opt/fog-setup/fog_0.32/kernel/kitchensink.config .config

    $ sudo make menuconfig

    Enable alx driver: Device Drivers > Network device support > Ethernet driver support > Atheros ALX Gigabit Ethernet support

    $ sudo make bzImage

    Resources used:

    [B][url]http://www.gossamer-threads.com/lists/linux/kernel/1513700[/url][/B]

    [B][url]http://askubuntu.com/questions/165192/how-do-i-install-drivers-for-the-atheros-ar8161-ethernet-controller[/url][/B]

    [B][url]http://forums.gentoo.org/viewtopic-t-931478.html[/url][/B]



  • Does anyone know how DaveO incorporated the 8161 driver into the kernel? I’d like to learn how for future use.

    All the examples I’ve found are to build a module, instead of incorporating it into the kernel image.



  • THANK YOU! You saved my summer.



  • We were having issues with new laptops that use the Atheros 8161 Ethernet controller so we have compiled the compat-drivers (alx) with Kernel version 3.5.4-kitchensink. Here is a link to the download for anyone that needs it: [URL=‘http://davidouwinga.com/bzImage.zip’]http://www.davidouwinga.com/bzImage.zip[/URL]
    You will need to extract the zip file and move the bzImage file to /tftpboot/fog/kernel/ as root


  • Moderator


  • Moderator

    There is beta support for the atheros card ar8161/8165. Link to how to add it to kernel is in 3360 thread.



  • So while we are waiting for the kernel to be patched/ updated, my boss, bought four of the Optiplex 9010 All-in-One models. We got them down to $800 which is a great deal since they were 1300. Anyway Fog works with these!!! This is fantastic news and we will begin to roll these out as our base models for our teachers. The look is great, less cords, and large 23" inch screen is just nice on the eyes. Still look forward to the new kernel and whatever else Fog has to offer down the line.



  • hey guys there was a similar thread on the 3360 which has the same chipset. I resorted to ghostcasting but after doing 8 successfully its not working any more.

    Would love if there was some way to get a kernel for this sorted, we would make a donation to anybody who did!



  • [quote=“chad-bisd, post: 5568, member: 18”]A quick search of the web shows little hope for the Atheros AR8161/8165 being supported in any version of Linux at this time. I’ve been to the OpenSUSE and Fedora forums and neither of them have support for the device.

    You’ll have to wait for someone to create/modify a device driver module. If you just have to get this done, you might try a USB to ethernet adapter. I have a kernel that supports the Asix AX88772B.[/quote]

    Okay, i may try a USB adapter but i am hopeful that we may get a kernel working. Also hope that the Optiplex version may have an older NIC driver…

    Andy


Log in to reply
 

395
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.