• Recent
    • Unsolved
    • Tags
    • Popular
    • Users
    • Groups
    • Search
    • Register
    • Login

    1.6 Migration via new Install with no DB Transfer

    Scheduled Pinned Locked Moved Unsolved FOG Problems
    fog 1.6clientagent1.6ca ssl
    1 Posts 1 Posters 2 Views
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • C
      Coolguy3289
      last edited by Coolguy3289

      I just did a massive overhaul on our fog service, migrating directly into 1.6 by running a new server from scratch rather than a database migration (there were some Foreign Key check failures on the in-place upgrade), and for the most part everything seems to be working except reliable agent communication. Both on the old and new agent I’m having a bitch of a time with the CA communication.

      When using the new agent from the GitHub, I get a 503 error, so referencing the apache error logs gives me a bit of insight:
      Got error 'PHP message: FOG agent enroll: signing for host 387 from 10.1.60.40 failed: the issued certificate does not verify against /opt/fog/snapins/ssl/CA/.fogCA.pem'

      In this instance, this was a fresh agent install, so I’m not sure what cert is being compared to what. I’m assuming until told otherwise that my FOG Generated PKI is foobar for production use, but I’m unsure of the steps to even take in this instance.

      1 Reply Last reply Reply Quote 0
      • 1 / 1
      • First post
        Last post

      48

      Online

      12.8k

      Users

      17.6k

      Topics

      157.2k

      Posts
      Copyright © 2012-2026 FOG Project