SOLVED Capture failed with step clearing ntfs flag failed

  • Server
    • FOG Version: 1.3.5 SVN 6067
    • OS: CentOs 7.2
    • Service Version:
    • OS: Windows 7

    I try to capture an image from a HP prodesk 400 G3 but it always failed after the resize. It complains about maybe the Windows filesystem as an ntfs flag error. Before I run the capture, I run a chkdsk and even with Gparted I run a check on both partition, the boot and the OS partition but Nothing change. Before the resize when Fog try to cleaning the NTFS flag, it’s always in error with reg file not found.

    I try to ftp the image server with the user fog to test if it’s a connection problem but it’s working I can browse the /images folder and create folder. When the upload task begin, a folder in dev folder is created.

    After that my Windows 7 can’t boot and give me a BCD boot error. I need to deploy a image on it to correct it.

    I have enough space on the server too.

    Thanks for your help

  • @Tom-Elliott Thanks Tom, the update resolved the issue. I upgraded to 1.4.0-RC7.

  • @gchartrandCRL Might I suggest you try out the RC-6 of 1.4.0? 1.3.5 had a lot going for it in regards to disk resizing but it still wasn’t quite right. 1.4.0-RC-1 addressed a couple more issues, and I think 1.4.0-RC-3 was intended to fix the alignment issues that could happen on occasion. Mind updating to the RC and trying to capture the image? I know it likely means you need to rebuild the image, but it should work better.

    Also, when building your image, please make sure to disable fast boot.

  • @Quazz
    it’s a brand new machine with SSD drive. I didn’t have problem when I deploy an image on it, it’s work fine. I try to run a chkdsk on both partition, the reserved one and the OS, no error at all. But when I try to capture it to another image, it’s failed and leave the reserved partition in RaW mode and shrink the partition to less possible.

  • Moderator

    Failure to read NTFS $Bitmap is a serious one, indicating that either the filesystem needs to be repaired or the disk is dying. (broken sectors).

    You can check the latter with certain SMART tools (eg Crystaldisk on Windows)

    If the disk is fine, then you should first to use ntfsfix (boot a Linux livecd):

    sudo ntfsfix /dev/sdXX

    Try again and see if this helps, if it does not then, you should run chkdsk on both partitions. For that, you’ll have to temporarily set a drive letter to the boot partition, though, since chkdsk can only use drive letters and it doesn’t have one by default.

    You may have to use chkdsk /r instead of chkdsk /f if you’re using a traditional hard drive. This will take far longer, but if there are sector issues (non hardware based), this is the way to go.

  • Hi, I try the wiki, but the way 1 didn’t work, the system said is already off, the way 2, I always reboot the Pc for capture and try the way 3 didn’t help.
    Here is the 2 screen capture
    0_1492616884947_IMG_2872.JPG !

  • Moderator

    @gchartrandCRL could you post a clear picture of the error message taken with mobile phone. The context of the error is just as important as the error.

    it sounds like the ntfs dirty flag is set on that disk. The screen shot will tell us more.