HostNameChanger unable to join domain V1.3.4

  • I’ve setup a computer as normal. I’ve always just before imaging removed the computer off the domain and renamed the computername to something random. Capture the image and deploy to my lab. Since my upgrade from 1.2.4 to 1.3.4 no computer will join the domain automactially.
    The computer name is correctly changed, just no joining onto the domain. In the fog.log I get
    HostnameChanger Hostname is correct
    HostnameChanger Attempting to join domain
    HostnameChanger Logon failure: unknown username or bad password, code = 1326.

    I can manually add any of these computers to the domain, confirming the username and password is correct.
    In fog settings I’ve tried only using the FOG_AD_DEFAULT_PASSWORD, allowing it to encrypt the password for me. I’ve tried only using FOG_AD_DEFAULT_PASSWORD_LEGACY, with me using FOGCrypt.exe to first encrypt my password. I’ve also tried both being set.

    I also tried removing the newer fog service of the computer and restoring the original on the computer. No change. Not sure what to try next.

  • This is a Face Palm picnic error!

    I was updating the main fog settings. I was thinking if I changed that setting it would change it for all hosts. I forgot I have to edit the host information to make a change to a existing host. (Did this via a group)

    Still, my username and password hadn’t changed between the fog upgrade, so something was wrong, but I should have spotted my error when trouble shooting 🙂

    This ticket can be closed

  • I forgot to say all the computers are running win7 pro