UNSOLVED problem accessing database

  • Server
    • FOG Version: 1.3.5 RC14
    • OS: centos 6.4
    • OS: windows 7

    when i try to capture windows 7, i get an errors about updating the database
    i’ve attached 2 screen shots:

    thanks for help

  • @oraniko Either you want us to help you fix the issue or you want to do your own thing.

    FOG RC 15 and 16 where both released 15 actually hopefully having a fix to the problem you’re describing.

    If you really want to go back to 1.3.3 that’s up to you, but doesn’t help us fix what the problem actually is.

  • ok ok guys
    i just downgrade to version 1.3.3 and it’s all working fine
    i think there is a bug in version 1.3.5 rc14

  • i changed fog home directory and now i can change folder to /images/dev
    usermod --home / fog
    and i also can create folders and files in there (from the ftp fog user).
    but the same error persists 😞

  • Moderator

    @oraniko can you issue a cd /images/dev command in ftp?

  • ok
    i can connect from windows by ftp to fog server
    but all i can see is 0_1489592196062_1.jpg

  • Moderator

    @oraniko if Q1 is yes then there is probably a ftp issue.

    Can you connect to the fog server from a windows computer using FTP? Using the user ID and password you setup for fog (btw: password == password is not quite secure. I would have ensured the linux “fog” password matched what was in the fog management gui not the other way around). The linux fog account doesn’t have any impact on the web gui management account (also called fog). They are two different accounts.

    back on point, connect to the fog server using ftp from a windows computer. change to the /images/dev directory see if you can upload any file there. Any small file is fine. I want to ensure you can upload to /images/dev. Then using ftp move that uploaded file from /images/dev to /images. If you can do that then the permissions are correct on the /images directory structure and the root of the issue is/was just the linux fog account’s password.

  • hey thanks for the fast reply
    here’s what i already checked:

    1. ls -la /images/dev there’s a directory with the same name as the mac address i’m trying to capture.
    2. i already try “passwd fog” and gave it “password” as fog password.
    3. in the fog gui - in fog settings - tftp server i changed the password of fog_tftp_ftp_password to “password”.
    4. in the fog gui - storage management i changed management password to “password” (user is still “fog”).
    5. i tryied to restart vsftpd service.

    and i’m still getting the same error.
    what i’m missing here?

  • Moderator

    My initial reaction is that you need to confirm/ensure that the linux user (fog)'s password is consistent with the value kept in the FOG management gui.

    As a quick check on the fog server linux console run this command ls -la /images/dev if there is a directory in there the same name as the mac address your trying to capture then you have a linux fog user password issue.

    I realize the error message says it can’t update the database, that error message is a bit inaccurate for what I think is going on.

    Here is a troubleshooting guide that may be helpful: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP