SOLVED Dell XPS13 with Displaylink DA100

  • @Junkhacker Hi Junkhacker, yes I tried both ports, on the right side and also on the left - no difference. Which one worked for you for see the PXE option ?

  • Developer

    @froydo i believe i’ve worked on that model before. it only supports pxe with a supported usb nic, and i think you even have to get the right usb port (that model has usb 3.0 on one side and 2.0 on the other, right?)

  • Hi Tom,

    Thanks for the quick reply. I’ve confirmed the displaylink dock is working fine within Windows in the Dell laptop and it can see the network where I normally do my PXE boot to work with my lenovo machines.

    And I tried the boot options and tried other changes UEFI and Boot options - and there’s never a network or even a USB device option other than the internal Samsung SSD appearing at any time when I try to stop and check it after going through the reboot cycles. Just trying to “dig out” the network PXE boot option, and I’ve looked through the entire BIOS even the areas I don’t think its there. But thanks for your suggestions - so looks like the dock might not support PXE boot and hence does not appear in BIOS .

  • @froydo Just making changes on a “whim” is not a good way to figure things out.

    This is because the way an OS is installed somewhat depends on these bios settings. Changing From “UEFI” to “Legacy” is not a good thing because the OS installed is not layed out as the legacy mode would be expecting.

    I’d start by looking at BIOS Setup. You could change “Boot mode settings” but if your device has a NIC and the device is recognizing the Dock and/or device at BiOS time, the option to pxe boot should be there. It may not be immediately obvious though and depends solely on the BIOS and your willingness to look around.

    It’s easy to just “give up” when you see a bunch of things and feel like you’re being rushed.

    To me, it sounds like either the dock is not recognized (if it is indeed connected to the dock) or the USB NIC does not support PXE booting.

  • @george1421 The CBC_MDM (or whatever it was) has not been removed because of that issue 4 weeks ago. Just trying to give a bit of “piece of mind” here.

  • hi Tom,

    Yes, the Dell Bios is very limited. But need your advice please. Once I boot into BIOS, I see

    Boot mode is set to UEFI: Secure BootL Off

    Legacy Boot:
    Minicard SSD
    Windows Boot Manager
    UEFI: Samsung SSD PM851 M.2 2280 256GB
    Other Options:
    BIOS Setup
    BIOS Flash Update
    Change Boot Mode Settings

    So I tried to change from UEFI to legacy by going into “BIOS Setup” in “Other options”
    And in Boot Sequence I only see:

    • Windows Boot Manager (checked)
    • UEFI :Samsung SSD (checked)

    Boot list option

    • Legacy
    • UEFI (checked)

    In Advanced Boot Options

    • Enable Legacy Option ROMs (checked)
    • Enable UEFI Network stack (checked)

    I don’t see network boot anywhere or the Enable PXE stack as you mentioned.

    And when I check - “Legacy” in the “Boot list option” , “UEFI” automatically becomes unchecked and the boot sequence changes to :

    • diskette drive
    • usb storage device
    • CD/DVD/CD-RW Drive
    • Minicard SSD

    But still no network boot option.
    And if I boot with this legacy option:
    I get a message " No Boot Device Found, Press any key to reboot the machine"

    Any ideas ?

  • Moderator

    @Tom-Elliott There was an issue about 4 weeks ago where we needed to add back in two kernel drivers CBC MDM, or something like that Sebastian was also part of that discussion. But those were needed for the DisplayLink adapters to work.

    For the OP in UEFI mode the firmware has to support the network adapter. If this is an official dell XPS dock then it “should” support uefi mode pxe booting. There are a lot of generic docks that use these display link adapters too.
    As Tom noted, a lot of times pxe booting or the PXE stack is disabled by default in the firmware. Since the ethernet adapter and dock are external there isn’t the tight integration as with a laptop with a built in network adapter.

  • I might also suggest you update.

    1.3.4 is the latest “stable” version, and 1.3.5 RC 12 is the latest “testing” version.

  • From the sounds of things, the device is attempting to boot UEFI mode (based on the menu options you are able to see.)

    I don’t know what your BIOS looks like, but most systems have a means to “Enable PXE Stack” and what not.

  • This is most likely something you have to define in the BIOS.