SOLVED Hard drive resize is not expanding

  • Description
    • FOG Version: 1.3.5 RC 7
    • OS: RedHat
    • Service Version:
    • OS: Windows 10 Enterprise

    We just noticed today that since updating to version 1.3.4 the hard drives are not expanding to use the rest of the HDD. I saw someone else had a similar issue, so I updated to 1.3.5 RC 7 and that did not fix the issue. Once the update did not fix the issue I thought maybe it was the image since I had uploaded it after updating to 1.3.4, but I used an older image and it had the same issue. As of this evening I’ve only been able to test this out with our UEFI image. I’ll try to see if we have the same issue with our BIOS image in the morning.

  • @Tom-Elliott Yep, that was my issue. I’ve updated to RC12 and from what testing that I have done, it seems that everything is working. I’m able to go from a 160GB to a 256GB and also 500GB drive and boot into Windows as well. The resizing seems to be correct as well.

  • @Doctrg Can you check disk space?

  • @Tom-Elliott I’m trying to go through the installer this morning and it is failing on Backing up database.

  • If you already installed, Please re-run the installer. I found a small issue in the approach yesterday and believe it has now been corrected for.

    Let me know if it works, or doesn’t.

    Thank you,

  • @Doctrg, @andreas.paul If you can try out RC-11 hopefully things will work better for you.

    I’ve released RC-11 to try to get more people testing as well. I’m hearing some success and others not so much. Just trying to get things worked out. I know I must be close by now.

    Thing’s I’ve personally tested in regards to resizable images.

    1. MBR -> Win 7 no extended partition.
      • Originating disk 60GB
      • Smaller disk 30GB
      • Larger disk 80GB
    2. MBR -> CentOS 7 no extended partition.
      • Originating disk 60GB
      • Smaller disk 30GB
      • Larger disk 80GB
    3. MBR -> CentOS 7 with Extended partition.
      • Originating disk 60GB
      • Smaller disk 30GB
      • Larger disk 80GB
    4. GPT/EFI Win 10
      • Originating disk 60GB
      • Smaller disk 30GB
      • Larger disk 80GB
    5. GPT/EFI CentOS 7
      • Originating disk 60GB
      • Smaller disk 30GB
      • Larger disk 80GB

  • Hi,

    yesterday i deploey a windows 10 around 10 times and today after the update he toled me 700mb free. But for now it’s working again. Don`t know what was wrong today morning :-D.

    Don’t take care, thanks, i will have an eye on it.



  • @andreas.paul What do you mean “with the older version it as worked”?

    What older version?

  • Hi,

    i’ve updated to 1.3.5-RC-10, and i have the same issue now. I have an image with 2 Partitions “System Reservated” + C:\ and seems that the partion is also not expand to the size of the harddisk. Yesterday with the older version it has worked.



  • I’m excited to hear news (hopefully good, but anything really) when you get a chance. Thank you.

  • A lot of work has been done on this and so far I think we’re on the right path.

    The latest init’s are up and ready for more testing, just needing @Doctrg to run the test.

    He’s already tested simply deploying back and it’s giving him some issues with the first partition (saying the partition is smaller than the source). I think this is because of the “math” that was being done originally up until I corrected around it last night.

    With any luck, however, a fresh upload will enable this image to be deployed to smaller/larger systems.

  • Please re-run the installer and try again?

    I know it’s a lot of back and forth, but it should work (hopefully).

    At least the original and new sizes appear to be expanding on the same originating disk, I have not yet had the chance to test orig < smaller drive and orig > larger drive yet. Just same size disk for now. All appears to be working atleast in that regard.

  • Using sysprep and an answerfile you can add:


    To the specialize phase.

    See ExtendOSPartition.

  • @Tom-Elliott Not a problem. If you guys were here I’d buy y’all a round.

  • @Doctrg I know I’m sounding rude here.

    I’m not worried, right now, that it’s not booting, I believe I know why it’s not and am trying to figure that part out, but it can wait for the moment. (it should work, and I don’t know why it’s not, but for now I don’t care about it – I know it is important trust me).

    I’m trying to work out what to do to fix the expanding in GPT layouts though, as this was severely broken and has been broken for a very long time.

  • @Tom-Elliott On the 256GB drive it did not resize. It came up showing as a 40GB drive when running fdisk -l /dev/sda. The drive size showed correct on the 500GB drive due to it being the size it was created on originally. Neither could boot into Windows though.

  • Did it not resize at all or did it not resize as you are “expecting” it to?

  • @Tom-Elliott Sorry, the GPT image did not resize correctly.

  • @Doctrg I’m not sure i understand here.

    You’re saying it DID or DIDN’T resize the partition? I understand the “blow-up” part just want to understand the rest.

  • @Tom-Elliott I’m glad it is not just me… I don’t have much hair on top of my head to pull out. I do thank you for your guidence on the bios image as recapturing it fixed that issue. I re-ran the FOG installer and my main server and storage nodes are now on 1.3.5 RC-10. I tried deploying the GPT image and it still did not expand the disk size. It did however it did not resize and it blew-up Windows. It is acting as if the Start-End of the partitions is not correct.