• Server
    • FOG Version: 1.2.0
    • OS: Ubuntu
    • Service Version:
    • OS:


    I tried to install the last version (1.3.4). On my server there is already the version 1.2.0.
    When I install the new version, I get some messages :

    * Skipping package: php7.1......................................(Does not exist)
    * Skipping package: php7.1-bcmath.........................(Does not exist)
    * Skipping package: php7.1-cli..................................(Does not exist)
    * Skipping package: php7.1-curl...............................(Does not exist)

    Then I get another error, at the end:

    * Stopping web service............................................Failed!

    Do you have any idea ?

    Thank you very much.

  • @mimi1255 If your current issues are not related to the original problem in this thread, please start a new thread - and we will gladly help you there.

  • Developer

    @george1421 well, unfortunately, the file naming conventions and formatting hasn’t always been the clearest. it’s gotten a lot better, even if i don’t think what we use now is perfect

  • Moderator

    @Junkhacker Well then my confidence level now is 0% I know what I’m speaking about.

  • Developer

    @george1421 from the list of files in that image’s directory, that was definitely not a partimage image. any image folder that contains the files
    are partclone

    image folders that contain image files with the naming format
    also may be partclone, from before the naming convention was changed

  • Moderator

    @mimi1255 I don’t feel 100% confident with this statement (simply since I don’t have any experience with 1.2.0 stable or before).

    I would say if the directory has this file sys.img.000 then its in partimage format. If it has d1p1.img it is (current FOG 1.3.x) partclone format. As for the OS, I would hope you knew what the captured image was. The other option like you found out is trial and error.

  • @george1421 I tried again, I changed the OS and the Image type. And now it works. !
    But is it possible to know settings for each old image (OS, image type, etc…) ?


  • Moderator

    @george1421 just for clarity this is what a Partclone format looks like.

    d1.fixed_size_partitions  d1.original.fstypes    d1p2.img
    d1.mbr                    d1.original.swapuuids  d1p3.img
    d1.minimum.partitions     d1p1.img               d1.partitions
  • Moderator

    @mimi1255 I would say that looks like the older format (just guessing since its not the same structure as one of my images).

    So what we need to enable is a FOG option to let you show the Image Manager in the on the image definition page.

    Go to this FOG setting and enable it.
    FOG Configuration->FOG System Settings->General Settings(section)->FOG_FORMAT_FLAG_IN_GUI

    Then go back to the image definiton and change the Image Manager from partclone to partimage.

  • @george1421 Below the result:
    administrateur@SRVFOG:/images$ ls -la /images/DellLatitudeE6320model
    total 3172580
    drwxrwxrwx 2 administrateur administrateur 4096 févr. 16 08:23 .
    drwxrwxrwx 14 root root 4096 févr. 16 09:19 …
    -rwxrwxrwx 1 administrateur administrateur 2 févr. 16 08:23 d1.fixed_size_partitions
    -rwxrwxrwx 1 administrateur administrateur 15 févr. 16 08:23 d1.original.fstypes
    -rwxrwxrwx 1 administrateur administrateur 259 févr. 16 08:23 d1.original.partitions
    -rwxrwxrwx 1 administrateur administrateur 0 févr. 16 08:23 d1.original.swapuuids
    -rwxrwxrwx 1 administrateur administrateur 8673377 févr. 16 08:23 rec.img.000
    -rwxrwxrwx 1 administrateur administrateur 3240019543 févr. 16 08:24 sys.img.000

  • Moderator

    @mimi1255 Was this image originally captured with a pre 1.2.0 version of FOG?

    Also could you post the results of this command? ls -la /images/DellLatitudeE6320model What I’m thinking is the image format may be the older style. We can fix this, I just need to be sure. We “may” also have to get a developer to look at this since I don’t remember the older version of fog anymore.

  • @george1421 Sorry, I have a problem…

  • Moderator

    @mimi1255 Yes and no.

    That number is entered by the FOS engine as it captures the image. Since you “side loaded” the images into the fog server that value will be zero. No worries its just an informational value. The system will deploy without issue.

  • @george1421
    I followed your message.

    But is it normal that the Image size is 0 ?

    0_1487249197871_16-02-2017 13-44-35.jpg

  • Moderator

    @mimi1255 This part of the process is a bit labor intensive.

    1. Go into image management and create new image
    2. Set the image name to match the directory name of the first image in /images (hint: use cut and paste if you are connected to the fog server using putty to ensure you get name exact)
    3. Set the storage group
    4. Operating system to match the image on disk
    5. The image path should match what you keyed in as the image name.
    6. The next one is going to be the tricky one. You need to set the image type to match (exactly) what was captured. Migrating from 1.2.0 you probably used single disk non-resizable.
    7. Partitions: everything
    8. And for compression leave it at 6

  • @george1421 said in Upgrade version:

    Just remember with FOG there are the physical files in /images that need to be moved and then you need to update the fog database (via the web gui) to define the images you moved in /images.

    I moved images to the new server in the /images.
    But now how can I do to update the fog database via the web gui ?


  • @george1421 Now it works ! Perfect ! Tomorrow I will try to move my old images to the new fog server.

  • Developer

    @mimi1255 George beat me to it!

  • Moderator

    @mimi1255 No what Tom recommended is that you upgrade FOG to the RC release. Using this process

    git clone https://github.com/fogproject/fogproject.git
    cd fogproject
    git checkout dev-branch
    cd bin
    ./installfog.sh -y

    The git checkout dev-branch will put you at the latest dev release.

  • @Tom-Elliott I installed the kernel, is it right ?