UNSOLVED Can't restore image, exit code 1. Missing partition number.

  • Server
    • FOG Version: 1.3.4 revision 6064
    • OS: 14.04.5
    • Service Version:
    • OS: Windows 10

    I created Windows 10 image from scratch using 250GB HDD and selected Single Disk - Resizable when uploading this image. I was able to restore it using 250HDD or large. Whenever I restore it to a 160GB HDD, I will get “Target partition size (336MB) is smaller than source (349MB). Use option -C to disable size checking (Dangerous)” and “Image failed to restore and exited with exit code 1 (writeImage).” I’ve checked d1.fixed_size_partitions file; partition number seems to be missing. After adding “1” in that file and I was able to restore the image to a 160GB HDD. Is there a quick fix for this or should I wait until the next official release? Thank you.

  • @Tom-Elliott

    It was on Raid, so I changed to AHCI. No Joy, still get the same message.

  • @chanter20001 Enter your BIOS first and see if disk mode is set to SATA/AHCI or RAID mode. Change from RAID to AHCI if possible.

  • @Tom-Elliott

    Interesting, this is a single drive system.

    Are there instructions on how to set the partition number during the imaging process?

    Thanks for your help on this matter.

  • Mind you this likely means you need to re-capture the image as the partition number it’s missing is specific to the file missing in the image. Typically, this could also indicate the HDD is not being recognized as a valid HDD we can image, (Most likely setup in RAID mode within the BIOS rather than AHCI/ATA)

  • Hello, has there been a solution found to this issue. I am trying to image a Dell Optiplex 3050 (right out of the box) and getting the same issue. I am running Fog Server 1.4.3 and for some reason I am unable to get this pc to image.

    I have it booting with UEFI disabled.
    It has a Toshiba THNSNK256GCS8 Sata 256GB SSD Drive in it.
    The biggest issue here: I am new to Linux and especially to FOG!

    Any help would be appreciated.

  • Thanks @Tom-Elliott I pulled/update using git but still does not work. I got same error as before.

  • Sorry I took so long to respond, please re-pull and rerun the installer. I think I finally got it (with any luck at least).

  • Thanks @Tom-Elliott for your prompt response.

    I upgraded my test server to 1.3.5RC5 using git method. Same issue. Partition number is still missing.

  • @TaTa, that currently IS the fix. You can try the 1.3.5-RC-1 release to see if uploading properly generates the fixed size partitions.

    The problem, as it stands, is trying to figure out the lesser of two evils.

    Either I can implicitly define the first partition as fixed always or try to have it auto detect. The code base has been updated to try to correct this behaviour but I don’t have any images with strange partition layouts that i could try.