UNSOLVED Issues with advanced tasks

  • Server
    • FOG Version: 1.3.3
    • OS: Debian Jessie
    • Service Version:
    • OS: Win7

    I’m using 1.3.3. I’ve tried the following advanced tasks, clamav and donate. Both report errors and reboot.
    Clamav complains it can’t mount /opt/fog/clamav that is because there is no clamav in /opt/fog

    /opt/fog# ls
    log service snapins

    Donate lets me know it can be stopped if I press a key, it going looking for servers, says it will power down the monitor, then a message says “/bin/fog.donate.monitor: line 8: clearscreen: command not found”

    It then reboots and ends the task.

    Mem test works.
    Haven’t been able to test other tasks

  • @kibade I don’t know if the donate option still works as it was compiled from long ago, but I did see the issue about the clearScreen. I’ve pushed a fix for the clearScreen issue.

    I’m not planning to work on anything for the clamav tasking as the intention is to have it mount the clamav portion from an NFS (of which you would need to configure first. This way sigs would not have to be downloaded everytime from the internet.)

    Please try :

    wget -O /var/www/fog/service/ipxe/init.xz https://fogproject.org/inits/init.xz
    wget -O /var/www/fog/service/ipxe/init.xz https://fogproject.org/inits/init_32.xz

    As I stated, I don’t know if it will still work, but the reboot and error message should be gone. (This is specific to the donate task.)

  • @george1421 OK. Thanks

  • Moderator

    @kibade I’m suspecting, no. But that question is for the developers to answer.

  • @george1421 Is the donate task meant to work for 1.3.3 as far as you know?

  • Moderator

    @kibade OK gotcha, thank you for reporting.

  • It was more of a bug report. I currently have 1.3.3 running nicely. It captures and deploys fine. I was running clamav just because it was a different AV to the one I have, might catch something the other one missed, no big deal. The donate was a curiosity as the fog team deserve something for this product, I was just exploring options. I listed it as an issue only because it was a feature, when I tried it, it didn’t work 🙂

  • Moderator

    Just an FYI, the ClamAV was suppose to be removed in the 1.3.x release since it requires AV signature updates that are not being maintained in FOG. I can’t speak about the donate function.

    More to the point what is your issue(s) (outside of what you have already stated)?

    Second, what hardware (manufacturer and model) are you trying to image. I assume since you are able to partly get clamav to launch you are getting into the fog iPXE menu.