UNSOLVED Edited undionly.kpxe now receive params: command not found

  • Senior Developer

    @jlober1981 Check out this information in the wiki: https://wiki.fogproject.org/wiki/index.php?title=IPXE#rom-o-matic.eu

    I am pretty sure you missed enabling the PARAM_CMD define. Maybe you mix things up? Using rom-o-matic to compile an iPXE binary for you there is no need to edit general.h by hand. It’s just selecting the correct options in the web interface. If you want to compile a binary directly from the official git source code you sure need to edit the header file by hand. From your description I don’t really get which way you are headed.

    As well make sure you modify the script George gave you and change x.x.x.x in the third line to exactly match your FOG server IP address!

  • Moderator

    You’ll probably have to do something similar as in this tutorial. https://forums.fogproject.org/topic/6400/usb-boot-uefi-client-into-fog-menu-harder-way

    But this one out of the box is for building ipxe.efi by hand and not undionly.kpxe. But you should be able to make the adjustments in the process.

    The only real difference is in step 3 and 4 the rest should be the same.

  • Moderator

    Just for clarity this OP has both an SCCM and FOG server on the same subnet so that caused conflicting pxe settings. The OP came up with a method using a syslinux menu to select the fog server for deployment. The FOG iPXE kernel gets booting ok, the issue is that the iPXE kernel again queries for the the next server and boot file (which currently point to the OPs syslinux setup which causes the process to break). So the suggestion I provided is to create a custom undionly.kpxe file that points directly to the fog server.

    If the pram command is not known then the quickie way of building the iPXE kernel on the rom-o-matic site probably doesn’t include the param function. We are still not dead in the waters here I think we’ll have to go the advanced route with the rom-o-matic.