SOLVED Upgrading to trunk 1.3.1 RC-2


  • I’m a little frustrated that I can’t seem to get git to work correctly, but I just don’t want to break anything on my installation.

    I’m running FOG 1.3.0 and am trying to upgrade to the latest trunk release following the current instruction set to move to trunk, but I always used svn before, so I don’t want there to be any conflicts if I do git now.

    I ran

    git clone https://github.com/FOGProject/fogproject.git /root/fogproject/
    

    and got

    destination path '/root/fogproject' already exists and is not an empty directory.
    

    which that’s where my 1.3.0 resides.

    and svn up doesn’t work anymore.

    What’s the best way from using svn before to switching to git without breaking a whole bunch of stuff? Or am I just being dumb and doing something completely stupid (rough week)?

    Thanks


  • This article has also been updated with instructions detailing how to do this:
    https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk


  • @Tom-Elliott Heyyy got it. Thanks Tom.


  • @THEMCV Then try:

    git clone https://github.com/fogproject/fogproject.git git
    cd git
    git checkout dev-branch
    cd bin
    ./installfog.sh -y
    

  • @Tom-Elliott git pull is telling me

    fatal: No remote repository specified.  Please, specify either a URL or a
    remote name from which new revisions should be fetched.
    

    But I can’t do the git clone because it already exists.


  • Seeing as /root/fogproject already exists.

    Run:

    cd /root/fogproject
    git pull
    git checkout dev-branch
    git pull
    cd bin
    ./installfog.sh -y
    

    Laugh at the simplicity.

391
Online

9.0k
Users

15.6k
Topics

145.2k
Posts