UNSOLVED Dell OptiPlex 790 and 7010 Small form factors boot to Windows Error Recovery after imaging.

  • Server
    • FOG Version: Trunk
    • OS: Suse Linux
    • Service Version: 1.2.0
    • OS:

    I have been trying to image a couple of Dell OptiPlex small form factor computers. I have been able to get to the fog screen through PXE boot and have successfully been able to upload an image once I get all the programs I want on the computer, but when I try to download that image to another small form factor I get all the way through the imaging 100% and the computer restarts but only boots to Windows Error Recovery. So it almost seems like it takes the image but is not able to boot up. I have not had any issues with the Dell 7010 normal form factor models. Any help would be much appreciated. Thanks.

  • Moderator

    @ethompson66 Thats great to hear it was just a driver. Some time down the road we can talk about having a universal image (that is sysprep’d) and injecting the model specific drivers during FOG imaging. That is what we do for our Dell fleet.

  • Yep it looks like my theory was correct there must have been a driver that was not loaded or upgraded.

    I did a clean install of Windows 7 then updated the BIOS, Chipset drivers, Video Drivers and Network Driver and then restarted the computer and booted from the onboard nic downloaded the image from fog and it worked like a charm.

  • I have an image for Dell 790 and I was able to make an image of the 7010 for both of those models the large form factors take the image but not the small form factors. I am not trying to deploy to different models.

    Before I image I run the fogprep and have never done sysprep.

    I created the image by booting to the nic to our PXE server doing a full inventory, then I log into the web interface find the computer I inventoried and select upload then I run the computer through onboard nic boot again to upload the image.

    That all works fine… When I go to take another, lets say for example small form factor 7010 and try to download that image I uploaded from another small form factor 7010 it goes through the whole imaging process and restarts the computer. But instead of booting to Windows 7 it fails then goes into Windows Error Recovery…

    Like I said it only seems to do that with the small form factor models I have imaged 790s and 7010s before but the small form factors have problems, which leads me to think maybe there are drivers that are not compatible or something like that.

  • Moderator

    Let me understand capturing and deploying to the same model computer works but deploying to a different model doesn’t?

    Are you syspreping the image?
    What is the model number of the system you are deploying to?
    How/where did you create your reference image?