Panasonic CF-54 mk2: Unable to inventory

  • Staring off, I am running v1.2.0. Isolated network install.

    Notebook SPEC
    UEFI with CSM enabled. Secure boot off.
    Intel Corre i5-6300U
    Intel I219-LM

    I am going to be getting a new batch of these notebooks and I am running into some issues.
    The mk1 series worked fine. The mk2 is kinda screwy.
    I am unable to inventory via PXE.

    Leaving the bios as UEFI, I am not able to LAN boot.
    Messing with having CSM on, no luck.

    Moving on, I changed the BIOS to not use UEFI. I can get to the main FOG splash screen and select Full inventory.
    The following is what I was able to capture before it scrolled on past everything to tell me it has an issue with inventory.

    tsc: Fast TSC calibration failed.
    usb 1-5: device descriptor read/64, error -71
    xhci_hcd 0000:00:14.0: Setup ERROR: setup context command for slot 3.
    usb 1-5: hub failed to enable device, error -22

    From here I deiced to update the bzimage and bzimage32 kernels manually.

    It seems to go further, but I still can’t inventory. I see a message rush past (shorter than the above), but I am unable to capture what it reads.

    Anyone know of any issues with this notebook? Or am I ahead of the curve here?

  • @george1421 I downloaded a copy from the kernel directory on a different PC and copied it over. They were just called bzImage and bzImage32. I will get the version in the morning and report back.

    I did run the test before I left and it did fail network. I also wasn’t able to see the mac address or IP through the menu.


    Also, running Ubuntu 14-04 LTS
    I get bzImage: x86 boot sector

    And I got the bzImage from here

    EDIT 2: Not sure why the edit from my main post vanished. Let me put that here again.

    I took a video of the newest message. From reading the blurry video, this is what I can read before the fog text logo comes up.

    mmc0: Unknown controller version (3). You may experience problems.
    usb 1-5: device descriptor read\64, error -71
    EXT4-fs (read): couldn’t mount as ext3 due to feature incompatibles
    Starting logging: OK
    Populating /dev using udev: udev[2612]: error creating spell? fd: Function not implemented

    EDIT 3: Took bzImage files and init files from a test fog machine I was messing with. 1.3.0 FOG on there. Copied the to the FOG 1.2.0 server.

    The compatibility test comes back with disk and network passing.

    Trying to register a host and I get:
    Unable to register host: Invalid MAC Address (/bin/
    Arg Passed:

    I think I am making some progress here.

  • Moderator

    When you say you updated the bzImage manually, what version did you update them to? The command file bzImage in the directory where bzImage is should tell you the kernel version. I can tell you that the intel network driver you mentioned needs a newer kernel than what was delivered with FOG 1.2.0. Also if your notebook uses a NVMe drive then you must update to FOG 1.3.0 for that support.

    When you boot in bios mode, and get into the fog menu, what do you get when you run the compatibility test. Does the disk and network adapter pass?

  • @x23piracy Nothing. I think Panasonic has some components wired internally to the board to look as USB.

    All I have plugged in is a network cable.

    On the newest bzImage/bzImage32, I thinks the xkci got resolved, I am still trying to grab what the message is being thrown before the FOG txtimage scrolls down.

    Is there a way to pause or slow down the messages?

    EDIT: Main post updated.

    Notebook Spec

    UEFI w/ CSM enabled. Secureboot Off
    NIC: Intel I219-LM

  • Which USB devices are connected when u try to image?

    Awesome Donkey 2015-08-05 11:27:55 UTC
    Correct, I’m still seeing the device descriptor read error with 4.1.4 - I experience this issue from 3.18.0 to 4.1.4.

    Kinda random, but now I’ve noticed it’s more frequent. I tested this on a new MSI Z97 MPOWER Max AC motherboard (my third >motherboard from a different manufacturer in the last 7 months) and it still happens.

    My workaround before was disabling XHCI by setting XHCI Handoff to disabled on my Gigabyte board and disabling Intel XHCI Mode on >my ASUS board and setting Legacy USB Support to Auto on both. However with the MSI board setting XHCI Handoff to disabled and >Legacy USB Support to Auto doesn’t make a difference.

    I only have three USB devices plugged in - keyboard, mouse and USB DAC. I’ve tried it with just the keyboard and mouse and I was able >to reproduce it. I also was able to reproduce it by changing keyboards (I have both a Ducky keyboard and a Razer keyboard and neither >made a difference). I haven’t tried a different mouse as I don’t have a second one, but that’ll be my next thing to try. I’m also planning on >trying a powered USB 2.0 HUB just in case there’s a lack of power causing this but I suspect this won’t make a difference as it works >every time in 3.17.8.

    I’m thinking I’ll probably have to download every RC kernel to 3.18 and test every one of them looking for a regression range.