• I’m new to the forums and relatively new to using FOG. At the company I work for we have a FOG server (0.32) set up on a VM running ubuntu (11.10) and have been able to manage four laptop images that deploy just fine. We are trying to register one of our desktop clients to upload and push it’s image to the server through PXE boot and having no luck. The desktops are Lenovo desktops running Windows 7 Pro 64bit. The error I’m getting is while the PXE boot menu is loading it gets to a “nvidiafb: unable to setup MTRR” error and the screen changes from black to green and hangs. I’m assuming its because of the nvidia graphics chipset not allowing it to display the correct settings for the fog PXE boot menu. All of the desktop’s are set up with dual monitors also. Can anyone lead me in the right direction as to what I should attempt? I’ve tried researching this problem online and through the forums with no luck and I apologize if someone with a similar problem posted in another topic. Thank you for the help!

  • I changed the kernel, and now at the menu screen I select “quick registration” and nothing happens. The only option that works is boot to HDD. Should I try a new kernel?

  • I am very much new to using FOG. I am trying to image a DELL Precission 4800 laptop, it is giving me FOG menu and when trying to register is giving me eroor message like nvidiafb: unable to setup MTRR. I have tried with the updated kernel and has not made any chage. I have tried with custom kernel; it saying that failed to register host for the following reason and after that it is saying attempting to send inventory and then no response.

    Anyone has idea?

  • Hello,

    I have the same issue as kcasper, but none of the kernels that any of you tried worked for me. 3.3.3 displayed me the same error as previous one (Unable to setup MTRR), the custom kernel made by Eric on the other topic made Kernel panic while loading, and seems to have issue with file system, it display raw as file system, and copy the whole disk (931GB while only about 50G are used).

    Anyone has idea to test? I am ready to retry with other kernels to see other error messages.

  • Ran into same problem with machines having ASUS P8Z77-V motherboard and geforce (GTX 670 ASUS GTX670-DC2-2GD5). The lenovo kernel mentioned by kcasper didn’t fix the problem but older Kernel- [url]http://sourceforge.net/projects/freeghost/files/Kernels/Kernel-[/url] seem to work.

  • Okay so I tried many different kernel updates with no luck, but with searching on the forums here another user posted a kernel that they compiled that seemed to fix the snow effect on dell and lenovo laptops. I figured why not try it to see if it would fix my issue. It worked. The topic here [url]http://fogproject.org/forum/threads/lenovo-x130e.587/#post-4426[/url] has a link to the bzImage that Eric has compiled. Thank You all for the help! Desktops and laptops are able to successfully pxeBoot and get into the fog menu to send client inventory.

  • Yes that is correct. We are able to see the fog menu and that error makes the client inventory halt about 3 errors down the list. I have not tried different Fog kernels so I will attempt some updates to the kernel and see what that yields. Thank you for the help Chad. I’ll get back to the forums if I come up with a fix/answer.

  • Moderator

    It sounds like PXE boot is working, because you are seeing the Fog menu, correct?

    What is failing is when control is transferred to the Fog kernel which tries to load and start processing whichever Fog task you have called, such as registering, imaging, etc…

    Have you tried different Fog kernels through the Kernel Updates option in the Fog server Web UI? Sometimes newer kernels work, like those based off 3.2.x or 3.3.x, but sometimes things work better going back to older kernels, such as 2.6.37 KS. Try a few and see if you get better results. If not, you can also work on compiling your own kernel and the forums are here to help either way.

  • Hey Chad thanks for the reply. We can get into the FOG menu where it begins to send the host information and then gives that error.

  • Moderator

    Do you get the main Fog Menu where you can try to register the host and then fail, or does it fail to even display the fog menu?