• Server
    • FOG Version: 1.3.0-RC-21
    • OS: debian 8
    • Service Version:
    • OS:

    Thank you for your work!
    We use a centralized virtual FOG server with 2 synology NAS for remote images.
    I created a group for remote sites and then assigned to NAS on each remote sites

    I created a new image in image management, I choose to “storage group” one of the groups assigned to the desired remote NAS

    Then assign to a host, then I start capturing the message is:

    "Failed to create tasking to Some or all
    ENS-49-034 Failed to start tasking like Capture
    Could not find this image Containing Any nodes "

    When I look in the group two storage group are assigned “default” and my group of my remote NAS

    With the RC19, I suppressed the “storage group” image the “default” group and update primary group just let the group of my remote NAS.
    starting up the task and created on the correct disk

    Is that the right way to proceed?
    Thank you

  • This is solved since the RC-28
    thank you

  • Moderator

    @hfredh This is in no way to offend, but I do not understand your translated post. Could you post again in your native language and I will see if Google gives me something better.

    But I think I understand that the synology nas did work correctly in 1.2.0. Fog 1.3.0 is a different program it should have been called FOG 2.0. There is a lot that changed between the two. The storage nodes in FOG 1.3.0 serve more functions than they did in 1.2.0. You should be able to get them to work if you enable FTP and NFS servers on the synology NAS. The ftp user must have change access to the images directory.

    With FOG 1.3.0 you can only upload from the target computer to FOG via the master node. Storage nodes are only used to send (deploy) images to the target computers.

    If you were able to delete the default group and it started to capture then you found a flaw in the FOG design. That should not have worked.

  • Thank you for your reply
    We already use the synology with version 1.2.0 it works
    but for this fonctione correctly (pout tftp) we must inquire “into the” storage nodes “in the following fields” Image Path “and” FTP Path “that exist only in the improvement of fog” trunk ".
    which lead us to this version ‘trunk’

    to version 1.3.0-RC-19 by deleting in “storage group” image the “default” group, I managed to start capturing

    Since version Version 1.3.0-RC-20, I arrived again created a capture spot, even removing the “default” group of the image.

    thank you

  • Moderator

    There is a couple of things going on here.

    1. You can only deploy from fog storage servers. Captures have to go to a full fog server.
    2. You “should” be able to use a synology NAS as a remote storage node, but it will need to be setup properly. You will need NFS and FTP setup. You will also need home directories enabled. If you intend to pxe boot at the remote locations then you will need to install tftp too. To date I have not worked with a synology nas as a remote storage server so I can’t say for absolute that it will work.

    I will have an older synology NAS coming out of service in about 2 weeks where I could test to see if its viable.

    What is your logic for using the Synology NAS as a remote deployment server vs a regular computer?