Skipping chkdsk?

  • I was digging around in the init image, trying to track down the “chkdsk” variable that seems to control this and eventually discovered that is is trying to get this setting from the web management! So, try this:

    Other Information --> Fog Settings --> General Settings --> FOG_DISABLE_CHKDSK =1.

    1 skips chkdsk, 0 runs it. Mine was set to 1 already. It seems that this is an “experimental feature” in .32.
    Let me know if that works for you. If not, I’ll go back into the init image. I think I know what to adjust now.


  • Ah, I see. I don’t use the quick image much.

    Modifying the init image is not a big deal. Just make a backup copy of the file before you start.

    I just took a quick peek. There is a fog file in /bin with a “RUN_CHKDSK” setting and some conditions. I’ll see if I can modify it and get it to never do a checkdisk. Give me a day to take a look. I won’t have a chance to try it today.


  • With FOG .32 if you were to do a quick image, it forces a check disk on restart, regardless of how the image was setup. If you were to go through and setup the machine to deploy an image from the webserver, it’ll run just fine without running check disk. The file that jdd49 made, the bypass, would be similar to doing a quick image. It does work really well, and has saved us a lot of time doing mass imaging, but due to the mass imaging, that’s why I was asked if the check disk could be removed. And quite honestly, I have no idea where to start to even look into modifying the .32 (or ,33) init file.

  • Can someone provide more details here? Chkdsk never runs after I image any systems, unless something has gone wrong.

    I generally build a Win7 image on one computer in audit mode, add all the drivers for sysprep, shrink the partition down to the lowest drive size of the computer I keep in inventory, then do a defrag and chkdsk before I sysprep and pull the image. Works all the time and across every kind of hardware I’ve tried.


  • I created registration bypass long before the option to skip check disk was availabl, from .29 You would not be able to do this without modifying init from a new version of fog to include the changes

  • Basically, by using the bypass, it’s essentially doing a quick image and if I remember right, a quick image forces a checkdisk. I don’t have a problem with it, but my job is not to replace/install computers. When we receive computers in, it’s not unheard of to have 500-800 come in at one time but can only image about 20-30 at a time. Needless to say this takes awhile and the less time it takes, the better. Hence the request made by co-workers.

  • I just tested putting a image onto a new (blank) virtual machine. It’s a WinXP image. It did not run a check disk after laying down the image. This makes me think it’s a setting in the image that you’re using.

    Also, what’s the problem with letting check disk run? We have hundreds of machines that run a check disk every night on reboot and experience no issues from that.

Log in to reply