SOLVED RC14 ... Sleeping 10 seconds

  • Can you make this mechanic introduced with RC14 manageable in FOG settings?

    I get enough blowback from clients about long boot times. Forcing another 10 seconds will not go over well.

  • there’s now yet another folder within all the installer for ipxe binaries. squeaky wheel, grease, something blah glah

  • @Wayne-Workman Yes, it needs to be 10 seconds. This was tested on backed systems and has been proven fruitful.

    The issue is some nic’s are not waking up in the time that iPXE is requesting access to the nic. This causes the ipxe system to drop directly to shell (why I have yet to figure out). I initially tried with 4 seconds and everything seemed to work a “little” better. I iterated upwards until we found a point where things worked. It was suggested to be 5-6 seconds which I switched to be 10 because of other issues that were happening.

    Like I said, I didn’t just “oh here” which is also why the message is a clear message to inform people of what is happening.

  • @Tom-Elliott said in RC14 ... Sleeping 10 seconds:

    This is embedded into the ipxe binaries to help ensure the network will boot already.

    What do you mean by “Already” ?

    And still 10 seconds is a long time, does it need to be 10 seconds? Take my building for example. Every computer in the building - about 500 of them - boot to the network first. This is to make imaging much easier for the techs of the building (me and my co-worker). This 10 second delay will delay every boot every time forever by 10 seconds - when the previous boot files without the delay were working perfectly fine. Why not have another set of files? A set with the 10 second delay, and a set without, as well as the set from 7156? They are small files. At least have a copy of these files available without delay: undionly.kpxe, undionly.kkpxe and ipxe.efi

  • I want others to understand, I didn’t just add these 10 seconds cause, “hey I like having people wait cause why the hell not?”

    This was added because there were those people getting ‘Configuring devices: and here’s a shell for you’.

    It would drop the user into a shell rather than try to get dhcp or any other items. The 10 second wait was added to ensure the nic’s had time to “wakeup” from whatever they were doing. Because of how this occurs this must be hard coded into the binaries. You all are more than welcome to building your own binaries for your situation too. Please know this addition is an attempt to improve functionality of all devices, not a jab to make people complain about wait times.

  • This was added because if not it’s causing many more issues for many more nics. This is embedded into the ipxe binaries to help ensure the network will boot already.

    Unfortunately, this particular setting is unable to be handled by the GUI. Yes I’m shoving it down people’s throats, and I don’t like it. That said, the 7156 should still work and does not have the 10 second enforcement.

  • @Tom-Elliott I agree with him. It should be a global or per-host setting - or just removed entirely.