UNSOLVED Getting PXE-EC8 error on NUC6i7KYK Skull Canyon

  • Server
    • FOG Version: 1.2.0 7887
    • OS: Fedora 23
    • Service Version: Intel NUC Kit NUC6i7KYK
    • OS: CentOS 7

    I just configured a system on a Skull Canyon NUC, and wanted to create an image. I tried PXE booting to my FOG server and received “PXE-EC8: !PXE structure was not found in UNDI driver code segment”

    It then exits and boots to the hard drive. This happens instantly, and I had to take a picture of the screen to even read the error message.

    I looked up the error, but the description didn’t really help me understand where to look, or what the solution might be. Any help would be appreciated.

  • Moderator

    @mageta52 Ok, no problem.

    The proper tcpdump filter that will show us what is going on without showing things that you shouldn’t post to an open forum is this.
    tcpdump -w output.pcap port 67 or port 68 or port 69 or port 4011
    This will record only dhcp, tftp, and dhcpProxy traffic. Start this running on the FOG server then pxe boot the target computer (on the same subnet) until the target errors out then hit ctrl-C on tcpdump and review with wireshark or post it hear for review.

  • @george1421I’ll run tcpdump on that interface tomorrow when I get in and see what happens during the PXE boot.

  • Moderator

    @mageta52 I don’t have one of the nuc’s in front of me. I seemed to recall a check box its either uefi on or off (but don’t quote me on that). And then there was a personality setting.

    If you don’t know what mode it is (I can’t tell from your last post) and your fog server and nuc are on the same subnet we can use the fog server to record the dhcp booting process and that will tell us what the client is saying during bootup.

  • @george1421 Under boot options, it lists UEFI and legacy. All of the boot devices are set under legacy mode, including the NIC.

  • Moderator

    We use the intel nucs on our campus, not the 6i but the 5i5 models.

    On the intel nucs, have you gone into the advanced firmware settings and confirmed you are in uefi or legacy(bios) mode? Also some of the nucs have a “personality” option, where you can set it for win7, win8, win10, unix make sure you have the right personality selected on the nuc. Also be sure you have the latest firmware installed on the nucs they have updates every quarter for new versions. Make sure you are up to date.

    I just looked up error EC-8

    PXE-EC8: !PXE structure was not found in UNDI driver code segment.
    The UNDI ROM image has probably been corrupted, or has not been initialized by the BIOS. This error is most often caused by one of three things:
    A .NIC image was programmed into a BIOS when a .LOM image should have been used.
    The memory allocated by the POST Memory Manager ($PMM) during PXE option ROM initialization has been corrupted or erased before PXE option ROM boot.
    The UNDI_Loader structure was not properly initialized during option ROM initialization.

    Just a stab in the dark here, maybe a undi boot kernel was sent to a uefi based system??

  • Moderator

    @mageta52 If I remember pfsense there is a field for bios (legacy) mode and that is typically undionly,kpxe and there is also a uefi field where you might puth ipxe.efi.

  • @mageta52 said in Getting PXE-EC8 error on NUC6i7KYK Skull Canyon:

    I’m assuming that the boot files under /tftpboot are the options available to me?


    There are a lot of them there, not sure if I should just start cycling through them, trying them all until one works?

    The ones ending with .efi are for UEFI systems. You said you’re working with legacy, so you’d try everything but the .efi files, and also exclude default.ipxe because that’s a service file and not a boot file.

  • I just logged into the PFSense box and was set up for undionly.kpxe, I tried switching to undionly.kkpxe but got the same error. I’m assuming that the boot files under /tftpboot are the options available to me? There are a lot of them there, not sure if I should just start cycling through them, trying them all until one works?

  • @mageta52 You might also try a firmware update on the NUC as well, it might make a difference.

    1. PFSense is handling DHCP. I’ve been using this setup for a while now and it works great.
    2. Yes I can image from other models. 90% of what we do is on an Asrock Z97E board.
    3. Legacy mode. We’ve had issues with images not restoring properly if the install was done in UEFI.

    How do I change the boot file? It seems like I’ve had to do this in the past but can’t remember what needs to be edited, or where the config file is.

    1. What is doing DHCP for your environment?
    2. Can you capture images from other models?
    3. Is the NUC in legacy mode or uEFI mode?

    If it’s in legacy mode, the first thing I’d try is a different boot file. You’re probably using undionly.kpxe I would switch that to undionly.kkpxe note the extra K. There are other boot files to try too.