Unsure if these settings in FOG are correct

  • @Tom-Elliott do appreciate all your help. My PXE boot client keeps bombing out at the TFTP bit. I have attached a pic…is there any tools to see what TFTP is not doing…??very frustrating…!
    Also its not on the screen, but when i press F11 then F8 the screen displays BD, then it bombs out.

    [0_1475756423399_IMAG1208.jpg](Uploading 100%) 0_1475756637041_IMAG1208.jpg

  • Senior Developer

    @pencils According to your pictures, you have a folder called “tftproot” and I’m fairly sure it should be “/tftpboot” (With a b, not an r).

    Yep, it’s with a b:


    Please update your folders properly and the files referencing /tftproot change to /tftpboot and I suspect you’ll have more success. While looking for this, I see that I have a couple of hard-coded references to /tftpboot which should probably use the variable name. I’ll fix that tonight (which should enable people to have their own setup as needed).

  • sorry that was my error. It is /tftproot. i have attached a few screen grabs of the different locations of the file structure. Also as i am using DNSMASQ i have attached the config file.

    0_1475748439276_IPXE folder.PNG 0_1475748446167_tftproot.PNG 0_1475749007208_dnsmasq1.PNG 0_1475749011911_dnsmasq2.PNG

  • @pencils
    Do you have a folder called tftproot or is it just a typo and you have a folder tftpboot?

    If it was a typo take a lock at these configs:

    Remove the last slash in FOG_TFTP_PXE_KERNEL_DIR setting.
    Check if the .pxe, .kpxe files in the /tftpboot are available?
    Also check if the the kernel and boot images are present in /var/www/fog/service/ipxe

    Can you please attach a screenshot of the PXE-M0F error.

  • yes. Initially i didnt have a folder at the root called /tftproot. So i manually copied it over. I also isntalled DNSMASQ. I know my PXE client is reading the config file because i made a change to the timeout for pressing F8 from 3 secs to 15. My pixxy client, then, im assuming tries to read the boot file and fails with an exit code. So i changed the config file to read the UNDIONLY.PXE, But it fails and im not sure why. The error is PXE-M0F

  • @pencils
    At first view everything seems to be correct. Do you have problems with the tftp?