• Server
    • FOG Version: 1.2
    • OS: ubuntu
    • Service Version: 4787
    • OS: Windows 7

  • Ok it’s now working fin, you can mark this topic as solved.

    So it was due to the ftp path, i couldn’t specify the correct ftp path in the fog interface 1.2.0.

    Thanks a lot for your help guys.

  • 0_1530763109245_33e20c39-f273-4851-b3f1-fedd0e4bbeed-image.png

    Got this working over the weekend with QNAP. The NFS shares are slightly different in v4.3.3 of the QNAP software on the TS-231. You don’t have to specify the full local path. Only the shared path location.

  • Ok it’s now working fin, you can mark this topic as solved.

    So it was due to the ftp path, i couldn’t specify the correct ftp path in the fog interface 1.2.0.

    Thanks a lot for your help guys.

  • Thanks
    So i updated my fog to 1.3

    I will try to upload/deploy with that storage node setting :

    0_1475484260147_NAS 1.3.PNG

    By the way, do i have to encrypt my password in the storage node ?

  • Moderator

    @Quazz I think your nfs and ftp location are differents, like that :

    ftp : ftp://your_nas/imagesfog/
    nfs : nfs://your_nas/share/CACHEDEV1_DATA/imagesfog/

    In your version of FOG you can’t specify different path for ftp and nfs; in you screenshot it’s : Image Chemin
    In the 1.3 you can specify the ftp and nfs path.

    FYI when you capture or deploy it’s the NFS server of your NAS that is mounted on the client. For the capture the move from /dev/mac_address to the destination folder is assured via FTP.

    Capture : 1-Capture via NFS --> 1-Move via FTP --> Done
    Deploy : 1-Deploy via NFS --> Done

  • @Quazz said in QNAP NAS storage:

    If it’s 14.04 or newer, would you be willing to upgrade FOG to trunk?

    Yea it’s 14.04. The 1.3 version will help me ? i’m gonna try.


  • Moderator

    @Sunks Which Ubuntu version is your server running?

    If it’s 14.04 or newer, would you be willing to upgrade FOG to trunk?

  • @Quazz I can’t add any slash, the webGUI delete automatically te last /

    My error apache is empty. I tried severals time to download image today and there is nothing


    if anyone have any others ideas…

    Thanks for the help guys 🙂

  • Moderator

    @Sunks I believe you need a trailing forward slash

    So add a / to the path on the storage node.

    Also, post apache logs if the issue persists after trying this.

  • @Quazz My storage nodes NAS


    i can add some other screenshot of my nas

    after the upload the image is right there, and sit there instead of moving.

    The service FTP is enable on my NAS (it’s in french):

  • Moderator

    @Sunks Please share a screenshot of your storage node settings.

  • How do i know the FTP path on my NAS ? And where can i specify this 2nd path on the fog GUI ?

    I tried on my NAS to manually move my image uploaded on /share/CACHE_DEV1_DATA/imagesfog/dev/<ADRESSEMAC> to /share/CACHE_DEV1_DATA/imagesfog/imagesNAS(folder specified on the GUI FOG) with this command :

    mv /share/CACHEDEV1_DATA/imagesfog/dev/001999547b85/ /share/CACHEDEV1_DATA/imagesfog/imagesnas

    and then i could download it correctly.

    I don’t rlly know how the FTP is working to create the folder imagesnas and move the image, but every permissions are allowed on my NAS, and i can correctly connect to the ftp path with the fog user i specified in the GUI interface.

  • I think we need a lot more info.

    Basic steps for NAS as a Node would be:

    Ensure FTP is enabled and you know what username and password will connect to that FTP.

    Ensure NFS is enabled for the location you need. (You will need two entries at least, one for the Main images location and one to upload the images to that must be labeled with dev.

    For example in your case, /share/CACHEDEV1_DATA/imagesfog is the “base” location. So you would need a directory structure of:


    Just creating the shares is not enough though. We have tests that happen within the init’s which are there simply to verify we have made a proper connection to the NFS.

    The way the installer automates this for you is:

    mkdir -p /share/CACHE_DEV1_DATA/imagesfog/{,dev}
    touch /share/CACHE_DEV1_DATA/imagesfog/.mntcheck
    touch /share/CACHE_DEV1_DATA/imagesfog/dev/.mntcheck
    chmod 777 -R /share/CACHE_DEV1_DATA/imagesfog

    The NFS Config should look something similar to:

    /share/CACHE_DEV1_DATA/imagesfog *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /share/CACHE_DEV1_DATA/imagesfog/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)

    Now the RC’s of FOG should allow you to customize all the fields, but you will most likely have the inability to see hardware information and/or disk usage information from the GUI as it requires web based files your QNAP will not have.

    Of relevance, most NAS systems allow you to have NFS and FTP, however they way they work is anything but straight forward. FTP, from what I’ve typically seen, is not going to be accessed by /share/CACHE_DEV1_DATA/imagesfog but will rather be accessed via /CACHE_DEV1_DATA/imagesfog (Notice we’re missing the /share part).

    To allow NAS to be imaged from you would make sure the node is configured within the GUI, but setting the FTPPath to the (most likely) /CACHE_DEV1_DATA, and the main path should still be /share/CACHE_DEV1_DATA/

    Hopefully this helps you along your journey.

  • Moderator

    @Sunks If I’m not mistaken it should show up in the Apache error log.

  • @Quazz I did chmod 777 on my QNAP sholder imagesfog and imagesfog\dev

    I tried to upload an image and then to deploy it. My task is now starting but i got an error on the computer i want to deploy, “unable to locate image store”.
    The images on my nas is still not moving to \share\CACHEDEV1_DATA\imagesfog.

    Maybe i can see ftp log error somewhere ?

  • Moderator

    @Sunks What about permissions, though? Try setting 777 to images and images/dev

  • @Quazz thanks for answering that fast 🙂

    I already tried ftp://<QNAP ADRESS>/ and connect with the user i entered under storage node info. It’s working and i can see my share folder \imagesfog\dev<mac-adress>.
    By the way, on my fog interface, the information disc is showing “failed to connect”, i guess this is bound with my problem

  • Moderator

    @Sunks Good day.

    This is a typical FTP authentication issue. Please make sure FTP on your NAS works and that the credentials match the ones entered under Storage Node info.

    FTP is used to move the images from images/dev (or your/path/here/to/images/dev) to images

  • Hello, i’ve got a problem to store my images on a QNAP NAS with FOG.

    I’m able to upload the images on my QNAP share folder \share\CACHEDEV1_DATA\imagesfog\dev\ADRESSE_MAC. But i can’t donload the image to an other computer. The images is not moving to the folder i specified in FOG interface, so FOG can’t see it to download.

    The solution might be to upgrade my fog to 1.3 ?