Fog Service causes sysprep to fail

  • I’ve been testing my lenovo m73 desktop, both with HDD and SSD. I tried updating my image (it was previously working) and it caused sysprep to fail.

    All I did was run updates for VLC, iTunes, Adobe, and the FOG service (latest version pushed out in the trunk versions). I ended up working backwards to realize whenever I image with the fog service, it fails sysprep, but whenever I imaged with no fog service, sysprep works great. I did try uninstalling/reinstalling the fog service a few times, but it still fails on sysprep with generalizing.

    Weird thing, whenever I pop in an SSD and image, it does go through even with the fog service installed… so I’m not sure what that’s about, but I figured to let you know in case that helps to understand more


  • Have you tried it with a different mechanical HDD? I’ve had hard drives fail right after chkdsk /F /V /R /X reported that there are no errors or bad sectors.

  • Awesome, thanks for the info!!

  • Moderator

    Hi @GFm
    I had the same issue in the past. The reason this is happening is that the newer revisions of the FOG client are much more efficient than the legacy client. It is basically kicking in too early. The way to fix this is to disable the service before you sysprep it pre-capture (best practice for the FOG Client). You then use the setupcomplete.cmd method shown in this Wiki Article:

    You are basically telling it to re-enable and start the FOG service after sysprep is finished.