• Hi there guys,

    i’m testing out an CMD script – Changing things in the register.
    I added my script to the snapins.
    alt text

    I think this worked good. When i add the snapin to my client , i can find the script in “C:\ProgramFiles\Fog\TMP” --> So he pushed it to the client.
    I see the task ending in a minute but nothing happened.

    When i look to Debug-File : C:\ProgramFiles\Fog\Fog.txt I see this error :

    24-6-2016 12:06 Client-Info Client Version: 0.11.2
    24-6-2016 12:06 Client-Info Client OS:      Windows
    24-6-2016 12:06 Client-Info Server Version: 7410
    24-6-2016 12:06 Middleware::Response Success
    24-6-2016 12:06 SnapinClient Snapin Found:
    24-6-2016 12:06 SnapinClient     ID: 3
    24-6-2016 12:06 SnapinClient     Name: TestScript
    24-6-2016 12:06 SnapinClient     Created: 2016-06-24 10:05:22
    24-6-2016 12:06 SnapinClient     Action: 
    24-6-2016 12:06 SnapinClient     Hide: False
    24-6-2016 12:06 SnapinClient     TimeOut: 0
    24-6-2016 12:06 SnapinClient     RunWith: cmd.exe
    24-6-2016 12:06 SnapinClient     RunWithArgs: /c
    24-6-2016 12:06 SnapinClient     File: testScript.cmd
    24-6-2016 12:06 SnapinClient     Args: 
    24-6-2016 12:06 Middleware::Communication Download:|40:2C:F4:1C:6A:72|24:77:03:04:E7:60|10:1F:74:ED:8A:3D||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&taskid=3
    24-6-2016 12:06 SnapinClient C:\Program Files\FOG\tmp\testScript.cmd
    24-6-2016 12:06 SnapinClient ERROR: Hash does not match
    24-6-2016 12:06 SnapinClient ERROR: --> Ideal: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <H1>NOT FOUND</H1>
    24-6-2016 12:06 SnapinClient ERROR: --> Actual: 0E45F1905D0487C4827013E17F7D105DA112E68238E69ABD67A5EEA9F5A60745B13738E07A0CB8444C2A11463F6C30323BF76729A7E136ECB0C11C5E148285B3
    24-6-2016 12:06 Middleware::Communication URL:|40:2C:F4:1C:6A:72|24:77:03:04:E7:60|10:1F:74:ED:8A:3D||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService&json

    What can this mean?
    Do i need to add Administrators right somehow to the script to change something in the register? Yes, How?

    Greetings Tom!

  • @Tom-Elliott

    Ok, so I changed the storage group for my snapins from my QNAP to default and now it worked.
    Thanks for the help!

  • @boeleke storing snapins to a nas won’t work nicely. This is because nas most often have their own web server operating and there is no native mechanism on them to install fog. I moved hash getting to using a a local web poll so to not saturate the network with temporary download, then scan for the hash. You could copy the GUI information on a nas or setup your local server to nfs mount the snapins location to the .201 server.

  • Moderator

    @boeleke He is looking for hash checking php file on the QNAP. It fails to verify because it fails to find the file on the QNAP. I bet if you were to put it on the main server it would work just like that.

    Perhaps an idea for the devs to make it check hash on the main server, seeing as it’s already checking in there and such anyway.

  • @Quazz

    alt text = FOGserver
    Images & Snapins are stored on a NAS (QNAP) on
    But I don’t think that is a problem because i can image correctly and the computer got the script and put it in C:\Program Files\Fog\tmp\testscript… So he can ‘download’ it from the QNAP – He just can’t execute it?..

  • Moderator

    @boeleke said in Snapin Problem:

    I’m guessing you’ll see something when you open that link.

    However, the weird part is that Apache seems to report being on instead. Even though the Service checks in at the correct location in all other circumstances…

  • @Wayne-Workman : Ok FOG is running on XenServer (Virtualization). I updated it & its now Running on version 8255 ( SVN Revision 5755). I update my server with GIT.

    Because it keeps saying 7410 in the log , i deleted the FOG client.
    When reïnstalling it – It gives some errors about a CA - Certificat. This error only goes away when i manually delete the remainig FOG directory in Program Files (Yeah there are still things in there) so it don’t unistall it completely. – Maybe something for @Tom-Elliott ?

    After deleting this directory manually I installed the fog client with the smart installer. But now I got the same error but no Client Info Server version. I can see the script in /program files/fog/tmp but again this error :

    Post Edited on 9:31:

     27-6-2016 11:26 Client-Info Client Version: 0.11.2
     27-6-2016 11:26 Client-Info Client OS:      Windows
     27-6-2016 11:26 Client-Info Server Version: 
     27-6-2016 11:26 Middleware::Response Success
     27-6-2016 11:26 SnapinClient Snapin Found:
     27-6-2016 11:26 SnapinClient     ID: 12
     27-6-2016 11:26 SnapinClient     Name: TestScript
     27-6-2016 11:26 SnapinClient     Created: 2016-06-27 11:26:29
     27-6-2016 11:26 SnapinClient     Action: reboot
     27-6-2016 11:26 SnapinClient     Hide: False
     27-6-2016 11:26 SnapinClient     TimeOut: 0
     27-6-2016 11:26 SnapinClient     RunWith: cmd.exe
     27-6-2016 11:26 SnapinClient     RunWithArgs: /c
     27-6-2016 11:26 SnapinClient     File: testScript.cmd
     27-6-2016 11:26 SnapinClient     Args: 
     27-6-2016 11:26 Middleware::Communication Download:|40:2C:F4:1C:6A:72|24:77:03:04:E7:60|10:1F:74:ED:8A:3D||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&taskid=12
     27-6-2016 11:26 SnapinClient C:\Program Files\FOG\tmp\testScript.cmd
     27-6-2016 11:26 SnapinClient ERROR: Hash does not match
     27-6-2016 11:26 SnapinClient ERROR: --> Ideal: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <H1>NOT FOUND</H1>
     27-6-2016 11:26 SnapinClient ERROR: --> Actual: 0E45F1905D0487C4827013E17F7D105DA112E68238E69ABD67A5EEA9F5A60745B13738E07A0CB8444C2A11463F6C30323BF76729A7E136ECB0C11C5E148285B3
     27-6-2016 11:26 Middleware::Communication URL:|40:2C:F4:1C:6A:72|24:77:03:04:E7:60|10:1F:74:ED:8A:3D||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService&json

  • It’s not permissions related. All snapins run as the SYSTEM user, which actually has more privilege than a local administrator account.

    @Quazz is right, it says in the log that there is a hash mis-match.

    also, in the log, it says 7410 and 0.11.2

    I’m not entirely sure how that’s possible, I’m pretty sure that 0.11.2 didn’t exist back when 7410 was pushed, Seeing as 0.11.2 was released yesterday and current trunk is almost 1,000 trunk versions ahead of 7400, I don’t think something is right.

    Is this FOG server in a VM? Did you restore a snapshot from way back? How are you updating your server, exactly?

    The thing to understand is that the new fog client and the fog backend and web interface are being developed simultaneously. Changes are made to both at the same time to make things work, fix stuff, add features, and so on. What this means is, if you don’t use the version of the fog client that the version of fog you’re using came with, things are likely to not work.

    Additionally, simply properly updating your main server to the very latest could potentially fix your issue.

  • Moderator

    Judging from the error, the snapin stopped because of an issue with the hash. I’m not sure what went wrong precisely, though.

    What revision are you on? What OS is FOG running on? Are you trying to do this in a VM?