"TFTP open timeout" Error when trying to PXE boot.

  • I’m running into this “PXE: TFTP open timeout” error when I try to pxe boot a client machine.

    My DHCP server is working because every client machine I try is getting its own IP address. I’ve restarted my TFTP server, gave everything in the /tftpboot directory 777 permissions, and disabled the firewall. The TFTP password/user name is set correctly also.

    I can ping the fog server from the client machine but I can’t ping from the server to the client. I even tried updating to the latest git version (8203). The current version I had wasn’t working either so I thought maybe an update would fix it. I was running 79** something.

    I don’t know what’s wrong. It worked fine 3 weeks ago. I stepped away from it to do something else and when I got back, I get this error on every machine I try to pxe boot into.

    I’m going through the wiki troubleshooting guide for TFTP but I can’t find the fix.

  • Just wanted to reply here, I just had the “TFTP open timeout” error at home, it ended up being a bad patch cable. Simply replacing the cable with a new one solved the issue.

  • @Wayne-Workman @ITSolutions

    Yeah…umm, I said screw it and did a wipe and fresh install on the entire thing. I can pxe boot fine now. I am however run into an image capturing issue but i’ll save that for another day or post if I can’t figure it out.

    I appreciate the the help.

  • @phil_guy said in "TFTP open timeout" Error when trying to PXE boot.:

    You wanted a picture of it or the actual file?

    The actual file, copy/paste please.

  • Testers

    @phil_guy That sounds like there maybe an issue elsewhere such as the client with a static address, or the switch doing something odd. If the fog server is the only DHCP on the network and you unplug it the client shouldn’t receive any IP at all. Can you try a different client machine?

  • @ITSolutions

    My fog server does have to 2 nics. I’m pretty sure I configured those right. I had a separate post and another fog project moderator helped me through the process and got it working perfectly.

    I really think something in that software update I did messed something up. Thats literally the only change I made in that 3 week period between it working and not working.

    So i unplugged the fog server from my local network and rebooted the client machine. When it started it back up again, it still had the same IP address and pointed back to the fog server as its DHCP server.

  • Testers

    @phil_guy said in "TFTP open timeout" Error when trying to PXE boot.:

    @ITSolutions I unplugged my fog server from the network and on my client machine it shows the DHCP server to be the fog server.

    But did you do an IPCONFIG /refresh or reboot the machine to ensure that it isn’t getting an ip with the FOG server unplugged?
    Also it sounds like you have 2 nics in the server, are you sure that everything in FOG, DHCP and TFTP are configured tot he correct NIC?

  • @ITSolutions I unplugged my fog server from the network and on my client machine it shows the DHCP server to be the fog server.

    @Quazz I have one router but my fog server doesn’t need internet access. I use it just for imaging. The fog server does get Internet through one of its NICs but thats just for browsing/convenience. I had set up the fog server to be separate from my local network to be used just for imaging.

    @Wayne Workman You wanted a picture of it or the actual file? I just ran a cat /etc/dhcp/dhcpd.conf and snapped a photo.

    Worst comes to worst, I’ll just have to do a fresh wipe and reinstall everything.

  • @phil_guy The file you uploaded is not the /etc/dhcp/dhcpd.conf file.

  • Moderator

    @phil_guy The fact that you can’t ping the client from the fog server is very strange though. I really feel like something changed in your network setup.

    Are there no routers on your network? (if there are, declare them in your DHCP file) Also, if this will be your DHCP server anyway you might want to declare a DNS server (unless it’s not needed of course).

    I can post (part of) my DHCP config if you feel like that might help, but I really doubt the issue is in your DHCP tbh.

  • Testers

    @phil_guy said in "TFTP open timeout" Error when trying to PXE boot.:

    @Quazz To my knowledge, there is no other dhcp server.

    Can you try unplugging your FOG server from the network and checking a client machine to ensure there are no other DHCP servers on the network?

  • @Quazz To my knowledge, there is no other dhcp server.

    And that link should just be a picture of whats in my dhcp config file.

  • Moderator

    @phil_guy Long shot, but there isn’t any other DHCP server on your network, right…?

    I don’t know what that link is, but it doesn’t seem to be a dhcp config file.

  • @Wayne-Workman @ITSolutions @Quazz

    I think I just installed the ISC-DHCP and start/enabled it. I didn’t need to configure it at all because at the time everything was working fine.
    I’ve also tried restarting the both the isc-dhcp and tftp-hpa service multiple times.

    The only major change I can think of that might have messed something up is when I did an update (not a manual apt-get update in the terminal, but when I turned on the machine and a window popped up telling me there are updates available for install).

    And i don’t think it’s the switch. Because if i connect a client machine directly from the fog server machine, I get the same issue.

    Here’s the output of the dhcp config file.

  • Moderator

    Quick google search seems to blame switches. I would guess some kind of network change at least.

    Can you download through TFTP of a different computer?

  • @phil_guy did you configure ISC-DHCP yourself? I’m assuming so the way you use the term.

    Just because DHCP is running and handing out IPs, that doesn’t mean it’s configured correctly for fog. Please post the configuration file: /etc/dhcp/dhcpd.conf

    Also, try to restart the tftp-hpa service.

  • @ITSolutions

    I’m running Ubuntu Server 14.04. Three weeks ago it was running fine. I could connect any client machine, it was able to get an ip address, and pxe boot. I literally just stopped and stepped away from it for three weeks. I came back because I had to image something, I figured hey this new fog server is faster than my old one, let me use this one. And thats when I came across the tftp error. I was running git version 79** something, I can’t recall.

    My fog server is isolated on its own separate network. This is being used only for imaging purposes but i have the isc-dhcp server running on it to hand out IP addresses.

  • Testers

    What OS are you using(Ubuntu, Cent…)?
    Did this occur after an update or did anything else change over the 3 weeks?
    Are there any other DHCP servers on the network?