• I just imported a couple thousand hosts to FOG and now when I go to list them all I get is:


    Oh and this is what shows in the Apache log viewer:


    Version 8159

  • @adukes40 I guess if I was more on top of my game tonight, I’d have seen the 500 page and said to look at the Apache Error logs, and I imagine we would see some errors about memory being exhausted… I’m glad you figured it out.

  • @Wayne-Workman yea basically I could search for individual hosts, but not click List all, it would just bomb to the 500 error. When I would click Membership in group mgmt, just came up with a blank white page. I don;t know why I thought about the memory limit, but figure WTH, and it turns out it worked for my case. Now that I can add to groups in mass, I will now push an Inventory task to everything so that get all updated.

  • @adukes40 Hmm so I guess your problem is not like mine, the page loads every time for me, just doesn’t have all hosts lol.

  • @Wayne-Workman I got the page to go away. all 3072 hosts now load when I click List all Hosts. Takes a few seconds, but it loads. I ended up going to to FOG Settings > General Settings > FOG_MEMORY_LIMIT. Every time I bumped it up higher the faster it loaded. Going from 128 to 512 at least let the page load. bumping it to 1024, just made it better. Testing at 2048 even better. (Memory isn’t an issue here)

    Subsequently I couldn’t add multiple members to groups because the page would never load. It now lets me browse hosts not part of a group and add them.

  • @adukes40 I think this could be related to a bug I found today - I talked to Tom about it but haven’t officially reported yet… I’ll do that now.

  • @Wayne-Workman 10mb. I copied the csv over to the local site and tried, but was still having to click upload multiple times. It seems importing them 100 at a time is making the import look better, but now sitting at 3000 hosts… I can’t click on the Lists all Hosts. Instantly goes to 500 error. I was checking it every so often. It would load closer to 2000, but now it does not.

    Also click Lists all Hosts, while remoted into a machine at the server site, instantly returns 500. I can search for them and it works, but just not list all.

  • @adukes40 What sort of link speed is between your workstation and the server?

    It’s possible the connection is being lost I guess, or the file is being sent incorrectly.

  • @Wayne-Workman Manually. I only have 2 fields. the first field in the MAC and the second is the machine name. I have dropped down to uploading 100 at a time, and seems to be cooperating better. Still a bit more than a 1000 to go.

    although I did do a machine export to verify the field order.

  • @adukes40 Did you build this file manually or did you export it from another fog server?

  • When trying to reimport back in, it looks like it timesout during the upload. I get the http 500, then i try to reupload the same file. Sometimes it takes a few tries to get them all. They finally go through. I tried breaking them down into 500 host segments, and 250 host segments. Only once has it gone through all the way doing a successful 250/250, all times it timesout.

  • You most likely have formatting issues in the import, if I had to guess.

    We can manually truncate the tables so you can try again and again until it’s correct. Be aware this will bast all the host records you have:

    use fog
    truncate table hosts;
    truncate table hostMAC;

    Also, in the future, before you do this, do a configuration save so you can go back if it gets jacked up.
    Web Interface -> FOG Configuration -> Configuration Save -> Export

    ALSO, if you are so lucky to have fogguiuser and foggui password in your .fogsettings file as proper, and have updated recently, you will find DB backups inside of /home