Fresh install/upgrade to FOG trunk gets stuck during installation

  • Hello,

    I’m in the process of rebuilding our FOG machine and am attempting to do a fresh install of the latest Trunk. I’m a novice at Linux but have been able to create a FOG machine in the past.

    I’m running Ubuntu Desktop14.04 LTS with the latest updates installed and am attempting to set up the system according to this guide: Fog on an isolated network and Upgrade to Trunk as I have done so successfully in the past. This system is on nothing more than a desktop to an unmanaged switch.

    I’ve tried a fresh install on 14.04 and 16.04 using different methods. On 14.04 I’m able to install FOG 1.2.0 without any issue; an upgrade or fresh install of fog gives this issue.

    For this particular attempt Ive fresh installed 1.2.0 and attempted to upgrade to trunk. The below screenshot is what it gets stuck at.

    0_1466177742085_Fog error.png

    During the installation, the installer get up to "Changing permissions on apache log files and does not proceed any further.

    I’ve also attached the recent error logs I could find: (I hope they upload correctly)

    Any insight on this would be greatly appreciated.



  • I have a feeling that the way I’m going about installing the latest trunk might be causing the issue.

    I’m using a Dell Optiplex 3010 as the fog sever that only has one NIC and intend to put the system on a network that has not internet connectivity.

    When I install fog 1.2.0 (which works for some reason) I’m switching between DHCP and manual Ethernet configurations throughout the process to complete the install.

    Example: I’ll set a manual Ethernet configuration of etc, start the fog installation and choose my settings, then since the install reaches out to the internet during installation I’ll switch it to DHCP to grab and install the files. When it wants me to update the schema I’ll put it back to manual to do that until the install completes.

    It’s a dumb method I know, but works for 1.2.0 and what I have.

    I’m trying the same thing for trunk and I guess this method I’m trying doesn’t work with it.

    I’ve ordered a second NIC for this 3010 and will attempt to install it without screwing with the Ethernet settings during install to see if it will proceed correctly this time.

    I’ll report back when the NIC arrives and I attempt to install Trunk again.

  • Senior Developer

    @Msobelman Why don’t the IP/subnet mask on the console and the gui display match I wonder? Something really wrong I suppose. As well the dhcpd.conf you posted is kind of mixed up… 172.31… in the subnet class definition but 192.168… for most settings within that class?!?

  • DNS isn’t required for DHCP, something about the config itself is causing DHCP to fail.

    Please post the contents of /etc/dhcp/dhcpd.conf and also give us the output of ip addr show

  • Quazz,

    I’m following this guide Fog on an Isolated Network

    My FOG computer is on nothing more than an un managed switch. I’m attempting to do the install and then remove internet connectivity to it.

    I also find it strange how I can install FOG 1.2.0 without issue, but the latest trunk doesn’t play nice with me.

  • Moderator

    @Msobelman You need to enter a DNS server (usually same as router) for DHCP to be able to start. Add it in /opt/fog/.fogsettings

    HOWEVER, it seems your server has the IP which is most commonly assigned to routers. If your router has that IP already then you’re going to have a ton of issues to get this to work.

  • I’ve done as you suggested and it still seems to hang around the same area.

    But after waiting 20 minutes it decided to let me proceed up until it failed at a different point.

    It let me proceed to update the schema which I did. and after hitting enter it fails to start the DHCP server. (check install log)

    here’s the error logs.



  • @Msobelman Its hanging at php-fpm. I’d suggest uninstalling that, reinstalling it, and restarting it. Commands:

    sudo -i
    service php5-fpm stop
    apt-get remove php5-fpm
    apt-get install php5-fpm
    service php5-fpm start
    service php5-fpm status

  • Just did a fresh install of 14.04.4 downloaded the latest updates and the latest Trunk.

    Ran the installer and the same issue is happening.

    Here’s the logs of this install.



  • I’ve tried that with the same results previously,

    But I will go ahead and reinstall as you suggest and report back.

  • on Ubuntu 14, completely skip the 1.2.0 stuff. Just download trunk and run the installer. See how that goes.

    So, reinstall Ubuntu 14 and try that.